Paint OS13

From OLPC

Jump to: navigation, search
Test Case ID Category Feature Description Prerequisite Test Description Input Data Expected Result No Of TC combination Status (Pass/Fail) Defect Id
1. Verify the navigation to the Paint Activity
PNT_P1FUN Verify user can navigate to the Paint activityPaint activity icon is available Click on the Paint icon Navigate to the Paint Activity1 Pass
1.1 Verify the Activity tab in Paint Activity
PNT_P1.1FUNVerify the features of the activity tab in Paint activityUser is in Paint activity window
  1. Click on the Activity Tab
  2. Check the features of activity tab
System should navigate to "Activity" tab and following features should be displayed
  • Name of the Activity
  • Share Option
  • Keep
  • Stop
1Pass
PNT_P1.1.1UI Verify weather Activity Name is displayed in the "search box" optionUser is in Activity tab Window. Check the activity name in the search box option "Paint Activity" should be displayed in the search box option.1Pass
PNT_P1.1.2FUN Verify the features "Share with" option of the activity tab User is in Activity tab Window. Click on the Drop down list. System should display "Private" & "My Neighborhood" and default should be "Private".1Pass
PNT_P1.1.2.1FUN Verify the functionality of "Private"User is in Activity tab Window. Click on Private option User should be able to continue the actions on paint activity without any failure.1Pass
PNT_P1.1.2.2FUN Verify the functionality of "My Neighborhood"
  1. User is in Activity tab Window
  2. OLPC Mesh connection is available.
  1. Click on My Neighborhood option
  2. Invite to the person.
  3. In the Journal top of the Paint activity keeps the mouse point send to select the person.
  4. Check whether shared person can view your actions.
Connected people could share their actions.1Fail Tickect #8228,#1863
Only neighborhood can view the paint activity icon.
PNT_P1.1.3FUN Verify the functionality of "Keep". User is in Activity tab Window. Click on Keep button. Paint Activity should not be closed. 1Pass
PNT_P1.1.4FUN Verify the functionality of "Stop" User is in Activity tab Window. Click on the stop option Paint Activity window should closed1Pass
1.2 Verify the Edit tab in Paint Activity
PNT_P1.2UI Verify the features of the edit tab in Paint activity User is in Paint activity window
  1. Click on the Edit Tab
  2. Check the features of Edit tab
System should navigate to "Edit" tab and following features should be displayed
  • Undo
  • Redo
  • Copy
  • Paste
  • Clear
1Pass
PNT_P1.2.1FUNVerify the functionality of "Undo". User is in Edit tab Window.
  1. Draw the image in window.
  2. Click the Undo button.
Whatever things do it in the window that should go back to step by step.

"Redo" button must be enable.

1Pass
PNT_P1.2.2FUN Verify the functionality of "Redo" User is in Edit tab Window.
  1. Draw the image in window.
  2. Click the Undo button.
  3. Click the Redo button.
Whatever things do it in the window that should forward back to step by step. 1Pass
PNT_P1.2.3FUN Verify the functionality of "Copy"User is in Edit tab Window.
  1. Draw the image in window.
  2. Under the Tools tab clicks the Rectangular Marquee & selects the needed area in that image.
  3. Click on the Copy option.
Which one user should select & copied it should be appearing in the frame on bottom left side. 1Pass
PNT_P1.2.4FUN Verify the functionality of "Paste". User is in Edit tab Window.
  1. Draw the image in window.
  2. Click on the Copy option.
  3. Click on the Paste button.
Whatever user copy, it should be appear in the window. 1Fail Tickect #6231
It can open in the other selected activity window.
PNT_P1.2.5FUN Verify the functionality of "Clear". User is in Edit tab Window.
  1. Draw the image in window.
  2. Click on the Clear button.
Window should be cleared. 2Pass
1.3 Verify the Tools tab in Paint Activity
PNT_P1.3UI Verify the features of the Tool tab in Paint activity. User is in Paint activity window
  1. Click on the Tools Tab
  2. Check the features of Tools tab
System should navigated to Tools tab and following features should be displayed
  • Tool Color
  • Pencil
  • Brush
  • Eraser
  • Polygon
  • Bucket
  • Rectangular Marquee
1Pass
PNT_P1.3.1UI Navigate to the (Tool Color) "Pick a color" Window. User is in Tool Tab WindowClick on the Tool color button. Verify whether the system should be popup a "Pick a color" window and following features should be displayed.
  • Outer ring
  • Inner triangle
  • Color name
  • Hue (Passion on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
  • Eyedropper
  • OK (Button)
  • Cancel (Button)
  • Close (Button)
1Pass
PNT_P1.3.1.1FUN Verify the functionality of "OK" button. User is in "Pick a Color" Window.
  1. Select the color
  2. Click "OK" button
Selected color should appear in the selected tool and appear in the "Tool tab window" & the Pick color window should be close. 1Pass
PNT_P1.3.1.2FUN Verify the functionality of "Cancel" button. User is in "Pick a Color" Window.
  1. Select the color
  2. Click "Cancel" button
Selected color should not be appearing in the selected tool & the Pick color window should close.1Pass
PNT_P1.3.1.3FUN Verify the functionality of top right hand side “Close" button. User is in "Pick a Color" Window. Click the top right hand side “Close" button. Selected color should not be appearing in the selected tool & the Pick color window should close. 1Pass
PNT_P1.3.1.4FUN Verify the functionality of "Outer ring". User is in "Pick a Color" Window.
  1. Select the color outer ring.
  2. Click "OK" button.
The color should be appearing in the selected tool and following features changes.
  • Color name (Color code)
  • Hue (Position on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
1Pass
PNT_P1.3.1.5FUN Verify the functionality of "Inner triangle" User is in "Pick a Color" Window.
  1. Select the darkness or lightness of the color using the inner triangle.
  2. Click "OK" button.
The color should be appearing in the selected tool and following features changes.
  • Color name (Color code)
  • Hue (Position on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
1Pass
PNT_P1.3.1.6FUN Verify the functionality of "Color name". User is in "Pick a Color" Window.
  1. Enter the color name or color code inside the color name text.
  2. Click "OK" button.
  • Pink
  • #FF0000
Tool appears with selected color2Pass
PNT_P1.3.1.7FUN Verify the functionality of "Eyedropper" User is in "Pick a Color" Window.
  1. Click on the Eyedropper.
  2. Select the color anywhere.
  3. Click "OK" button.
Selected color should appear in the tool.1Pass
PNT_P1.3.2FUN Verify the functionality of "Pencil" User is in Tool Tab Window
  1. Click on the Pencil.
  2. Draw the image.
Whatever the user draw with pencil, it should be appear in the Tool tab window and default the Pencil Size is 2 and Pencil Color is black. Following features should be displayed
  • Size
1Fail Tickect #1902
There is no difference in the image based on the pencil size selected.
PNT_P1.3.2.1FUN Verify the functionality of Pencil "Size". User is in Tool Tab Window.
  1. Move cursor on to the Pencil.
  2. Select the size.
  3. Select the tool color.
  4. Draw the image.
  • Size = 2
  • Size = 50
  • Color = Red
  • Color = Blue
Pencil size 50 should be changed as bigger than size 2 & Pencil color should appear selected color.4Pass
PNT_P1.3.3FUN Verify the functionality of "Brush". User is in Tool Tab Window.
  1. Click on the Brush.
  2. Draw the image.
Whatever the user draw with brush, it should be appear in the Tool tab window and default the Brush Size is 2 and Brush Color is black. Following features should be displayed.
  • Size
  • Shape
1Pass
PNT_P1.3.3.1FUN Verify the functionality of Brush "Size". User is in Tool Tab Window.
  1. Move cursor on to the Brush.
  2. Select the size.
  3. Select the tool color.
  4. Draw the image.
  • Size = 10
  • Size = 50
  • Color = Green
  • Color = Yellow
Brush size 50 should be changed as bigger than size 10 & Brush color should appear selected color.4Pass
PNT_P1.3.3.2FUN Verify the functionality of Brush "Shape". User is in Tool Tab Window.
  1. Move cursor on to the Brush.
  2. Select the shape you want
  3. Draw the image
  • Circle
  • Square
Brush should appear selected shape.2Pass
PNT_P1.3.4FUN Verify the functionality of "Eraser" User is in Tool Tab Window
  1. Click on the Eraser.
  2. Erase the image.
The image should erase in the Tool tab window. Following features should be displayed
  • Size
  • Shape
1Pass
PNT_P1.3.4.1FUN Verify the functionality of Erase "Size" User is in Tool Tab Window
  1. Move cursor on to the Eraser.
  2. Select the size.
  3. Erase the image.
  • Size = 10
  • Size = 30
Eraser size 30 should be changed as bigger than size 10 2Pass
PNT_P1.3.4.2FUN Verify the functionality of Erase "Shape" User is in Tool Tab Window
  1. Move cursor on t|o the Eraser.
  2. Select the shape you want
  3. Erase the image.
  • Circle
  • Square
Eraser should appear selected shape2Pass
PNT_P1.3.5FUN Verify the functionality of "Polygon" User is in Tool Tab Window
  1. Click on the Polygon.
  2. Select the Tools color.
  3. Draw the image.
The polygon should appear. Default size (Border) is 2. & Fill (check box) select.

Following features should be displayed.

  • Size (Border)
  • Fill Color
  • Fill (Check Box)
1Pass
PNT_P1.3.5.1FUN Verify the functionality of Polygon "Size" User is in Tool Tab Window
  1. Move cursor on to the Polygon.
  2. Select the Size (Border).
  3. Draw the image.
  • Size = 5
  • Size = 10
Polygon Size (Border) 10 should be bigger than size 5. 2Pass
PNT_P1.3.5.2FUN Verify the functionality of Polygon "Fill Color" User is in Tool Tab Window
  1. Move cursor to the Polygon.
  2. Select the Tools color.
  3. Select the Fill Color.
  4. Draw the image.
  • Fill Color = Green
  • Tool Color = Yellow
The polygon should appear with selected “Fill color” inside, selected "Tool Color" appear in the border and default the Fill check box select.2Pass
PNT_P1.3.5.3FUN Verify the functionality of Polygon "Fill" check box User is in Tool Tab Window
  1. Move cursor to the Polygon.
  2. Unselect the Fill check box.
  3. Draw the image.
Inside the image color should not appear.1Pass
PNT_P1.3.6FUN Verify the functionality of "Bucket" User is in Tool Tab Window
  1. Click on the Bucket.
  2. Select the tool color.
  3. Move to the relevant painting place and click.
The paint which we want to fill, it should be appearing in the selected area. 1Pass|
PNT_P1.3.7FUN Verify the functionality of "Rectangular Marquee" User is in Tool Tab Window
  1. Click the Rectangular Marquee.
  2. Click again the relevant place on the image.
  3. Select the cut image and move it to other relevant place.
The Rectangular Marquee tool should cut and moves the image.1Pass
1.4 Verify the Shapes tab in Paint Activity
PNT_P1.4UIVerify the features of the "Shapes tab" in Paint activity User is in Paint activity window
  1. Click on the Shape Tab
  2. Check the features of Shape tab
System should navigated to Shape tab and following features should be displayed
  • Fill Color
  • Stroke Color
  • Ellipse
  • Rectangle
  • Line
  • Polygon
  • Heart
  • Parallelogram
  • Arrow
  • Star
  • Trapezoid
  • Triangle
1Pass
PNT_P1.4.1UINavigate to the "Pick a color" Window. User is in Shapes Tab WindowClick on the Tool color button. Verify whether the system should be popup a "Pick a color" window and following features should be displayed.
  • Outer ring
  • Inner triangle
  • Color name
  • Hue (Passion on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
  • Eyedropper
  • OK (Button)
  • Cancel (Button)
  • Close (Button)
1Pass
PNT_P1.4.1.1 FUN Verify the functionality of "OK" button. User is in "Pick a Color" Window.
  1. Select the color
  2. Click "OK" button
Selected color should appear in the selected tool and appear in the "Tool tab window".The Pick color window should be close. 1Pass
PNT_P1.4.1.2 FUN Verify the functionality of "Cancel" button User is in "Pick a Color" Window.
  1. Select the color
  2. Click "Cancel" button
Selected color should not be appearing in the selected tool. The Pick color window should close. 1Pass
PNT_P1.4.1.3 FUN Verify the functionality of top right hand side “Close" button.User is in "Pick a Color" Window.
  1. Select the color
  2. Click the top right hand side “Close" button.
Selected color should not be appearing in the selected tool. The Pick color window should close.1Pass
PNT_P1.4.1.4 FUN Verify the functionality of "Outer ring".User is in "Pick a Color" Window.
  1. Select the color outer ring.
  2. Click "OK" button.
The color should be appearing in the selected tool and following features changes.
  • Color name (Color code)
  • Hue (Position on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
1Pass
PNT_P1.4.1.5 FUN Verify the functionality of "Inner triangle" User is in "Pick a Color" Window.
  1. Select the darkness or lightness of the color using the inner triangle.
  2. Click "OK" button.
The color should be appearing in the selected tool and following features changes.
  • Color name (Color code)
  • Hue (Position on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
1Pass
PNT_P1.4.1.6 FUN Verify the functionality of "Color name" User is in "Pick a Color" Window.
  1. Enter the color name or color code inside the color name text.
  2. Click "OK" button.
  • Pink
  • #FF0000
Tool appears with selected color2Pass
PNT_P1.4.1.7 FUN Verify the functionality of "Eyedropper" User is in "Pick a Color" Window.
  1. Click on the Eyedropper.
  2. Select the color anywhere.
  3. Click "OK" button.
Selected color should appear in the tool1Pass
PNT_P1.4.2 UINavigate to the "Pick a color" Window. User is in Shapes Tab WindowClick the Stroke Color. Verify whether the system should be popup a "Pick a color" window and following features should be displayed.

- Outer ring - Inner triangle - Color name

  • Hue (Poisson on the color wheel)
  • Saturation (Deepness of the color)
  • Value (Brightness of the color)
  • Red (Amount of Red light in the color)
  • Green (Amount of Green light in the color)
  • Blue (Amount of Blue light in the color)
  • Palette entry (Select Color Display)
  • Eyedropper
  • OK (Button)
  • Cancel (Button)
  • Close (Button)
1Pass
PNT_P1.4.2.1 FUNVerify the functionality of "Stroke Color". User is in Shapes Tab Window
  1. Click the Stroke Color.
  2. Select the color.
  3. Click OK.
The shape outlines appearing the selected color.1Pass
PNT_P1.4.3 FUNVerify the functionality of "Ellipse" User is in Shapes Tab Window
  1. Click on the Ellipse
  2. Draw the shape
The shape should appear with black color. Default the Fill check box select and size is 2. Following features should be displayed.
  • Size (Border)
  • Fill
1Pass
PNT_P1.4.3.1 FUNVerify the functionality of Ellipse "Size" User is in Shapes Tab Window
  1. Move cursor to the Ellipse.
  2. Select the size. (Border)
  3. Select the Fill color & stroke Color.
  4. Draw the shape
  • Size = 10
  • Size = 50
  • Fill Color = Blue
  • Stroke Color = Green
The shape should appear with selected Fill color, Stroke Color (shape border) and selected size.2Pass
PNT_P1.4.3.2 FUNVerify the functionality of Ellipse "Fill" User is in Shapes Tab Window
  1. Move cursor to the Ellipse.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the shape should be blank.1Pass
PNT_P1.4.4 FUNVerify the functionality of "Rectangle"User is in Shapes Tab Window
  1. Click on the Rectangle.
  2. Draw the shape
The shape Rectangle should appear with black color. Default the Fill check box select and size is 2. Following features should be displayed.
  • Size (Border)
  • Fill
1Pass
PNT_P1.4.4.1 FUNVerify the functionality of Rectangle "Size"User is in Shapes Tab Window
  1. Move cursor to the Rectangle.
  2. Select the size. (Border)
  3. Select the Fill color & stroke Color.
  4. Draw the shape
  • Size = 10
  • Size = 50
  • Fill Color = Blue
  • Stroke Color = Green
The shape Rectangle should appear with selected Fill color, Stroke Color (shape border) and selected size.2Pass
PNT_P1.4.4.2 FUNVerify the functionality of Rectangle "Fill"User is in Shapes Tab Window
  1. Move cursor to the Rectangle.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the shape should be blank. 1Pass
PNT_P1.4.5 FUNVerify the functionality of "Line"User is in Shapes Tab Window
  1. Click on the Line.
  2. Draw the image.
The line should appear with black color. Default size is 2.Following features should be displayed.
  • Size
1Pass
PNT_P1.4.5.1 FUNVerify the functionality of Line "Size"User is in Shapes Tab Window
  1. Move cursor to the Line.
  2. Select the size.
  3. Select the Stroke Color.
  4. Draw the line.
  • Size = 10
  • Size = 50
  • Stroke Color = Green
The line should appear with selected Stroke color & selected size.2Pass
PNT_P1.4.6 FUNVerify the functionality of "Polygon"User is in Shapes Tab Window
  1. Click on the Polygon.
  2. Draw the shape.
The shape Polygon should appear with black color. Default the Fill check box select, size is 2 and sides is 5. Following features should be displayed.
  • Size (Border)
  • Sides
  • Fill
1Pass
PNT_P1.4.6.1 FUNVerify the functionality of Polygon "Size"User is in Shapes Tab Window
  1. Move cursor to the Polygon.
  2. Select the size. (Border)
  3. Select the Fill color & Stroke Color
  4. Draw the shape.
  • Size = 10
  • Size = 25
  • Fill Color = Blue
  • Stroke Color = Green
The shape Polygon should appear with selected Fill color Stroke Color (shape border) and selected size.3Pass
PNT_P1.4.6.2 FUNVerify the functionality of Polygon "Sides"User is in Shapes Tab Window
  1. Move cursor to the Polygon.
  2. Select the Sides.
  3. Draw the shape.
  • Sides = 7
  • Sides = 10
The shape of polygon should be appearing with selected numbers of sides.2Pass
PNT_P1.4.6.3 FUNVerify the functionality of Polygon "Fill"User is in Shapes Tab Window
  1. Move cursor to the Polygon.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the shape should be blank. 1Pass
PNT_P1.4.7 FUNVerify the functionality of "Heart"User is in Shapes Tab Window
  1. Click on the Heart.
  2. Draw the shape.
The shape Heart should appear with black color. Default the Fill check box select and size is 2. Following features should be displayed.
  • Size (Border)
  • Fill
1Pass
PNT_P1.4.7.1 FUNVerify the functionality of Heart "Size"User is in Shapes Tab Window
  1. Move cursor to the Heart.
  2. Select the size. (Border)
  3. Select the Fill color & stroke Color.
  4. Draw the shape
  • Size = 10
  • Size = 30
  • Fill Color = Blue
  • Stroke Color = Green
The shape Heart should appear with selected Fill color, Stroke Color (shape border) and selected size.3Pass
PNT_P1.4.7.2 FUNVerify the functionality of Heart "Fill"User is in Shapes Tab Window
  1. Move cursor to the Heart.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the shape should be blank. 1Pass
PNT_P1.4.8 FUNVerify the functionality of "Parallelogram"User is in Shapes Tab Window
  1. Click on the Parallelogram.
  2. Draw the shape.
The shape Parallelogram should appear with black color. Default the Fill check box select and size is 2. Following features should be displayed.
  • Size (Border)
  • Fill
1Pass
PNT_P1.4.8.1 FUNVerify the functionality of Parallelogram "Size"User is in Shapes Tab Window
  1. Move cursor to the Parallelogram.
  2. Select the size. (Border)
  3. Select the Fill color & Stroke Color.
  4. Draw the shape.
  • Size = 10
  • Size = 30
  • Fill Color = Blue
  • Stroke Color = Green
The shape Parallelogram should appear with selected Fill color, Stroke Color (shape border) and selected size.3Pass
PNT_P1.4.8.2 FUNVerify the functionality of Parallelogram "Fill"User is in Shapes Tab Window
  1. Move cursor to the Parallelogram.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the Parallelogram shape should be blank. 1Pass
PNT_P1.4.9 FUNVerify the functionality of "Arrow"User is in Shapes Tab Window
  1. Click on the Arrow
  2. Draw the shape.
The shape Arrow should appear with black color. Default the Fill check box select and size is 2. Following features should be displayed.
  • Size (Border)
  • Fill
1Pass
PNT_P1.4.9.1 FUNVerify the functionality of Arrow “Size"User is in Shapes Tab Window
  1. Move cursor to the Arrow.
  2. Select the size. (Border)
  3. Select the Fill color & stroke Color.
  4. Draw the shape.
  • Size = 10
  • Size = 50
  • Fill Color = Blue
  • Stroke Color = Green
The shape Arrow should appear with selected fill color, Stroke Color (shape border) and selected size.2Pass
PNT_P1.4.9.2 FUNVerify the functionality of Arrow "Fill"User is in Shapes Tab Window
  1. Move cursor to the Arrow.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the Arrow shape should be blank. 1Pass
PNT_P1.4.10 FUNVerify the functionality of "Star"User is in Shapes Tab Window
  1. Click on the Star
  2. Draw the shape.
The shape Star should be appearing with black color. Default the Fill check box selected, points is 5and size is 2. Following features should be displayed.
  • Size (Border)
  • Points
  • Fill
1Pass
PNT_P1.4.10.1 FUNVerify the functionality of Star "Size"User is in Shapes Tab Window
  1. Move cursor to the Star.
  2. Select the size.
  3. Select the Fill color & stroke Color.
  4. Draw the shape.
  • Size = 10
  • Fill Color = Blue
  • Stroke Color = Green
The shape Star should appear with selected Fill color, Stroke Color (shape border) and selected size.2Pass
PNT_P1.4.10.2 FUNVerify the functionality of Star "Points"User is in Shapes Tab Window
  1. Move cursor to the Star.
  2. Select the Points
  3. Draw the shape.
  • Points = 7
  • Points = 10
The shape of Star should be appearing with selected numbers of points2Pass
PNT_P1.4.10.3 FUNVerify the functionality of "Star Fill"User is in Shapes Tab Window
  1. Move cursor to the Star.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the Star shape should be blank. 1Pass
PNT_P1.4.11 FUNVerify the functionality of "Trapezoid"User is in Shapes Tab Window
  1. Click on the Trapezoid.
  2. Draw the shape.
The shape Trapezoid should appear with black color Default the Fill check box select and size is 2. Following features should be displayed.
  • Size (Border)
  • Fill
1Pass
PNT_P1.4.11.1 FUNVerify the functionality of Trapezoid "Size"User is in Shapes Tab Window
  1. Move cursor to the Trapezoid.
  2. Select the size.
  3. Select the Fill color & stroke Color.
  4. Draw the shape.
  • Size = 10
  • Fill Color = Blue
  • Stroke Color = Green
The shape Trapezoid should appear with selected Fill color, Stroke Color (shape border) and selected size.2Pass
PNT_P1.4.11.2 FUNVerify the functionality of Trapezoid "Fill"User is in Shapes Tab Window
  1. Move cursor to the Trapezoid.
  2. Unselect the Fill color check box.
  3. Draw the shape.
The middle of the Trapezoid shape should be blank.1Pass
PNT_P1.4.12 FUNVerify the functionality of "Triangle"User is in Shapes Tab Window
  1. Click on the arrow, and then click on the Triangle.
  2. Select the Fill color & stroke Color.
  3. Draw the shape.
The shape Triangle should be appearing with selected Fill color and Stroke Color.1Fail Tickect #9025 , #6320
Can't change the border size.
1.5 Verify the Text tab in Paint Activity
PNT_P1.5UIVerify Verify the features of the Text tab in Paint activity User is in Paint activity window
  1. Click on the Text Tab
  2. Check the features of Text tab
System should navigated to Text tab and following features should be displayed
  • Type
  • Pick a color
1Pass
PNT_P1.5.1FUNVerify Verify the functionality of "Type"User is in Text Tab Window
  1. Click the Type.
  2. Type the Text in window
The displayed text, what should user typed.1Pass
PNT_P1.5.2FUN Verify the functionality of "Pick a color" User is in Text Tab Window
  1. Click the Pick a color.
  2. Select the color.
  3. Type the Text.
The displayed text color, what should user selected. 1Pass|
1.6 Verify the Image tab in Paint Activity
PNT_P1.6UIVerify the features of the Image tab in Paint activityUser is in Paint activity window
  1. Click on the Image Tab
  2. Check the features of Image tab
System should navigated to Image tab and following features should displayed
  • Insert
  • Rotate Left
  • Rotate Right
  • Height
  • Width
1Pass
PNT_P1.6.1FUNVerify the functionality of "Insert"User is in Image Tab Window
  1. Click on the Insert.
  2. Select the image.
The image should display.1Pass
PNT_P1.6.2FUN Verify the functionality of "Rotate Left" User is in Image Tab Window
  1. Click on the selected image.
  2. Click on the Rotate Left button.
The image should rotated in the left side way. 1Pass
PNT_P1.6.3FUN Verify the functionality of "Rotate Right" User is in Image Tab Window
  1. Click on the selected image.
  2. Click on the Rotate Right button.
The image should rotated in the Right side way. 1Pass
PNT_P1.6.4FUN Verify the functionality of "Height" User is in Image Tab WindowSelect the Height The image Height should changed 1Pass
PNT_P1.6.5FUN Verify the functionality of "Width" User is in Image Tab WindowSelect the Width Verify the image Width should changed 1Pass
1.7 Verify the Effects tab in Paint Activity
PNT_P1.7UIVerify the features of the Effects tab in Paint activity User is in Paint activity window
  1. Click on the Effects Tab
  2. Check the features of Effects tab
System should navigated to Image tab and following features should be displayed
  • Grayscale
  • Rainbow
1Pass
PNT_P1.7.1FUNVerify the functionality of "Grayscale"User is in Effects activity windowClick on the Grayscale The image should be change in to the Gray color.1Pass
PNT_P1.7.2FUN Verify the functionality of "Rainbow" User is in Effects activity window
  1. Click on the Rainbow.
  2. Draw the image
The rainbow should appear with multiple colors. Default shape is circle. Following features should be displayed.
  • Shape
  • Size
1Pass
PNT_P1.7.2.1FUN Verify the functionality of Rainbow "Shape" User is in Effects activity window
  1. Move cursor on to the Rainbow.
  2. Select the shape
  3. Draw the image.
  • circle
  • square
The selected shape of the Rainbow should display.2Pass
PNT_P1.7.2.2FUN Verify the functionality of Rainbow "Size" User is in Effects activity window
  1. Right click on the Rainbow.
  2. Select the size.
  3. Draw the image
  • Size = 5
  • Size = 10
The Rainbow size should change2Pass
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox