Jump to: navigation, search
  • Is it possible to open a xterm window in sugar? alt+shift+F11 doesn't work for me. I am using olpc-devel 207 in a real X0.
As recently noted in the B1 Release Notes, the latest builds are launching "Memphis" from alt+shift+F12 instead. Note that Memphis has bugs--it only seems to reliably launch the first time and it is not Sugarize, so you cannot run it with other activities very well, and it is very very slow. Let's hope that this is a temporary situation. --Walter 08:21, 5 January 2007 (EST)
Probably the solution is to switch to a Linux console with the 12x22 font (framebuffer console), giving a 100x40 terminal. The next-best alternative is a full-screen genuine xterm, with a big font and the scrollbar enabled, possibly with a little helper app to do any Sugar-related work related to shutdown and activity switching. Nothing else is reliable and compatible. The xterm solution may be better done with a 600x450 screen resolution (divide down by 2x) and the programmer-friendly "fixed" font. AlbertCahalan 22:37, 23 February 2007 (EST)


Easy for the tech saavy, the rest of us need help

Re: "Installing Opera on test machines is easy. From a shell, run these commands as root"

Sorry to say I don't have a clue what the above means. I have no idea how to do it, but using Opera might mean I could possibly figure out how on earth to use the browser.

You can login as root by typing "su - root" at the command prompt, without the quotes.

Please try the revised instructions here.


Well, for the most part the above means that you'll want to be fairly knowledgeable with Linux administration before you attempt it. Here's the gist, though:

  1. Open up a terminal window
  2. cd /tmp
  3. wget
  4. rpm -vi opera-9.12-20070122.10-static-qt.i386-en.rpm

At this point you should be able to run the browser.

  1. wget
  2. cd /usr/share/activities
  3. tar xvzf /tmp/opera-activity.tar.gz

Now restart sugar (ctl-alt-erase) and look for the Opera logo on your activity bar. Thither 07:04, 21 December 2007 (EST)

As of Feb. 1 2008, I'm getting a 404 Not Found on the wget ... opera-activity.tar.gz command. Sarah Elkins

Oh, brother, if that's the quick start, I'm in trouble.

(new anon user) Do I understand correctly - open up terminal app and type that series of commands? Sounds simple enough. Whatcan go wrong that one would need to be a poweruser before attempting - warn me before I start -and is this only for test machines? Will this work on the lean green machine itself? I've never used linux before, but I am a former computer programmer, so the above doesn't scare me - I just wonder if something can go wrong I won't know how to fix.

Unable to get newest versions of java and flash to run

This may be expected since the build was frozen in time, but could not get Adobe Flash 9.0.115 to run properly in Opera, but 9.0.48 works fine. The same goes for java: jre-6u3 did not work (seems that it flashed up the applets briefly but then I was unable to interact with them), downgraded to jre1.5.0_13 and it works great. Should the page be updated to reflect this (or is this just my personal experience)? --bbb

This is a second confirmation that jre-6u3 does not work on the olpc. I wasted a half day on this. Will someone please update the Java and/or Opera pages to reflect this?

Java works, sort of

I got Java jre1.5.0_13 working under Opera (and Firefox), but there are two problems:

1) Font sizes can't be adjusted.

2) I can't figure out a way to make it usable with multiple windows.

The font sizes are tiny. I tried making adjustments in two ways (opera:config#UserPrefs|ForceDPI and setting the minimum font size in Tools->Preferences->Advanced->Fonts), but these only work with the browser, and not Java applets. I could buy reading glasses, but there's gotta be a better way....

But more importantly, pop-up windows take up the whole screen and can't be closed. I play bridge on yahoo, and there are buttons to look at the last trick, the last hand, the score, etc. When I click on one of these, it brings up the screen correctly, but it takes up the whole window and can't be closed. Once you view one of these screens, you can never get back to it again.

On a Windows desktop, these appear in small windows that can be viewed side-by-side, and can be closed with the Windows "X" button.

Does anyone have any ideas to solve these problems? If you go to and "Watch" a game, you can click on these buttons. Is there a better place to ask this question? Thanks in advance!

SOLUTION: The root of the problem #2 is that Sugar doesn't really have a window manager, so all windows appear full-size; there is no way to place windows side-by-side. So the solution is to use a different window manager, like the native X Windows manager. This may not be for the faint of heart... Unix experience helps.

Use Ctrl+Alt+F1 (where F1 is the first of the leftmost group of 4 keys on the top row, the neighborhood key) to get to a shell window. Login as root (no password). Then issue 'telinit 3' to kill Sugar. For some unknown reason (to me), this never returns, so use Ctrl+Alt+F2 (F2 is the group key) to get to another shell window. Login and enter 'startx' to start X11. X Windows should start; I got an xterm and xclock window. Now windows can be resized and placed side-by-side, closed, etc.


I've used Opera since the early days when the program could fit on a 3.5" floppy, so I was very happy to hear that the browser would run on the XO. The problem is that I'm a complete Linux illiterate, so if there are any problems, I have no idea where things are going wrong.

I had no problems getting opera downloaded. When I tried Step #2. install Opera using rpm:, I get the following error message:

bash: sudo: command not found

Have I typed something incorrectly? BlankVerse 17:04, 23 December 2007 (EST)

I don't have a Build 650 machine--maybe you need to use su instead on that software release. Try:
rpm -iv opera...

Neither approach using either sudo or su work on my machine. My machine does recognize the sudo command at all and the listed use of su generates a syntax error (double checked the typing). What's next?

I had to use
su -

for it to work, not just


--Tomhannen 16:09, 26 December 2007 (EST)

Setting Preference is unclear in these directions

It seems that there are a few skip steps in Setting the preferences. For instance, when you select the lower Edit button, you have to pick which Opera you're editing - UNIX or Standard. Then when you're adding the New shortcuts, you must select Application first - I think. I muddle through it and it seems to be working...


For you guys and the Firefox2 folk - add the word "browser" to the keywords on this wikipage. I gather that many newer-to-open-source folks like me are having trouble finding these instructions because we don't know the NAMES of the possible alternative browsers.

Also suggest you specify at the top of the Installing the Opera activity section whether you need to be in terminal with Su or not.User:KayTi

Also suggest you consider adding these alternate instructions for getting the Activity listed in the Activity list, courtesy of user: Grampa from the forums (copied with permission):

If you install the "activity" files, you will be able to start Opera by clicking an icon in the Sugar menu frame. To do this, go back to terminal and type the following commands:

cd /usr/share/activities wget tar xvzf opera-activity.tar.gz

You MAY need to get into supervisor mode in order for these commands to work. Do this by entering the command "su" before entering the "wget" command above, and "exit to leave supervisor mode, i.e.,

cd /usr/share/activies su wget http:// ... tar ... exit

Then close Terminal and reboot Sugar by pressing alt-ctrl-erase.

These instructions are slightly different from those on the wiki page I referenced earlier. The wiki instructions tell you to make a new Activities directory under /home/olpc. I tried that, and it didn't work for me, but installing the activity in /usr/share/activities worked fine.

I mentioned a bug with the toolbar settings on the main page. I found the problem to be that the /etc/opera6rc file overrides all conflicting user prefs. So by removing the lines that are not neccesary for use on the XO (the DPI line is a must but the font might not be).

Updating Opera??

Opera has been running fine for me after installing using these instructions. It's telling me that there is a new version. How do you update Opera? Is there an apt-get type of command to do this? Or do I download the new version and try to replace the old one using the same instructions?

Thanks, Ian


Ok, figured that out. I'll add an update section at the end? Ian 20080509

Update section merged with install section truy 20090823

Uninstalling Opera?

I could not find instructions for uninstalling it. How is this done safely? Thanks, Norm 13:13, 27 July 2008 (UTC)

(Background: After I did olpc-update from 656 to 703 on G1G1, Opera stopped working: it just displays a blank screen. It still doesn't work after Ian's update above. So, I would like to get rid of it completely, so that I can re-install it from scratch. Norm )

SOLUTION: I had the same problem after installing Opera on a 703 build and then updating it to 711. Opera didn't start. This command:

rpm -e opera 

... removed Opera but there was still a blank screen after reinstalling and starting it. Therefore I removed the hidden Opera folders. You have to be logged in as root to remove those folders:

su -

First the one in the home directory:

rm -rf /home/olpc/.opera

and then the folder in /usr/lib/

rm -rf /usr/lib/opera

Once this was removed I reinstalled Opera and Opera launched as it has before. NOTE: Just to be clear - first remove Opera with the rpm command and then the additional folders as described.

- Sašo Borovnik 18:34, 22 August 2008 (CET)

Does not save preferences, requires EULA agreement upon opening every time

I'm running Opera 9.6, installed as an activity as per this page, and while the GUI is great and the loading times are wonderful, I have to agree to the EULA every time it runs, and it refuses to save any preferences. Also, there are always several items in the frame for additional tabs and downloads and whatnot, cluttering the frame of my XO and slowing things down noticeably. Could it be that i installed the wrong version somehow? Apparently there is a newer version, but Sugar is not one of the available versions of Linux, and even if I did download the file, I'd have no idea what to do with it, especially since everything downloads to a temp directory anyway (Opera doesn't have access to any "normal" directories). Please advise,

Eccomi 20:07, 27 December 2008 (UTC)

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
OLPC wiki