Talk:Release notes/11.2.0


Jump to: navigation, search

874 on sd card on XO-1

The new F14 versions of the OS are space hogs on t he XO-1. So, I had the bright idea of trying to install on an SD card, so that there was more work space and space to add a swap.

I tried several paths with no luck.

1) I tried downloading the lzma from /xo-1/os/official/latest and expand this to a 4GB card. I figured that this would be the nearest equivalent to the instructions in 'OS images for USB disks'. I ran into multiple errors in trying to extract this archive.

2) I then tried to load the SD card with an earlier bz2 image archive that supports ext3. The most recent one I found was 767. This extracted successfully, and the XO will boot into it.

3) With this installed I then tried to do a olpc-update to update from 767 to 874. The script dies because the SD ext3 image does not have a /versions/running directory. This behavior occurs either with online or from a usb image.

It would seem that the idea of putting a modern image on a SD card would be a good way to extend the usability the original XOs. Documenting a way of doing it would be a good idea.

Rmyers 22:55, 3 August 2011 (UTC)

I had no trouble with the extraction of the lzma archive, but the filesystem was not bootable. From memory, to olpc-update from 767 to 874 you must first olpc-update to 802, then 860, then 874. After doing that it is likely you'll have the same filesystem configuration as I did when I extracted the lzma archive, and so I expect it will not boot. Perhaps you might instead use the built-in flash memory for the operating system and your SD card as home directory? --Quozl 02:14, 4 August 2011 (UTC).
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
OLPC wiki