Builds 496-541 Notes

From OLPC

Revision as of 04:03, 26 March 2008 by Cjl (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Build 541

  • Doesn't see USB stick in the Journal. You must remove any .olpc.store files and directories for this to work.


- Zack


Build 540, RC for Trial-2

Smoke Results - Good:

  • Sugar loaded properly on 2 out of 3. One of them is experiencing the infinite loop described in build 539 below.
  • Two laptops got on the school mesh, were able to browse the internet and shared an Abiword doc.
  • I was able to resume the abiword doc from the journal.
  • I shared photos between two laptops.
  • I connected directly to an open Access Point and browsed the web.
  • Can't test item 6 on the smoke test unless I get into an environment without a school server.

End Smoke Results

  • Can't get image from clipboard into an abiword doc.
  • I can use CTL-C and CTL-V to copy and paste text across activities (like Abiword to Chat), but I can't drop and drag these items from the clipboard.
  • Too many things wake the laptop up from suspend. I pushed the suspend button on a laptop that was plugged in as well as one running only on battery. After about a minute or two they both resumed themselves.
  • I pushed the suspend and resume button many times (at least 10) on two laptops and they consistently suspended and resumed properly (a B3 and a B4). The gamepad buttons do not put it into suspend. So right now we are too agressive about coming out of suspend -- but only the lid close and button press are putting it into suspend. Need more data to make any conclusions.
  • I spoke too soon (above) -- both my laptops stopped coming out of resume after a few more tries, bug 2426.


Build 539


- Zack


- Luya Tshimbalanga

Build 537

Build 536

Build 535

  • Build 535 change log
  • Resumed activities aren't creating an icon in the mesh view when shared.
  • Kicked out of shared activities improperly.
  • Keyboard keys aren't always resuming from suspend on B4.
  • Resume icon in journal is broken.
  • No scrollbar in Journal when viewing USB sticks in journal.
  • The Changelog indicates that Paint should have Copy functionality, but it does not.
  • Some Chat activities are automatically making a shared activity icon in the mesh view of the XO that created it, but their sharing status defaults to Private. This happens consistently if the XO cannot complete the "Connecting..." step, which is understandable, but it happens at other points too. In some other cases, the Sharing status defaulted to My Neighborhood properly.
  • Chat activities that were never shared show up in the Journal with a normal Chat icon. Those that were shared show up with a Read icon.
  • On one B3 I encountered a snag where the laptop completely refused to suspend. Power button wouldn't work, and closing the lid didn't do anything either.
  • If I share a Write, News Reader or Connect activity with "My Neighborhood," I can't change it back to Private.
  • Trying to share with "My Neighborhood" for Paint and Browse does nothing.
  • Etoys isn't making a journal entry anymore (again).
  • Opening shared Newsreader activities doesn't seem to share anything; it's as though the user who joined has his own newsreader activity.
  • Videos are not being shared in a shared Record activity.
  • The "Invite" option has been removed from user context menus in the mesh view.

Build 532

  • Build 532 Change Log
  • Was able to pass all but step 6 of the smoke test.
  • Cannot use copy in a shared Write activity.
  • Context menu for user in a shared activity doesn't stay open.
  • Rollovers for XOs in neighborhood view are getting cut off.
  • Being unable to resume from suspend on B3/4s has become a very significant problem. Very frequently on the B4 I am using, when I try to resume using a key on the keyboard, the XO's screen will turn fully dark and can not be resumed by any means. Sometimes, it will turn fully dark and can only be resumed by the power button. I haven't encountered problems resuming with the power button on the B4 except in that instance, but the B3 still cannot resume via the power button.
  • B2s are still losing control of the cursor and keyboard upon resume.
  • I tried connecting to the mesh and, unlike in other recent builds, the exterior of the mesh icon started blinking and the mesh icon in my Home view turned blue. However, I was still unable to browse the web.
  • Between #1935 and #2412, the neighborhood view is getting really crowded. Icons are beginning to overlap again.
  • Write does not share automatically when opened from Neighborhood view.
  • Downloaded files are taking a long time to appear on the clipboard. Also, if they are canceled, every journal entry says that they were downloaded, even though they weren't.
  • Etoys is finally making a journal entry.

Build 530


Networking

Presence

Journal

Record

- Zack

Build 528

528 ChangeLog

Smoke Test - looks good; this might be a good RC4:

  • Boots up (you need to use the new Autoreinstallation_image process to get the activation to work properly).
  • Connected to local mesh with a B2 and a couple of B4s - they ran Abiword, Connect4, and Chat
  • Journal can resume and search is working better, but it seems you need to go in and out of the journal once or twice before all the searching, detail view, and renaming works.
  • I had some problems connecting to my WEP enabled access point.
  • I suspect the xo may not be scanning channels for a local mesh. I couldn't get an XO to connect to a local mesh created by another XO, which was connected to an AP.
  • I wanted to create a paint picture and add it to an abiword, but I can't figure out how to do that. More later.
  • B2 machines don't come out of suspend properly. I used the suspend/resume button and when I resumed the touchpad and keyboard don't work (this will need to be pretty high priority since the machines can go into suspend on their own).

-Kim

Build 525

525 ChangeLog

  • I wasn't able to activate using copy-nand. This is intended, I think?
  • Wasn't able to activate using the old autoreinstallation method, but once I tried the new one, the XO was able to boot just fine.
  • I did run into a bit of trouble with autoreinstallation - if you used copy-nand first, it does successfully install the build, so when you try to do autoreinstallation it will say you already have the latest build and think it's finished.
* It is normal because the autoreinstallation checks if the build number is lower than the recent version. - Luya Tshimbalanga 
  • Pressing the power button on the B4 didn't suspend.
  • Recent builds had been borderline-usable on B2s, but it's insanely slow on them again.
  • On B2, there is occasional freezing of sugar interface.

Camera

  • Camera is still badly render on B2 machine. I think it would be nice to recheck build 406.15 and even build 430 have better rendering.

Build 518

518 ChangeLog

  • B2 report: Sugar takes a long time to load. The screen will stay black for a while. - Luya Tshimbalanga

Build 517

  • PDFs don't open from the clipbaord (but do from the Journal)
  • Mesh did not connect between laptops (away from any access points)
  • Real Video didn't launch from Journal (Helix player not integrated with Journal?)
  • One of two machines did not suspend with lid closed
  • missing STOP icon in browser
  • search doesn't work in the Journal
  • Changing the label (in the detail view of the Journal) very slow
  • CAMERA Still blurred and screen goes out of right colors when camera activity is on, on a B2-1. -Rowen/ wenmi
  • White blur on screen when suspended by power button -Rowen / wenmi

Activity Details 517

Build 515, RC3

515 ChangeLog

Smoke results: passed all tests 1-5; not able to test 6.

  • This one should have the developer's console back and the Journal dates corrected.
  • B4 is not shutting off the display and backlight when suspended. The B2 suspended, but with the backlight and display still on, but the screen at least faded to white. With the B4, the screen does not change at all.
  • XOs only see themselves clustered around shared activities in the mesh view.
  • Content indexing in Journal is supposed to be fixed, but the search feature still doesn't work. Sorting by activity works fine.
    • There is a bug with metadata in the journal that's been fixed in jhbuild but it not yet in build 515, makes the load and save in TamTam fail.
      • The bug is still there in 517...
  • At one point, when in a chat session, the XOs stopped seeing each other on the mesh. For one of them, messages just didn't go through. However, for the other, it sent the message "Kim-B2" has left the chat - but the B2's messages were still able to reach the B4, albeit with a white, nameless XO icon attached rather than the normal icon. See #2090 for more specific info and logs.
  • Perhaps related to the above problem of losing communication between XOs when collaborating - I had one XO share a Connect activity and another XO join it. While both XO's appeared on each other's mesh view, the XO that shared never detected that the second XO joined. In the console, each XO is unable to ping each other. However, they still display each other on the mesh view.
  • XOs aren't seeing each other as much in the mesh compared to 514. They also appear and drop off randomly, even among two who are sitting right next to each other.
  • Shared activity icons sometimes still get stuck on the mesh view after everyone has left them.
  • Undo/Redo and Copy/Paste do not work in a shared Write activity. Is this intended to prevent the complexities that arise from two users, or are these supposed to be functional?
  • CAMERA Still blurred and screen goes out of right colors when camera activity is on, on a B2-1. -Rowen/ wenmi
    • Camera colors still screwed up on B1 as well. --gnu
  • Keyboard and Touchpad will freeze after B2 switched to suspend mode and an user resumed it. Rebooting the machine will restore their functionality until B2 suspends. #2230 - Luya Tshimbalanga
  • B1 does not suspend when lid closed. --gnu
  • B1 suspends OK on power button, screen gradually fades. But keyboard doesn't break it out of suspend. --gnu
  • B1 when resumed from suspend with power button, touchpad doesn't work. However, keyboard works (CTRL-ALT-F1), and you can type. Using the touchpad from the F1 screen, produces this message rapidly while touching the pad: "psmouse.c: PenTablet at isa0060/serio1/input0 lost sync at byte 1". I got about twenty such messages, with timing ticks from 88.315121 to 88.867698. --gnu


Record

Chat

Connect

Presence

- Zack


- gnu

Build 513/514

513 Change Log
514 Change Log

  • Bottom half of screen goes blank in Neighborhood view on B2 machines.
  • "Joined the chat" messages in Chat don't display user's name or color.
  • XOs in a shared activity are not always displayed in the frame.
  • In Chat, users in the activity are not displaying properly in the frame. In one instance, the frame did not even show the XO's own icon.
  • XOs are now able to find plenty of other XOs and display them on the mesh view, even after rebooting (!)
    • Is this bug #2214? --CScott 16:23, 16 July 2007 (EDT)
    • Was more of an update to indicate a fix to #1955, but I suppose it presents a new problem of its own as #2214 indicates.
  • Collaboration in Write works now.
  • Browse does not have a default page. When opened you just get a blank screen, and aren't directed to Google. Has no problems loading pages once told to, though.
  • XOs are more consistent about connecting to the mesh, but still take ~2 minutes after booting.
  • Clipboard selections are no longer all treated like downloads.
  • Mesh connectivity indicator is now accurate.
  • There doesn't appear to be a way to start a new game in Connect once a player has won.
  • Activities now appear to properly fall off the mesh when no one is using them, but only on other XO's screens - NOT on the screen of the XO that created and shared the activity.
  • Frame toggle key works again.

Build 511

ChangeLog 508
ChangeLog 510
ChangeLog 511

  • Laptops suspend right after boot. When you first boot this build you can get all the way to the sugar home view, but then within a minute, the system switches graphics mode and goes into suspend. It goes in and out of suspend, but if you start up some activities you may be able to work/test for a while.

==> NOTE: to turn off power manager, open a console window and type: /etc/init.d/ohmd stop

  • I was not able to get the XO MPP to work as it had in 502. With 511, I connected one XO to an infrastructure AP and was able to browse; and then booted a second XO and it could never connect to the first one's mesh. In 502 the second XO could browse the web through the Mesh to the first XO.
  • Laptops shutdown if adapter is added or removed.
  • With two laptops that have no connectivity to a school mesh or AP, they were able to see each other in the neighborhood mesh. When trying to share an abiword doc, I could see the 'Write Activity' in the neighborhood mesh view, but the text was not available, Bug #2183. If you click on the 'Write Activity' from the neighborhood mesh, you get a new document. IF you click from the journal, you get the saved doc.

- kim

  • CAMERA ON B2-1 doesn't get enough color. Very slow and it hangs. -ROWEN
  • When the sugar interface resumes, the cursor of the touchpad froze. The test was done from the XO B2.

- Luya

Build 505

ChangeLog 504
ChangeLog 505

  • This build is missing some pieces for proper IP connectivity. Do not use it for AP or mesh testing. Build 502 was better. This build is good for looking at activities.

- Kim

- John


  • Can't open things from the clipboard. I have tried (new) paint and write activities.
  • New paint does not have startup notification (throbbing the icon in the donut)

- Cameron

Build 502

Change Log

  • I was able to open two XOs on the train and they came up and saw each other in their neighborhood mesh views! There were no servers or access points anywhere in the vicinity. I was not able to share any activity, but they did see each other.
  • I was able to connect one XO to my home WEP AP; after it was up and running with a good connection to the internet, I booted the second XO, and it connected to the local mesh. It made sure it did NOT connect to the AP, but only to the local mesh and it was able to get to the internet through the first XO!
  • Next we have to make the collaboration work...

- Kim

  • Journal entries are visible again.
  • XOs can never detect any access points.
  • 1950 is still at large - been an issue for a while now.

- John

  • Still no feed back on Record mode bug 2101
  • Font corruption appears to be fixed bug 1837
  • can't see my AP so I can't test the Browse bugs
  • new login UI (nickname/color)
  • esc key does not close any apps still
  • paint still does not stop bug 2105
  • Frame button does nothing
  • Looks like Record still breaks after viewing a video bug 2106
  • additionally trying to take photo hangs the activity

-Cameron

- Zack

Build 499

Change Log

  • Journal is not displaying any entries.
  • XOs are constantly losing the ability to access the internet and then gaining it again.
  • Web is not displaying webpages properly. Sections that are supposed to be white don't fill the window completely.
  • The mesh connection indicator in home view now sometimes works, and the icons in neighborhood view sometimes blink properly when working, but they still don't a lot of the time. In fact, now, instead of saying that I'm not connected when I am (as was the case in #1950, the bigger problem is it saying that I am connected when I'm not. It may be the case that the mesh network status is changing so frequently that the XO is constantly playing catchup and never actually displaying the current state.
  • In Browse, the icon for the "Stop" button in the Browse tab is broken.

- John

  • At olpc I connected to a mesh network that really had no internet connectivity - so I can't ping or browse. Dan suggested this might be the case of an XO that was connected to the internet and then lost its connectivity; but is still advertising a mesh. All of us here will connect to that -- and we can see a few other XOs, but we won't get to the internet if that mesh is not connected. I will write up a few bugs on this.
  • Clicking on the infrastructure AP worked, updated my laptop IP address, and I was able to get to the internet that way.

- Kim

  • Still no labels on the login screen
  • The following eye is kinda creepy in Record
  • I can't tell which mode I am in, Video or Photo bug 2101, fixed in v14 of Record
  • Font in toolbar tabs change color randomly, I have seen mixed black and white, and green bug 2102 marked as a dup of bug 1837
  • Progress bar in Browse obscures the location url bug 2103
  • web pages with flash content have serious rendering issues bug 2104
  • paint activity will not close bug 2105

- Cameron

- Zack

Build 496

Change Log

  • Has new kernel, including almost all of our current work, including suspend/resume, up to date libertas driver, 2.6.22 kernel, etc. Still lacking:
    • frame buffer driver patch for dcon control, ergo dpms/screen saver broken
  • X server is FC7 based, but:
  • B2 cannot get on the mesh.
  • The icon for closing activities is broken.
  • New Journal icon to address #1962.
  • Battery indicator now displays properly.
  • Even worse performance problems on B2 than usual. B2 takes ~5 minutes to boot, and sometimes lags severely or hangs indefinitely as soon as the Sugar UI loads - completely unusable.
  • Connect sometimes desyncs player turns.

- John + Jim

- Zack

  • "My Name" and "My Color" don't appear on B4s.

- C-Scott

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox