Builds 681-702 Notes

From OLPC

Revision as of 16:58, 31 July 2008 by Kimquirk (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Build 702 Q2D14

Release notes are being built at OLPC Update.1 Software Release Notes.

pretest

  1. Update from 656 : took 25 minutes over media lab wireless from the Garden.
  2. Firmware update, Q2C26d --> Q2D14 : is taking a very very long time. after a few min, talked to Mitch; there's a quirk with the machine; trying a new MP.

starting over

  1. update from 656 : started at 21:45, done 22:06 (21 min)
  2. firmware is already at Q2d14a (was accidentally left near richard smith for more than 15s)

pretest take 2

for a spanish machine (es_ur).

  1. update from build 700 : olpc-update over wifi started at 21:58, wireless cut out. done in <5 min.

smoketest

I only made it partway through the smoketest. NTS: we should break this test into a few "fifteen-minute" tests.

boot

  • comes up at normal speed. on first load of my home view, however, on one of the two machines I didn't get a frame. I left the view and returned, and the frame was there.

base system

  • sugar-control-panel doesn't work from the root shell; it requires that you be in sugar. This isn't quite clear from the documentation, should be release-noted.
  • when I change my colors after removing my sugar info, the old work shows up under my old colors in the journal, and new work shows up under the new colors. It would be useful to have some confirmation that these were still activities started by me - so some text that indicates the user that started a joined activity.

power

  • After booting with half power, I let the machine power down until it was red, then plugged it back in. After an our of charging, it says "battery fully charged" but shows graphically a battery with only ~10% charge.

network

  • initial association with a network was fast. I had spotty connectivity with the media lab from 1CC. Eventually, after successfully transferring ~100MB of data, I was reassociated with mesh 1.
  • scholserver: when I associated with the mesh, I automatically found the local school server, from which I was also able to reach the internet.
    However, I was not able to see the schoolserver main page via the browser link, getting an "unable to determine IP address from host name for schoolserver" error. [this is an XS bug, not an XO bug (care to explain why you think so ? There are no known XS bugs about this, and no reason to suspect it doesn't work... --Wad 15:19, 14 April 2008 (EDT))]

collaboration

untested

customization

untested

activities

  • library/browse : navigation and localized bundles are localized; the start page is not. downloading new bundles works, and installs them automatically.
    • there were problems with the default bundle index pages; reported and fixed in 704.
  • library updates : reindexing the library should be done from the sugar terminal, not the virtual terminal. From the virtual terminal, on a system which has a non-ascii UTF-8 bundlename, you get an encoding error. The virtual terminal has LANG=C which leads to a utf-8 transcoding error when it concatenates the bundle name with the path. see [1].
  • removing bundles from the library by deleting them from the Journal works.
  • sugar activity-bar :
  • l10n : sugar bar titles are unlocalized for Acoustic Tape Measure, Memorize, News Reader, Log Viewer, Analyze, and Implode.
  • updating activities : not tested.

Build 699

Release notes are being built here: OLPC Update.1 Software Release Notes


The results from Michael and Yani (smoke test):

Customization:

  • We saw a bug today where the customization process would freeze when installing large .xo bundles like tamtamedit.

There is a workaround in customization-2, which was recently sent by mstone.

  • Read wasnt included in the Mexico customization. It has been added in customization-2
  • Michael managed to update activities/content bundles through the browser
  • Customization key wont install if the activities or library directories had already been created as root. This wont apply to freshly reflashed builds.


Activities:

  • Couldnt add feed to news reader. Clicking "+"/dropdown on the feeds tab didnt do anything
  • The contents of a USB key didnt show in the journal. So couldnt install activity bundles from the USB through the journal.
  • Could copy images to the clipboard through record+browse+paint. They were successfully opened in paint and pasted in write!


Collaboration

  • Activities were reliably sharing between 2 XOs in the same School server mesh, and also in simple mesh. This was tested with write/distance/chat/memorize
  • Some XOs were connected to APs, while still running salut in channel 6.

These could very reliably exchange presence info(XOs showed in meshview/received activity invitations/joined public activities) with each other and also with the ones connected to the SS in channel 6. However, no application traffic was able to be shared. This was tested in many activites including write/chat/pippy/connect and others. These XOs had different msh0 ip subnets(one was SS,msh0=172.18.x.x, other was AP,msh0=169.254.x.x). Perhaps this explains why the traffic data wasnt sent? But again, presence traffic was shared fine.

  • Some times when joining a Chat the activity wasnt responding. Keystrokes were shown int he edit box.

The log displayed : "groupadd: group 10019 exists Creating mailbox file: File exists". The bug wasnt consistent though Seemed identical to 6499

  • We couldn't manage to make read share, although didnt test extensively. Perhaps this is still related to 6483.


Network

  • WEP/WPA initially worked fine and were tested several times. However after some time no XOs could connect to the WPA/olpc. The icon also disappeared in one of the XOs. Perhaps smth was wrong with the AP.
  • Disabling salut(6299) was working fine. Salut + Avahi traffic were successfully disabled for some minutes when receiving a public ip.
  • Only one telepathy-salut crash was seen. It seemed that 6310 was fixed. More testing needs to be done here.
  • Also I didnt manage to reproduce the xmas-tree effect(5501). I wasnt aware that the new telepathy-salut was attempting to fix it. This is good news!
  • Last but not least: The inhibit-idle-suspend flag stops the XO from suspending automatically.

I was under the impression that a suspended XO will wake with MDNS packets. However, I removed the inhibit-idle-suspend flag and suspended for 15min. When resumed, all the XOs were failed in avahi. It seems that MDNS packets didnt wake it. Are there different rules for resuming from automatic suspend vs resuming from manual suspend? This needs to be further looked into.

Build 697

  • Only chat, browse, write, record, and paint show up in the activities bar. Nor will activities from other applications resume from the journal. They appear to have been disassociated. - Herbert 16:00, 7 March 2008 (EST)

Build 695 (2008-02-28)

  • Record activity takes ~10 seconds to begin recording video, after suspend/resume (bug #4255) - Ghopper 22:30, 2 March 2008 (EST)

Build 693 Q2D13

  • Still having problems with sharing read and write. One time I was able to successfully share a pdf via Read between two laptops running 693; but then I couldn't repeat that even after rebooting both laptops. Perhaps with a smaller pdf.
  • Sharing Write continues to crash when you open other activities (such as record)

One Hour Test:

  • Boot up after upgrade via olpc-upgrade upgrade.1-693 on non-writeprotected laptops. [NOTE: on C1 or B4 laptops I think you have to have a UUID and a SN, and perhaps other items, in the mfg-data or the laptop will not boot the un-signed OS; I havent' figured out all the details]
  • Individual activities open up and close down properly: Chat, Browse, Write, Record
  • Even when Read refuses to share, and the mesh neighborhood view stops reporting on shared activities; chat continues to share properly.


I turned off both security and suspend (rm /etc/olpc-security; touch /etc/ohm/inhibit-suspend); and used simple mesh only:

  • After a reboot; Sharing is much more reliable. I shared photos, write docs, Browse links, added pictures to write docs, and the measure and chat shared properly. I still can't repeatably share a large pdf. It might be the size of the pdf.

Kimquirk 16:53, 17 February 2008 (EST)

Build 691 Q2D13

  • Using olpc-update to upgrade from 690 to 691 - I could not connect to a WPA access point. I deleted the '/home/olpc/.sugar/default/nm/network.cfg' file; rebooted and it worked. 6370
  • For WEP or WPA, the access point must be set to channel 1, 6, or 11 for the XO to connect.(I have 691 working with WPA on channel 2)
  • Trac #6046: XO is slow after upgrade. Update.1 builds contain a time synchronization mechanism, which may leave the font cache in the 'future'. Until real time catches up, fontconfig is unhappy.

One Hour Test:

  • Boot up after upgrade was good; open AP, WPA (after above work around), and school server mesh all worked.
  • Record, Write, Journal, Browse all opened up with good basic functionality
  • olpc-update candidate-691
    • 1st XO, 650 -> 691, failure return code 1 (twice two different files), re-update again, finally complete no errors
      could of been in low battery state, was less than 20% left. after plug-in, booted fine, did auto-reset of OFW. works ok.
    • 2nd XO, joyride 1643 -> 691, /691-Errors but appears to be fine.
  • Problem copying a photo to a write doc - 6405
  • Problem when sharing a document; try to add a photo and write crashes - 6407

Build 690 Q2D10 (RC1)

  • Can't connect to WEP, #6123; maybe a work around if you create the networks.config file by hand.
  • Suspend is occurring at in-appropriate times, like when trying to rotate the screen or open an activity, #6235
  • USB drive might not be recognized in Journal; the workaround is to remove olpc.store from the USB drive. (#6269) --Chihyu 11:43, 30 January 2008 (EST)
  • Battery light problem with q2d10 (#6227); q2d10a fixes this. --Chihyu 11:47, 30 January 2008 (EST)

Build 689 (Exclusively for Mongolia?)

Smoke test results

Tested on a MP machine with firmware Q2D08a.

  • When Write is launched, the cursor turns into a horizontal arrow, but this does not affect editing, and one can get rid of it by moving the cursor around.
  • Suspend/Resume doesn't seem to work, see #5976
  • not fully localized in Spanish (#5968)
  • not tested: filling up journal

Build 687 (not quite RC1)

Smoke test results

Tested on a MP machine with firmware Q2D09.

  • Either something wrong with the firmware, or with the activities (#6187):
    • Write is broken. If Record Activity is open, the cursor in Write turns into a horizontal arrow, and one cannot type anything in the work area. Hitting Alt-1 cannot take a screen shot; instead, it adds multiple "Write Activity" entries to the Journal. If Write is the only activity that's open, the cursor still turns into a horizontal arrow, but one should be able to type in the work area and get rid of the horizontal arrow by moving the mouse around. #6164
    • If Record is open, one will also have trouble typing in the text field in Journal. Other key presses (Home /Mesh/Neighborhood view, toggle frames, Alt-tab) will not be acted upon, either.
  • It takes around 10 seconds to share a Write activity between two machines (same build, connected to the same school server mesh).
  • Buddy disappears while sharing an activity with another XO (same build, connected to the same school server mesh). #6169
  • Net bible can be installed and read, but the "download completed" message cannot be closed in the browser.
  • not fully localized in Spanish (#5968)
  • not tested: filling up journal

Build 684

Smoke test results

Tested on a MP machine with firmware Q2D08a.

  • olpc-netstatus error #5925
  • not fully localized in Spanish (#5968)
  • not tested: filling up the journal

Build 681

Smoke test results

Tested on a MP machine with firmware Q2D08a.

  • coping clipboard image to Journal creates 2 additional journal entries for "Terminal activity"
  • online ogg file sounds choppy, local ogg file sounds fine
  • not tested: installing activity bundle and library bundle, filling up the journal
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox