Old Joyride Builds

From OLPC

Revision as of 20:56, 31 August 2008 by Skierpage (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Contents

Build Joyride 2128

Please note that all activities running on the machines tested were upgraded via olpc-update from the 708 release candidate, and don't have joyride-specific activities yet because the activity updater isn't finished yet -- activity-specific issues may be related to that.

Measure does not display properly; the menus on the top of the screen and the scrollbars on the right edge of the screen display properly but the area where the waveform would be is a blank grey color.

indeedy, filed ticket #7467 for this -DanielDrake 19:42, 9 July 2008 (UTC)

Pippy do not start up.

this is ticket #5608 and ticket #3488, you just need to update to Pippy-22 -DanielDrake 17:58, 9 July 2008 (UTC)

TamTamJam does not start up.

this is because of ticket #7466

Record records and plays back audio, but does not appear to save photos or videos that are recorded; they don't appear in the journal or in the bottom part of the Record interface to be played back.

this is ticket #6850, please update to Record-55 and note the known issues -DanielDrake 17:58, 9 July 2008 (UTC)

Images in the clipboard will not paste to a Write document, nor could one be pasted using the Image menu in Write.

confirmed, ticket #7468 -DanielDrake 20:00, 9 July 2008 (UTC)

Browse was unable to download and install .xo and .xol files.

yeppers, this is ticket #7427 - you need Browse-92 or newer -DanielDrake 15:11, 10 July 2008 (UTC)

The two XOs being tested (CSN74902E58 and CSN74400075) could not find each other on either simple mesh on the same channel, or when on an AP with a schoolserver (schoolserver.media.mit.edu).

This is ticket #7319 and ticket #7457 --morgs 08:03, 10 July 2008 (UTC)

Build joyride 2026

All three TamTams don't start up on both machines. Firmware Q2D16, machines CSN74801BDF and CSN74804BE8. #7243

Attaching an external USB mouse (either wired or wireless) makes XO absolutely frozen after ~ 5+ minutes. Power to the mouse goes off. The only way to shut the machine down is to hold a power button for at least 5 sec. Reproducible bug, checked several times with 2 XOs. Firmware Q2D16, machines CSN74801BDF and CSN74804BE8. #7298

Build Joyride 1537

Smoke test results

Tested on a MP machine (clean installed) with firmware Q2D08a.

  • could not set the timezone using sugar-control-panel command #5819.
  • had to manually loadkeys to get the correct Spanish key map in the console.
  • sharing activities only worked within the same build.
  • sudoku.activity.xo was still claimed by etoys; couldn't be installed from Browse either.
  • had to manually load the content bundle (#5840); clicking on the .xol file from Browse did not make the library content accessible from Browse.
  • Journal had trouble showing the USB icon when a USB drive was plugged in. (The USB drive could be accessed from the console. Although commands like cp could be run in the console to "copy" the files to the USB drive, once the USB drive was unplugged, the files were NOT in the USB drive.)
  • Browse could not open items in the USB drive that were created by another XO: videos, images, urls.
  • olpc-netstatus error #5925
  • not tested: filling up the journal

Build Joyride 1520

Smoke test results

Tested on a B4 system with a clean install to 1516 (Autoreinstallation + square button cheat code) then olpc-update to reach 1520.

  • Could not test Installing an Activity Bundle from the web due to known IPv6 issues with laptop.org
  • Could not test Installing a library bundle due to known IPv6 issues with laptop.org
  • Wireless was very broken in 1516 but seems to be working well now, but I suspect establishing the initial connection to the mesh is not quite as reliable as ship2.2 (needs further testing)
  • Issues encountered:
  • As a first-time joyride user the whole experience is much nicer than ship2.2

-DanielDrake 10:24, 9 January 2008 (EST)

Build Joyride 1489

1 Hour Smoke Test Results

Tested with 3 machines:

  • Machine 1: olpc-update --usb from build 653
  • Machine 2: olpc-update (net) from build 653
  • Machine 3: clean install (usb)

1. testing connection types

This occurred on all 3 machines:

  • all machines were connected to the school server, but when running olpc-netstatus, the following appeared
 /usr/bin/olpc-netstatus: line 47: ifconfig: command not found
 /usr/bin/olpc-netstatus: line 55: ifconfig: command not found
 /usr/bin/olpc-netstatus: line 117: iwconfig: command not found
 /usr/bin/olpc-netstatus: line 37: iwconfig: command not found
 /usr/bin/olpc-netstatus: line 37: iwconfig: command not found

==> (KQ) please add a bug since this worked fine before security was turned on. ==> ticket #5846 --chihyu


2. network test

This only occurred 4 out of 5 trials on Machine 3 -- perhaps RF was weak or interfered?

  • after booting up, the machine tried to connect to mesh network (channels 1, 6, and 11) but failed, and ended up not connected to any access point.

==> (KQ) There are 2 bugs here; they might both be in trac already: 1) not able to connect to school server consistently; 2) losing WLAN circle after inability to connect to anything. ==> ticket #5847, ticket #5848 --chihyu

3. loading content bundle

This occurred on all 3 machines:

  • bible-en.xol could be downloaded, and the entry showed up in the left column when launching Browse
  • when clicking on the net bible, the browser showed
 File Not Found
 The file /home/olpc/Library/bible-en/bundle_index.html cannot be found. Please check the location and try again.
  • wonder if there will be new bundle for joyride builds; see ticket #5840 for details

4. Implode activity

Machine 3 worked fine. This occurred on Machine 1 and Machine 2:

  • the Implode icon was flashing in the donut for about 1 minute, and disappeared automatically. never able to play the game.

==> (KQ) This looks like a bug due to a difference between a cleaninstall and an upgrade. If it occurs with other activities, it is a serious bug. ==> ticket #5851 --chihyu


5. playing .ogg files

  • local .ogg files: choppy on Machine 1 and Machine 2, no problem on Machine 3
  • online .ogg files: stuck on Machine 1 (only played for 1 sec), choppy on Machine 2, no problem on Machine 3

==> (KQ) Another difference between upgraded versus cleaninstall machines?? Please add a bug. ==> ticket 5852 --chihyu


6. suspend/resume due to cover close

This only occurred 3 out of 5 trials on Machine 3:

  • after re-opening the laptop, could wake up the machine by pressing the mouse button, but the cursor wouldn't move
  • had to reboot to resolve the problem

==> (KQ) Need many more suspend/resume test cases and please write up bugs for everything. Please include whether the laptop is MP (all HW changes).


7. Filling up the Journal

has NOT been tested

Build Joyride 1408

1 Hour Smoke Test Results

  • Record doesn't load (permissions problem) trac ticket 5448
  • Library Pages didn't install properly
  • All other tests went fine.

Build Joyride 1395

No activities launch

Some activities launch fine, but several (e.g. Browse, Record) are not working, due to known missing Sugar libs. Ben 15:38, 10 December 2007 (EST)

Build Joyride 1372

1 Hour Smoke Test

  • Wireless
    • Insecure: Good
    • WEP: Good
    • WPA: Good
    • WPA2: Broken
    • Mesh and Collab: Untested

All other tests passed.

Build Joyride 348 - 357

WIRELESS BROKEN

  • as of joyride 348, a new wireless firmware was put in, which is broken
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox