Talk:Ejabberd Configuration

From OLPC

Revision as of 08:11, 5 March 2008 by Morgs (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

When I try following the instructions:

 You must perform this step by logging in to ejabberd's web admin interface, or your XOs will never see any buddies.
 We have a patch to allow the creation of a group that contains all Online users 
 with the @online@ keyword. It works similarly to the @all@ keywords. To set up 
 the 'Online' group, log in as your ejabberd's administrative user on the web admin   
 interface at http://yourserver:5280/admin/ and select Virtual Hosts, then your 
 server hostname, then Shared Roster. Add a group called Everybody with the following settings:
   * Name: Online
   * Members: @online@
   * Displayed Groups: Online 

The web interface tells me that @online@ is "Bad Format"

Ericvh 21:15, 8 January 2008 (EST)

This suggests you don't have the shared_roster_online.patch applied. Which version of ejabberd are you running?

RobertMcQueen 11:11, 9 January 2008 (GMT)

I was working off of the SVN version, so I thought I didn't need the patches. I was wrong. It seems happy now. Ericvh 20:35, 9 January 2008 (EST)

Close but not quite working

I'm running the ejabberd-2.x RPM package. After configuring the server as described in this article, I was able to observe that all olpc clients created accounts on the server. However, the clients could not see each other in the neighborhood view. I then edited the Shared Roster Group "Everybody" and changed the "Displayed Groups" setting from "Online" to "Everybody". The clients instantly began to see each other. I was able to restart Sugar multiple times on each client and observe the corresponding icon on the other clients disappear and then reappear when Sugar initialized. This seems to work 100% reliably. I'm not sure if this is a typo in the wiki article or a peculiarity of ejabberd-2.x.

However, shared activities are not working. When a client shares an activity, that client's icon is repositioned on other neighborhood views, but no activity icon appears. Is there another setting that is needed?

Adk0212 21:15, 21 January 2008 (EST)

Failed legacy authentication

I know this has been seen before, a bug was posted (5675). The bug was closed without explanation, though.

Trying to run the server under ubuntu 7.10 gutsy gibbon. All the steps worked, checked out the trunk source, applied the patches, grabbed the config, made the mods, started the server, registered a user to be the admin, applied the shared roster data.

The log returns "Failed legacy authentication for big-md5-number@felix.mraiow.com/Telepathy"

Has anyone else seen this and managed to kill it? Perhaps I have an out-of-date library? Co149 03:52, 28 January 2008 (EST)

I haven't seen that problem, but see my walkthrough at Installing_ejabberd for Ubuntu 7.10 - using the newly-released ejabberd 2.0.0. I see that #5675 was closed by the person who logged it, so they must have fixed the problem. Let me know (via my Talk page or email on my User page) if you still have a problem and we can look into it.--morgs 03:11, 5 March 2008 (EST)

ejabberd web admin password?

It says "log in as your ejabberd's administrative user on the web admin

interface at http://yourserver:5280/admin/".

When I do so, it prompts me for a username and password. I enter the admin username that I set up with '{acl, admin, {user, "<username>", "localhost"}}.' What do I use for the password?

Actually, never mind. Something else you have to do:

jabberdctl register <username> <hostname> <password>

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox