Talk:Git

From OLPC

Revision as of 09:33, 20 March 2008 by CharlesMerriam (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search

Help!

I'm having two problems with git which are not critical but very annoying. I'm on ubuntu feisty and everything relevant is installed by apt-get

1. The core.editor config option is not working. I hate vi, could live with vim, but for such simple stuff prefer pico. Here is the config file from my .git directory:

[core]
       repositoryformatversion = 0
       filemode = true
       editor = "/usr/bin/pico"
[user]
       name = homunq
       email = asdfasdfasdf

Suggestion: Try setting GIT_EDITOR, VISUAL or EDITOR in environment, in that order. Depending on the version of git you got, one of them must work. git-config core.editor is relatively recent invention (1.5.3-rc3). Better yet - just upgrade your git.

2. My .gitignore (*.pyc and *.bak) is not working. I've tried putting it both in my project directory (idlydevelop) and in the .git subdirectory. It is added and committed to the repository too, not that that should make any difference.

Suggestion: another place is .git/info/exclude, but it actually works in .gitignore here (it is recursive, and has no problems with CR/LF line endings)

Any help would be appreciated. Thanks, Homunq 01:45, 5 September 2007 (EDT)

You are not alone....

Many people will find GIT to be eating time during development on the XO. For one example, look at Mike Fletcher's blog.

It's nice to see others fighting with it as well. Nice web interface though. CharlesMerriam 15:45, 10 March 2008 (EDT)

Update it...

Well, I got sidetracked and updated the page with a lot more information aimed at new users.

I removed the draft tag.

I really should have time for development if I just stop editing the wiki. CharlesMerriam 05:33, 20 March 2008 (EDT)

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox