Tests/Calculate

From OLPC

< Tests
Revision as of 05:20, 17 November 2008 by Skierpage (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search
It has been suggested that this article or section be merged with Tests/Activity/Calculate. (Discuss)

Contents

Start the calculate activity

Actions

  1. Start the calculate activity by clicking the icon for it in the home view.

Verify:

  • A calculate icon is added to the activity ring on the home screen.
  • The calculate icon throbs to indicate the activity starting up.
  • That the calculate activity starts properly.


Use Copy/Paste/Cut

Actions

  1. Type something into the main window of the calculator.
  2. Click the Edit tab.
  3. Select what you just typed, and press the copy button.
  4. Click somewhere in the main window, and press the paste button.
  5. Select some other section of text, and press the cut button.
  6. Click somewhere in the main window, and press the paste button.

Verify

  • When you click the Edit tab, the Copy, Paste, and Cut buttons come up at the top of the screen.
  • When you press paste the first time, whatever text you copied is pasted in that place.
  • When you press cut, the text you selected disappears from the window.
  • When you press paste the second time, the text that was cut appears where your cursor is.


Use Algebra Features

Actions

  1. Click the Algebra tab.
  2. Click in order: a number, the square button, the enter button.
  3. Click in order: the sqrt button, a number, the enter button.
  4. Click in order: the exp button, the ln button, a number, the enter button.
  5. Click in order: a number (preferably low), the fac button, the enter button.

Verify

  • The square of the first number is returned.
  • The square root of the second number is returned.
  • The the third number is returned.
  • The factorial of the fourth number is returned.

NOTE: Either do tests with small enough numbers that you can do the math in your head, or use another calculator to check the answers.


Use Trig Features

Actions

  1. Click on the format tab, and click the deg/rad button until it shows rad.
  2. Click on the Trigonometr tab.
  3. Click in order: the sin button, a number (preferable to use something like pi/2), the enter button.
  4. Click in order: the acos button, zero, the enter button. Then, divide the answer by pi. (click divide to get the previous result with a divide symbol)
  5. Click in order: the sinh button, a number, the enter button.
  6. Click on the Format tab, and click the deg/rad button once. (should show deg)
  7. Click on the Trigonometr tab.
  8. Click in order: the cos button, a number (e.g. 45), the enter button.


Verify

  • The deg/rad button appears when the Format tab is clicked.
  • The trigonometric functions buttons appear when the Trigonometr tab is clicked.
  • The sin, acos, sinh, and cos functions all yield the correct relults.
  • The deg/rad button changes the trig functions from working in radians to degrees and back.

NOTE: Either do tests with numbers with which you can do the math in your head, or use another calculator to check the answers.


Use Boolean Features

Actions

  1. Click on the Boolean tab.
  2. Click in order: either 1 or 0, the and button, either 1 or 0, the enter button.
  3. Click in order: either 1 or 0, the or button, either 1 or 0, the enter button.
  4. Click in order: either 1 or 0, the xor button, either 1 or 0, the enter button.
  5. Click in order: a number, the eq button, a number (can be same as first), the enter button.
  6. Click in order: a number, the neq button, a number (can be same as first), the enter button.

Verify

  • The boolean function buttons appear when the Boolean tab is clicked.
  • The outcomes of the boolean functions is correct.


Check Constants

Actions

  1. Click the Constants tab.
  2. Click the pi button and then enter.
  3. Click the e button and then enter.

Verify

  • Clicking the Constants tab brings up the constants buttons.
  • The values for pi and e are correct.

Use help Feature

Actions

  1. Type help(index) in the main window, and hit enter.
  2. Type help(plot) in the main window, and hit enter.
  3. Press the up button twice, so that help(index) is in the window again, and hit enter.
  4. Type help(exp) in the main window, and hit enter.

Verify

  • Entering help(index) brings up the index of all the help topics.
  • Entering help(plot) brings up the help article on plotting.
  • Pressing the up arrow allows you to re-enter past commands.
  • Entering help(exp) brings up the help article for exponentiating.


Create and Use Variables

Actions

  1. Type apples in the Label: window.
  2. Type 5 in the main window, and hit enter.
  3. Type oranges in the Label: window.
  4. Type 5 in the main window, and hit enter.
  5. Type apples=oranges in the main window, and hit enter.

Verify

  • After entering apples and 5, the screen to the right shows apples equaling 5.
  • After entering oranges and 5, the screen to the right shows oranges equaling 5.
  • After entering apples=oranges, the screen should say that it's true.


Plot a Function

Actions

  1. Type plot(x^2,x=-4..5) in the main window, and hit enter.

Verify

  • A graph of the function f(x)=x^2 is generated.
  • The graph's range (values of x) is from -4 to 5.


Quit the activity

Actions

  1. Click the Activity tab.
  2. Click the X in the top right corner.

Verify

  • Clicking the Activity tab brings up the activity options, including the close button.
  • That the activity closes properly.
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox
In other languages