Wifi Troubleshooting Guide

From OLPC

Revision as of 03:46, 12 February 2014 by Quozl (Talk | contribs)
(diff) ← Older revision | Current revision (diff) | Newer revision → (diff)
Jump to: navigation, search
This page is part of the XO Support FAQ.     Support Index | Print This Page
http://laptop.org/manualSupport FAQhttp://forum.laptop.orgOther support
community support pages

Contents

Is your network name visible?

After the laptop starts up, the Neighborhood View should show a circle for each network. Move the mouse over each to see the network name. If your network name is not shown, then perhaps:

  • you have a hidden network;
Is your network hidden? You cannot connect to a hidden network in Sugar. You can switch to Gnome to connect, and then switch back to Sugar. Some deployment teams have added hidden network support, contact Sugar Labs.
  • you hit our bug: and networks appear very slowly;
OLPC OS 13.2.0 and earlier don't show networks quickly enough, especially when there are many hidden networks or XO-1 laptops nearby. Call your deployment team to get it fixed, or see 12757 for details and a fix from OLPC.
  • your operating system is too old;
Is your network on another channel other than 1, 6 or 11)? For some very old operating system releases, only these channels are scanned. Try upgrading. Try changing your network to one of these channels and check if you can connect to it.
  • your network is restricted to certain MAC addresses;
Does your network have a white list of MAC addresses? To learn the MAC address of your XO laptop, go to Terminal, then type ifconfig. If your network is restricted to a white list of MAC addresses, add your laptop to the list.

Why can't the XO browse when connected?

Symptom: I can connect, but I cannot browse/search any pages.

Most likely, the XO has failed to receive DNS information from your internet access point. If this is the case, you would be able to access the Internet for sites named directly with IP addresses but not their common names. In other words, http://209.85.133.18/ would work but http://www.google.com/ would not.

Verify what the XO has received (from the Internet access point) for DNS information by using the Browse activity and looking at this URL:

 file://localhost/etc/resolv.conf

This page should show the IP address of the DNS server assigned by the Internet access point. If there isn't an IP address on this page, or if the IP address assigned is wrong, this would account for the behavior you're seeing.

If there is no IP address, or the address is wrong, you'll need to determine why the Internet access point is failing to supply one, but this is likely to be misconfiguration of the access point.

What common wireless symptoms do users report?

  • I cannot connect to a network from the network neighbourhood view. (The symptom is usually a flashing circle icon where the rim of the circle never turns white—this indicates the XO is trying to connect, but the connection fails.)
  • I associate but I have no connectivity; or I cannot access the Internet from the browser in my XO.
  • The password window disappears, the network starts blinking and after some time, the password window is displayed again.

How to test the antenna?

The antenna can be broken by dropping or too much rotating. Sometimes it can look fine but still be broken inside. A broken antenna may stop internet, or may restrict it to work only right next to an access point of a network. See Antenna testing for how to test the antenna.

What information is needed to help diagnose wireless problems?

If you are experiencing problems with wireless connectivity, here is a list of information that you should provide your friends and OLPC community, so they can help you in the diagnosis of the wireless problems.

  • The access point/router brand, model, version, and firmware version (ideally).
  • The security configuration of your wireless home system. Some access points will be open (security disabled) by default. If you configured it to be secure, you should gather this information; the type of security, and whether it works from another computer.
  • The description of the problem.

Other useful information you should consider adding to your description:

  • Do you see the network in the mesh view?
  • Have you previously successfully connected to this network from an XO?
  • Can you connect to the network from another non-XO laptop?
  • Is the network displayed as protected (a lock badge appears), or as open in the mesh view? Is it consistent to the Access Point's configuration?
  • When you click on the network circle does it:
    • start blinking and after some time stop, without connecting? (no external white circle)
    • prompt for a window with:
      • a menu for "Encryption type" only
      • a menu for "Key type" and another for "Association Type"
  • In case you have a secured network, what happens after you type in a passphase or a key?
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox