Talk:F11 for XO-1

From OLPC

Jump to: navigation, search

Contents

Interesting How To...

Not sure I'm up to doing it/ taking it on. but nice to know it's available for keeping those with older hardware in the loop...

I've been calling the XO 1.5 a Fat XO in the Mac tradition, same form factor / box, but different... Maybe Prodigy XO? It's same kid size, but smarter ;-/

danceswithcars 16:53, 14 July 2009 (UTC)


git checkout xo-1 FAILS, no joy ;-( ...

danceswithcars 17:42, 14 July 2009 (UTC)

more specifically, fails in the following way:

git checkout xo-1
fatal: Not a git repository (or any of the parent directories): .git

danceswithcars 23:19, 14 July 2009 (UTC)


Still Didn't Work ...

I've not figured out Git. The commands listed on main page didn't work for me... same error. Tried Perl6. Rakudo, proto and november (wiki in P6) with git and no success either. Long learning curve...

danceswithcars 10:26, 24 July 2009 (UTC)

My XO-1 Bites the Dust

Ok, so I've been having touchpad problems since I got it, but a mouse workaround fixes that.

Then the camera not working, ok, I don't show record, the crowd pleaser, use Speak and the microphone app measure? instead...

But then the screen stops working (weird behavior, was blank restarting fixed, now dark line/bars and looks like shorting out, maybe a smell too?), then it's toast...

And the G1G1 program is not running, I'm probably a little light on the tech for doing an alpha (though would want it, run school server software, and show to LUG members, across users groups like Perl Mongers, mini demos, etc... and beta boards of Fat XO-1.5 are a ways away...

SO IT SEVERELY LIMITS WHAT ONE CAN DO WHEN YOU CAN'T GET THE HARDWARE, LIKE ANY OTHER MACHINE... And wastes my years of experience with the project (albeit mostly user, and OLPCLearningClub user group)...

Not sure if I'm going to be able to get them from lending / pool...

Ebay sounds risky... Netbook Bakeoff (OLPCLearningClub comparing netbooks) makes me wonder which one, though not a good comparison...

danceswithcars 10:26, 24 July 2009 (UTC)

XO-1.5 software will not fit on XO-1.0???

How much will fit on a smaller Footprint?

If the XO-1.5 is 2x the machine that the XO-1 is (memory, processing power, etc), then what software will one have to leave out in order to get it to fit and work on a more limited initial machine??

danceswithcars 10:34, 24 July 2009 (UTC)

Work starting

After some discussion on support-gang@ a working solution is:

 git checkout --track -b xo-1 origin/xo-1

Cheerfully proving everything I already believe about git.

snip out old dependency trouble

Fixed now - git pull and try again
git reset --hard HEAD
git pull
make ...

PS - you don't need the --track option any more unless you've changed the defaults.

MartinDengler 03:02, 17 July 2009 (UTC)

Yes, thanks, the build nearly completes now. Apparently this new Fedora install doesn't have squashfs, so I'm working on that now.

Adricnet 03:50, 17 July 2009 (UTC)

Okay, I'm on a new F11 vm and running a build now. Once I do that smoothly we can talk about automation and making builds available.

Cheers

Adricnet 18:43, 28 July 2009 (UTC)

Working Better, Thanks

Better,

cd fedora-xo/
git checkout --track -b xo-1 origin/xo-1
Branch xo-1 set up to track remote branch refs/remotes/origin/xo-1.
Switched to a new branch 'xo-1'

seems to have changed the links to the latest changes on server...

make 

needs an argument... build file created looks interesting BUT wants to be root

make fedora-xo.iso

so more git, packaging and build learning, but working better now, THANKS!

python build

pulls lots of stuff down in rpms (AND I'M RUNNING ON A 64 BIT DESKTOP MACHINE PULLING 32 BIT RPMS?...)

EVENTUALLY failing at

Installing: kernel                       ##################### [594/629] 

28429 blocks

 Installing: gnome-session-xsession       ##################### [595/629] 
 Installing: system-config-network-tui    ##################### [596/629] 
 Installing: yum                          ##################### [597/629] 
 Installing: sugar-presence-service       ##################### [598/629] 
 Installing: yum-utils                    ##################### [599/629] 
 Installing: system-config-firewall-tui   ##################### [600/629] 
 Installing: olpc-update                  ##################### [601/629] 
 Installing: libdrm                       ##################### [602/629] 
 Installing: mesa-dri-drivers             ##################### [603/629] 
 Installing: mesa-libGL                   ##################### [604/629] 
 Installing: mesa-libGLU                  ##################### [605/629] 
 Installing: fltk                         ##################### [606/629] 
 Installing: squeak-vm                    ##################### [607/629] 
 Installing: sugar-toolkit                ##################### [608/629] 
 Installing: fuse                         ##################### [609/629] 
 Installing: gvfs-fuse                    ##################### [610/629] 
 Installing: csound                       ##################### [611/629] 
 Installing: gnome-panel                  ##################### [612/629] 
Traceback (most recent call last):
  File "/usr/share/yum-cli/callback.py", line 124, in callback
    fd = os.open(rpmloc, os.O_RDONLY)
OSError: [Errno 2] No such file or directory: '/var/tmp/imgcreate-8HP56B/install_root/var/cache/yum/olpc/packages/sugar-0.84.5-1.fc11.2.i586.rpm'
error: python callback <bound method RPMInstallCallback.callback of <callback.RPMInstallCallback instance at  0x5ef54d0>> failed, aborting!

[root@localhost fedora-xo]#

BUT GOT A LOT FURTHER. I might want to/ need to learn more...

danceswithcars 16:17, 24 July 2009 (UTC)

Additional rpms required for build

So far:

  • crcimg : for crcimg
  • mtdutils : for jffs tools

I'm able to yum these in fine and then os1 (done) and os2 (going now) img seem to build completely.

--Adricnet 23:59, 28 July 2009 (UTC)


I fleshed out the instructions, and found a few bugs...

Hopefully this is OK with everyone. I did yum install firefox, and apparently it installed, but I got an error that said, roughly, "Could not allocate memory."

Bcbc 22:50, 27 October 2009 (UTC)

Anybody have luck playing videos

All the players I have tried give me the "X11 error: Bad Alloc (insufficient resources for operation)" using the xv driver. I can use x11, as in mplayer -vo x11, but then the videos are postage stamp size. This used to work with the original XO OLPC software. Unfortunately, I found after I upgraded my son's XO I could not find compatible RPM's. So I decided to try Fedora 11 on the XO. Still videos are the biggest problem.

Everything I've found with google indicates this is a problem with the geode driver. I filed https://bugzilla.redhat.com/show_bug.cgi?id=540056 but unless someone finds the right place to file this upstream, there probably won't be a resolution anytime soon.

Build labels

Have you considered potential trademark issues of calling builds with names like OS9? http://os9archive.rtsi.com/os9faq.html

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox