Talk:OLPC Firmware q2e12


Jump to: navigation, search

OpenFirmware can't read the keyboard or reads garbage (NOT a hardware problem)

I acquired a developer key yesterday and at first I was able to get the OpenFirmware prompt and type things, but now even if I power-on the machine, press escape and type at the OFW prompt, nothing shows up, or garbage characters, or sometimes it behaves as if the CTRL key is pressed.

For example, if I press the letter 'f', I need to press it several times for it to appear, sometimes if I press CTRL first it seems to toggle it back off and then the next character I type will indeed appear, but mostly I can not enter any text now.

The strange things is that the first few times I tried, I could.

I would like to apply this new firmware to solve the problem, but since I cannot type in the flashing commands, I cannot update.

When OFW boots, I get this message:


OLPC C2, 256 MiB memory installed, S/N myserialnumber OpenFirmware CL1 Q2D07 Q2D

Type the Esc key to interrupt automatic startup Type 'help' for more information.



But as I wrote, I am unable to enter any text with the keyboard.

PS - I was able to proceed after plugging a USB keyboard into the unit.

PPS - The firmware upgrade has not solved the problem, I still cannot enter any text into the OFW ok prompt with the OLPC built-in keyboard. Plugging a USB keyboard in solves the problem. Note: The keyboard works perfectly once the operating system has loaded, so this is NOT a hardware issue.

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
OLPC wiki