Talk:Tiny Core Linux

From OLPC

Jump to: navigation, search

Configure wireless

An XO-1.5 here with firmware Q3C16. No eth0 is evident.

  • scan for networks:
iwlist scan | more
... lo ...
... wlan0 ...
  • associate with an open network:
#iwconfig eth0 essid network
iwconfig wlan0 essid linksys
... 
  • configure the interface using DHCP
/etc/init.d/dhcp.sh
  • Try to retrieve something.
lynx http://wiki.laptop.org/go/Tiny_Core_Linux
Unable to locate remote host wiki.laptop.org.
Yes, eth0 is no longer present in recent versions, you must identify the interface name using iw dev, and I've edited the page to show that. For all other network connection problems, refer to the Tiny Core Linux web sites, as we don't provide support for Tiny Core Linux here beyond that required for hardware compatibility. --Quozl 23:09, 16 February 2014 (UTC)

Configure DHCP

I have an old XO-1 and the instructions aren't working. I have a wlan0 interface, I set it to the SSID of my open wireless network, but when I run /etc/init.d/dhcp.sh it never seems to assign an IP. Any ideas? --Lmsurpre 21:11, 29 March 2014 (UTC)

Figured it out! dhcp.sh was only looking for devices like "eth." I modified this script to look for "wlan." instead and it worked like a charm. --Lmsurpre 21:27, 29 March 2014 (UTC)
Even easier is to invoke udhcpc directly. Thanks, I didn't notice this problem because I build with the mktinycorexo --essid option, and this calls udhcpc. --Quozl 23:17, 30 March 2014 (UTC)
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox