Talk:Xo-get

From OLPC

Jump to: navigation, search

See discussion on devel@ list. (snipit below)



From: Bert Freudenberg <bert AT freudenbergs DOT de>
Date: Sat, Mar 15, 2008 at 7:22 AM
Subject: Re: Update.1 activities download script
To: OLPC Devel <devel AT lists.laptop DOT org>
Cc: Sugar List <sugar AT laptop DOT org>


On Mar 15, 2008, at 1:55 , Gary C Martin wrote:

> On 15 Mar 2008, at 00:34, Ixo X oxI wrote:
>
>> Another great program to use to install .xo bundles..... is  'xo-
>> get'.  Has
>> both a console/terminal and Sugar/GUI interface.
>>
>>     http://wiki.laptop.org/go/Xo-get
>>
>> Currently under going testing, but pretty darn close with only a
>> handful of
>> 'un-documented features left'. :-)
>>
>> -iXo
>>
>> p.s xo-get also has one of the most extensive collections of
>> available .xo
>> activities to install .
>
> Yea, I use xo-get quite a bit previously very useful. However the GUI
> version has failed to work on any recent xo builds for quite some time
> (using a B4 here), and you do have to have already somehow installed a
> working terminal activity before you can use the command line version
> of xo-get, as it seems to have sugar dependancies that prevent it from
> running in the hidden command line. Maybe there are new versions that
> work under these situations?
>
> So not too great a fix just now for the activity bloodletting going on
> in the latest update-1 candidates ;-)

Xo-get does a lot more with its database of installed activities etc.
Mine simply downloads and installs activities from the repository for
"supported" activities.

But I'd be happy if someone merged my script into xo-get, I do not
intend to maintain it indefinitely.

It should be simple to add the official activity repo to xo-get. In my
script I like the simplicity of the default operation, which simply
upgrades all installed activities to the latest version found in the
repo. Also working from the console/ssh is useful, possibly one should
even support for installation without Sugar running (by simply
unzipping the .xo).

- Bert -

--71.217.3.13 12:38, 15 March 2008 (EDT)



Is this project still active? Today I was unable to update the list of packages on my XO using xo-get.py. Everett 01:07, 7 February 2010 (UTC)

repos arent existing anymore on olpc austria, there seems to be the python script on olpc europe though. so most of the article/links may not work.81.217.63.142 17:59, 12 February 2010 (UTC)

I tried to download xo-get.py from the link provided, but it is broken. Could somebody fix it? I replaxed


I also tried downloading (Jan/2011), and it's not there.

I found xo-get.py elsewhere, but it doesn't work.

HOW ELSE CAN I INSTALL .xo FILES?

thanks!

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox