Talk:Adobe Flash

Jump to: navigation, search

How to ignore the page and follow Adobe's instructions under 10.1.3 to install an older version

I have installed 10.1.3 in two OLPCs. When I switch to GNOME, I see that Firefox (FF) is the default browser (visible in the top menu). When I launch FF i am urged to install 3.6 but i have been told to ignore that (see 10.1.3 Release notes > discussion). A particularly useful web site which worked once on the XO under Sugar>browse, but no longer does is:

When i open it, it displays nothing but "Seattle" and is unresponsive. This site is very dependent on FlashPlayer. Apparently Gnash doesn't work properly.

Another site is (a MAC user website). Under "about us" I am advised my flash player is out of date and to download latest version of flash.

I have gone to the Adobe Website and am advised to download Flash. I am given choices; I chose and downloaded and have in my Download - File Browser window (shown in order Name Size Type Date Modified)

(folder symbol)install_flash_player_10_linux.tar.gz 4.7 MB Tar archive (gzip-compressed) Fri 18 Feb 2011 10:16:46 AM GMT

If i double click the above, Archive Manager launches and i see (file symbol) 11.6 MB shared 05 February 2011 9:14

If i double-click that i get "Extracting Files from Archive" then there is an "Open Files" window with two boxes Available "applications": and "Recent applications". There is nothing in either box.

I do not know what to do to install Flash Player. That was my first try. I don't know if i made the right choice in the download version from Adobe. Since some of the previous entries mention "YUM" perhaps that was the one to use. I feel this is very important in making the OLPC XO completely useful.

(by the way: If i click "Help"> about in the tool menu, i get "About the File Roller "File Roller 2.26.3" an archive manager for GNOME". If i click Contents F1, i get "Could not display help Failed to execute child process "gnome-help"(No such file or directory). THAT ISN'T MUCH HELP. )

So what should be a (more or less) simple step-by-step procedure goes nowhere.

Hope i didn't make an error in putting this first: I notice that the last previous entry appears to be dated in 2009. Somebody knowledgeable needs to address this. At this edit, i can only document what i see and what i do. What i do next is missing:)

--Generalludd 00:19, 19 February 2011 (UTC)

The instructions for installing at Adobe Flash - Firefox Browser (on GNOME) work fine for me on 10.1.3. Please follow them. --Quozl 04:25, 21 February 2011 (UTC)
Thanks Quozl - I'll check them out, however I got it working fine as the next section describes. I'll see how they compare. I also obtained the Epiphany browser from the Fedora site, installed it, and it works fine. Judging from its flash performance I think it is faster than Firefox. --Generalludd 23:18, 22 February 2011 (UTC)
Is this because Firefox scales the image? Measure the image size and compare between two browsers. --Quozl 01:13, 23 February 2011 (UTC)

It turned out easier than it looked.

FlashPlayer 9 is now running on the laptop under Gnome and either Epiphany or Firefox. Epiphany appears to be the faster browser.

1. Start by getting the rpm file on your desktop (in whatever way—I put it on a usb stick from a Mac, then plugged the stick into the XO, then copied it to the desktop). It will show up as a file symbol titled: Adobe-release-i386-1.0-1.noarch.rpm

2. Hover the mouse over the symbol and name,then copy (shift-ctrl-c)

3. Go to applications>System Tools>Terminal and click. When the terminal window appears you will see the prompt [olpc@xo-11-52-f1 -] $ and a flashing black rectangle

4. type: su – , and you will see the prompt [root@xo-11-52-f1 -] # and a flashing black rectangle

5. type: rpm –Uvh (don’t forget the space after h)

6. then paste Shift-ctrl-v keys and you will see the following filled in:

file:///home/olpc/Desktop/flash-plugin- (by the way that answers the "navigate to the desktop" problem)

7 Now press enter and wait …Text will appear and the installation will complete with a remark about older flash files being removed and stored (somewhere) as a tarball, etc. which can be removed. Then the prompt of step 4

8. Now type exit and get the prompt of step 3

9. Type exit again and the terminal window is closed

(NOTE: you can also just click the close button on the terminal and respond to the comment about killing a running process).

10. Now test a browser. (in accordance with an earlier instruction from the Fedora site) I selected Epiphany.

A good site to check is If you see a window with a list of cities and you click on it and get a measurement, it is working OK.

Another good test is to go to

then click on the “about us” tab. You should see a series of pages showing the officers of the Mac User Group. They automatically flip.

Another good site to check is

If you see a window with a list of cities and you click on it and get download and upload measurements, it is working OK. (my XO shows around 5 MB down and 1 MB up – I am on a 10 MB connection the mac is quicker).

--Generalludd 23:18, 22 February 2011 (UTC)

Why did you choose version 9? I can't really recommend version 9 of the player since version 10 is available, works, is maintained, has security update support, and is required for certain web sites. --Quozl 01:13, 23 February 2011 (UTC)
I'll try again. It is hard for me to tell what version I am running. I thought I was getting 10, but it looked like 9 was being installed. I am very unskilled with Linux code. By the way, can you tell me what version of Fedora the 10.1.3 update is running?
I tried again with adobe-release-i386-1.0.1.noarch.rpm, and got the message "package adobe-release ... is already installed." That was the one the Adobe site said was the latest. --Generalludd 00:55, 24 February 2011 (UTC)
Okay, so you chose version 9 by accident, or because that is what Adobe's web site provided. I've not looked at Adobe's web site, I'm referring to the Adobe Flash page here on the OLPC Wiki, because that's what I've tested. If you ignore the tested advice, you're relying on Adobe's testing. I don't think they test on an OLPC XO at all. That it doesn't work on Sugar is a pretty significant problem for OLPC usage. To answer your question, the OLPC OS version 10.1.3 is based on Fedora 11, according to the release notes. --Quozl 02:46, 24 February 2011 (UTC)
Thanks for the information. I mispoke on working under Sugar. I went to the sites I mentioned previously with Browse and when I clicked on the "click to play" at the top, then Flash operates. After I checked some documentation on Browse, I found that is as it should be. I see that Adobe has a page that identifies the browser on a system. . It worked on my Mac, and I found I was way out of date and updated it. So indirectly thanks on that. I will try that site with the XO, though it probably is not applicable. Regards --Generalludd 01:21, 25 February 2011 (UTC).
The instructions for installing here at the Adobe Flash page have a step for checking the Flash plugin version. The link is to another page provided by Adobe. I've compared both pages, and I think the one we already link to is adequate, especially as it links to the one you mentioned anyway, but also because it is an Adobe support knowledge page. --Quozl 02:52, 25 February 2011 (UTC)
I went back over the instructions at the Adobe Flash page above. I misread some of it, and that is why I had difficulty. I think others may encounter similar problems. Mainly, the links in steps 2 and 4 describe far more than is necessary. The step 3 (mouse over and copy the URL) should simply be ... copy the contents of the box below (beginning with wget and ending with exit); and I would put the box directly beneath the step. If permissible, I could go to the procedure itself and edit it to clarify it. I sucessfully installed Flash 10 and it works fine. Regards: --Generalludd 18:29, 25 February 2011 (UTC)
I agree, the procedure was complex and self-referential, and could have easily led to confusion. I've changed it. Have another look. Yes, you can change it too. --Quozl 22:56, 27 February 2011 (UTC)
Thank you. I checked the procedure and it looks much clearer. Just about what i did. These instructions might contain a note to be patient. There was a period of several minutes when i had a blank screen and thought the terminal had died, but it finally completed and i could exit. --Generalludd 23:28, 28 February 2011 (UTC)
I trust the delay was in response to the rpm command? --Quozl 23:59, 1 March 2011 (UTC)

Uninstall Previous Versions of Flash first?

Has anyone else had the experience of it being best to uninstall flash and gnash before putting in a fresh install of flash? I'd like to add that to these instructions (as a reccomendation), but only if its been applicable to others (as we may have an oddball experience because something we personally did). -Andrew (OLPCsb)

Playing Flash videos

I followed the instructions and Flash works most of the time. However, some videos on YouTube have a strange audio echo - usually when the video has over 5000 views. I'm thinking this could be an issue with YouTube's streaming - maybe I could use or another site for them to download the video. Ideas?

Any update or ETA on when OLPC Browse Activity will be ready for Flash 10?

As mentioned in the developer notes, Flash 10 doesn't work me under the Opera 9.12 OLPC Edition (installation seems to succeed; about:plugins shows flash installed; but a flash 10 site doesn't work.)

Any updates on when a new update to Opera OLPC Edition will be coming out?

Interestingly, the version of Opera shipped with the 2007 G1G1 laptops does work with flash 10. I'll probably revert back to that for now.

I see the instructions for moving forward to Opera 9.60 desktop version, but sounds like 9.60 isn't quite compatible with Sugar and the rest of the XO environment (e.g., see the issues under creating an Activity on

Current version of Browse works fine with Flash 10. Please Update. --Quozl 04:28, 21 February 2011 (UTC)

Can't get it to work

These instructions didn't seem to work - Gnash is still used on all Flash webpages. For those of us who do not know how to replace gnash with flash, a quick note from an expert would be greatly appreciated.

  • The original instructions for Adobe Flash installation allowed for a local user installation as an alternative to the system installation. An advantage of a local user installation is it doesn't not have to be re-installed after a standard upgrade. A disadvantage is that Gnash, a system installation, seemed to override the Flash installation in Browse. Katie 06:09, 5 January 2008 (EST)

run as root

That command didn't work for me either. Running 'sudo' just gives an error. I'm no unix expert, so I think there is a way to do it with one line like he was trying to say. But I was able to get it to work this way:

su - root

then type this

rpm -i

Forcing Adobe Flash to run in "low-quality" mode by default

Many G1G1 users who have installed Adobe Flash report improved performance with this edit to the flash binary, which forces the plugin to run in "low-quality" mode by default.

  cd /usr/lib/flash-plugin
  cp && sed -i 's/HIGH/LOW/g' && sed -i 's/LOW/HIGH/'

Found at: The poster there credits .

~ Hexagonal 17:02, 4 January 2008 (EST)

This seems to be the lowest-common-denominator of binary edits that acheives the same goal:

  sed -e 's/\<AUTOLOW\x00AUTOMEDIUM\x00AUTOHIGH\>/AUTOHIGH\x00AUTOMEDIUM\x00AUTOLOW/' > libflashplayer.s

I also feel that it is more robust than the previous solution.

It is confirmed working on 01:56, 30 November 2009 (UTC)

Firefox now provides a plugin:

Flash and Gnash Conflict

I'm working with the two laptops I got for my kids.

I installed Adobe Flash and have noticed on that some of the games seem to be trying to run in Gnash and Flash at the same time now. Anyone know how to uninstall Gnash? Is that safe?

Carey Cranston--New Dad to the community.

Installing Adobe Flash will not do irreparable harm to your system. No need to uninstall Gnash. --Walter 14:28, 6 January 2008 (EST)

Not sure what I am doing but trying to figure it out for my daughter who received as a gift. Forgive me if my question is in the wrong place. I somehow installed the wrong Adobe version by just clicking the link and I can't figure out how to fix it. The instructions do not help since the terms are foreign to me. I am worried that if I find the "terminal" and uninstall, I will do more damage. Any suggestions? Is there someone in the NYC area I can hire for assistance?

If you installed the wrong version, then you can just reinstall the correct version by using the --force option. e.g.,
rpm -i -v --nodeps --force flash-plugin-

--Walter 14:28, 6 January 2008 (EST)

installing adobe

thanks walter!! when i open the terminal there are characters on the first line. do i type the characters you gave me underneath the ones that are already there? or do i erase them and type the installation language instead?

A good question, I could see how that would be confusing. Here's what I know - the characters on the first line when you start the Terminal are called a "prompt" - it lets you know who you're logged in as, (your user name), the name of the machine you're working on, and some indication where you are in the directory/folder structure. You can't delete those characters. When you log in as root, those characters change to "bash 3.2 #" or some such, but they are still a prompt only, not deletable. So you type the commands after the prompt. I hope this helps! annegentle 02:44, 31 August 2008 (UTC)

Disabling Gnash

I installed Adobe Flash in /home/olpc/.mozilla, and like others found that both Adobe Flash and Gnash were installed (according to about:plugins), but that Gnash was handling any Flash animations. I disabled Gnash by doing this:

mv /usr/lib/mozilla/plugins/ /usr/lib/mozilla/plugins/

When I upgraded from build 650 to build 653, Adobe Flash was still installed, but the change above (disabling Gnash) had been reversed, and I had to do it again.

Mouse Cursors

Is there any easy way (e.g. X resource) to change the mouse cursor to something larger, preferably the standard Sugar cursor?

Yes, at least on build-656 the default icon theme needs to be changed from Bluecurve to sugar:

su -l
cd /usr/share/icons/default
cp index.theme index.theme.bak && sed -i 's/Bluecurve/sugar/' index.theme

Restart X by pressing ctrl-alt-erase. Thunder 05:54, 4 July 2008 (UTC)

segfault on right click

With Adobe Flash 9.0.r48, right-clicking on a flash animation would cause a segmentation fault for both Browse and Firefox on the XO. This is fixed with Adobe Flash player version 9.0.r115.

Notlong URLs?

I'm not sure it's a good idea to advocate installing software from "" URLs, especially as root. Yes, it's more convenient, but there is considerable potential for abuse. Not only does it assume that the database at is secure, but it also makes it harder to detect a malicious person inserting his own URL (or preregistering typo URLs or future versions). —Joe 15:23, 14 January 2008 (EST)

Capability of a the flash player on the XO

I have a B4 XO. What is the maximum .swf file size that the flashplayer can play on the XO? I could play .swf files up to 50 kb with acceptable performance. Is there anyway that the flash player on the XO can play a .swf file which is 2 to 3 MBs large?

> Does Flash lite work on the XO as yet? Flash Lite 1.1 (based on Flash 4) and Flash Lite 2.0 (based on Flash 7) content run pretty good on the XO with Flash 9 or 10 beta installed. Performance is more or less the same as that on a Nokia Series 60 feature pack 3 Flash Lite-enabled phone. -Naz

Webcam functionality

Webcam functionality of adobe flash player just seems to spew out a black box on the XO... could this have to do with adobe's usage of v4l1 instead of v4l2? It successfully detects the camera, but all video is just black.

> If you upgrade from Flash Player 9 to Flash Player 10 beta, it improves a little, but not by much: instead of just a black box, you'll get red and green static, but you know it does something because the static reacts when you wave your hand in front of the camera.

You can test it by going here:

This may also help:

The Flashcam Project

-Naz 09/24/2008

"file not available"

I'm one of the g1g1 recievers and I can't get this download to come out. I followed the commands exactly and I have problems with the "wget" command. it connects to the internet, recgonizes the alias, and says file not there. I followed the link on the page and downloaded it through there and ran the final command but it wouldn't run saying it still wasn't there.

Opera-compatible flash version (048) no longer on adobe site

Today (14 May 2008) I tried downloading the 048 flash version and got a 404 not found error. It looks like Adobe took it off their site. If you download the 100MB archive of old fp9 versions, there is still a .tar of the 048 version available. Ugh.

If someone has a fix for this I hope they edit the instructions, and feel free to delete this entry if the problem gets resolved.

Using Flash in both Opera and Browse - can you have two versions installed?

Back on March 31st, I followed the instructions on this page and installed flash twice - once for Browse (ver 115) and once for Opera (ver 48). (I found the ver. 48 today - so maybe that's been fixed?) Since then, I've done secure upgrades, including one to 708 yesterday. This page now offers the 124 version of Flash as the newest for Browse, and 48 for Opera. However, installing them both is not possible (124 has files that don't work with 48 - drat.) So, I try to uninstall as noted here on the page, but....

Uninstall is not working for Flash

as of 8/18/2008 - I get the following error when I run this command (it's the same for all versions.) Any help on this one?

snipped from Terminal ------

-bash-3.2# yum remove flash-plugin-

Setting up Remove Process [Errno 14] HTTP Error 404: Not Found

Trying other mirror.

Error: Cannot retrieve repository metadata (repomd.xml) for repository: olpc_koji-update1. Please verify its path and try again

FYI - I checked the Linux Flash support pages at and found the simple delete option. I'll try this later tonight. - 8/19/2008 g1g1pdx

Removal instructions

Manual removal (for users who installed the plug-in via Install script): Delete binary and flashplayer.xpt file in directory /home/<user>/.mozilla/plugins/

RPM removal:

As root, enter in terminal:

  1. rpm -e flash-plugin

Click Enter and follow prompts

Hope this helps others....

2014-10 installation on XO-1.5

"... go to and complete the prompts."

With 13.2.1 on a 1.5, that yields four choices with the two most likely being "YUM for Linux (YUM)" and ".rpm for other Linux". Outside of OLPC I have never used Fedora and have no ideas about which of the two might work best. Advice? Thanks. --Peasthope

We cannot afford to keep tracking changes made by Adobe to their software delivery. Just try both, let us know what you find. --Quozl 20:25, 26 October 2014 (UTC)
The two retrievals give these files:
[olpc@xo-53-1d-bb ~]$ ls -l *rpm
-rw-r--r-- 1 olpc olpc    4368 Oct 30 05:36 adobe-release-i386-1.0-1.noarch.rpm
-rw-r--r-- 1 olpc olpc 6905974 Oct 30 05:42 flash-plugin-
I can't guess at the purpose of the first and ignored it. The second installed with your compound command and works. Release number updated. Regards, --Peasthope 13:50, 30 October 2014 (UTC)
Thanks. That first package is likely to be a yum repository metapackage, which we are familiar with already (e.g. rpmfusion-free-release GStreamer#Adding_codecs) so that system updates will install the new version. However since we do not support yum update we can ignore that package. Our preferred method of updating is with olpc-update and OS_Builder. --Quozl 21:04, 30 October 2014 (UTC)