Jump to: navigation, search

DebXO Wired Ethernet Connection


I am not able to connect DebXO gnome with broadband ethernet connection. My modem is a Nokia Siemens C2110 Dynamic. Can you help? Please mail me at indoria_abhishek_AT_hotmail_DOT_com


I'm having some issues with debxo 0.3.

1) I wanted to have a login name of quixote, but when I changed it, using "usermod -L quixote olpc", the shutdown gui ceased working again. Could this be related to the earlier issue, in 0.2, that prevented shutdown from working? I've switched it back to "olpc" but shutdown still doesn't work. Hibernate generates error messages and aborts back to regular "on" mode.

2) Trying to establish a new user resulted in lots of things not being set up, such as wireless networking. Is there a simple way to set up another user just like the "olpc" user?

3) I gather "zcat" does a raw write, because my 16GB SD HC became a 2GB SD with lots of unallocated space. Maybe it would be good to let people know they'll have unallocated space with a card or thumbdrive larger than 2GB. I set it up as my new /home partition and am enjoying all the oceans of space!

Other than those issues, I'm finding debxo to be stable. It boots up quite quickly. And the install, with that nice little zcat command I'd never seen before, couldn't be simpler.


DebXO USB Not Readable

I followed the instruction zcat debxo-awesome.ext3.img.gz > /dev/sdc1 where /dev/sdc1 is a 4 GB USB disk. My olpc can't read it and wont boot from it. At startup I press Esc and get the ok prompt. The boot command and the dir u:\ command say the usb disk is unreadable.

I can mount the usb disk on my Lenny box with mount -o loop,offset=16384 -t ext3 /dev/sdc1 /media/linuxkey and have added a directory security and copied my developer key there. While mounted df - h shows only 740 M of the 1.9 G partition is used.

cfdisk /dev/sdc1 shows the partition is bootable and has the label DebXO but will not allow me to maximize it although it shows 2039.42 M free space. I could make a new partition to use the free space but it seems more logical to have a single 4 G partition.

At any rate, what is wrong?

My bad - just realized that should be /dev/sdc not /dev/sdc1. Awesome boots but to gray screen with no keyboard response. I'm trying gnome next.

OK, gnome is awesome. Many thanks for all the work that went into these images, its great keep olpc and also have debox.

Can DebX0 Use XO Wireless Adapter?

I have booted debxo-gnome from a usb drive, opened a root terminal and tried setting iwconfig parameters - our LAN uses static ip addresses. Signal strength is good but no connection. Have others had success? If so, how?

A: DebXO-awesome (the version I use) has a running network-manager. One should suspect that this can be used to manage your network connections, but the usual nm-applet is not visible on screen, nor can it be started from an xterm. I also tried stopping network-manager and trying my luck with wpa_supplicant. That failed also, I wasn't able to connect to my WPA2-PSK network (which works flawlessly for my bigger laptop).

A: The DebXO-gnome has network-manager including its usual nm-applet visible at the usual place. Still does not work for wpa2 for me, but it works for wpa.

(0.5)DebXO-awesome.ext3.img --> clues for getting started

When you first start the (0.5) DebXO-awesome.ext3.img on the XO-1, you get the blank wm screen. To open a terminal press the "hand" button and the enter key. The fonts in the terminal will be tiny and barely readable for someone with good eyesight. As this is an xterm you can change the fontsize by holding the ctrl button while pressing the right-click button of the mouse which will give you a menu that you can use to change the font size in the terminal to something useable.

man awesome will give you most of the commands you need to use the awesome wm.

To get on the network there is ifconfig, dhclient, etc. Use the whereis command to find if the program you want is there and its location. "whereis dhclient" gives you /sbin/dhclient. As /sbin is not yet in $PATH you need to either add it or type it.

(0.5)DebXO-awesome uses awesome v2.3.3 which uses the "libconfuse" configuration library ( (It is much different from v3 which writes the configuration file in the Lua programming language, or v1 which used the libconfig library from dwm.)

My vote for the most useful window manager concept for an adult geek's XO-1 is the awesome wm. Given that the mouse pad on the XO-1s is still only semi useable, the rodent-free approach of the awesume wm fits the XO and its 1200x900 display quite well. If I were bored and had time I would be interested in creating an even more vi-like interface for the wm where a single keypress, (much as vi uses "esc") puts the windowmanager into command mode, waiting for a single keypress command to manipulate the wm or move the mouse curser. This would be more flexible and easier to use with the small keyboard than trying to press two or three keys at a time on the tiny keyboard to input a wm command.

Suggestion for a future release

I used DebXO-awesome 0.5 (thanks for creating it, I like deb-based distributions much more than rpm-based stuff), not sure whether it applies for the other images also:

  • Please use a bigger default font size for the gui as well as for the console. Although the console font is slightly bigger, both are a pain to work with.
  • The default Xserver background with those little pixel-Xs leads to irritating flickering. Please use some solid colour.
  • Without an easy way to get wireless working, most people will be blocked after flashing DebXO. A WPA2 protected wireless network is state of the art today (and required to have best security), so it should be an issue of a few minutes of getting that working. Maybe just a missing wpa_supplicant XO sample config or a hint how to get the UI of network-manager?

Additional suggestions: [--Marathonjon 05:27, 28 July 2011 (UTC)]

  • Don't assume everyone who uses the XO is a Linux guru. After all, it was designed for kids. A few additional GUI tools would make the system easier to use.
  • Include Synaptic Manager
  • Include Gnome System Tools
  • Include gksu
  • Set a password on the root account because when running Synaptic from the menu, a root password is required, but a blank password isn't accepted.

Once I made these changes, it was a lot easier to add and remove applications.

Upgrading instructions

The upgrading instructions on the main page sound a bit like upgrading to squeeze is easy, if one keeps the current kernel (as contained in DebXO 0.5).

But, if you try to do the squeeze upgrade, it will tell you that the udev 1.60 won't work with the current kernel asking whether you want to upgrade udev or not. If you tell no, it won't upgrade udev, but (at least) xserver-xorg-core depends on the newer udev. Broken dependencies.

If you ignore the warning and tell yes (risking breaking your system), you will run into out-of-memory problems a little later (at gconf2), so don't try upgrading within a xterm under gnome, but rather stop X and other services not needed and do it from the console.

Installing to Media Larger Than 2GB

First of all, I want to say "Great work!" to Dilinger. I've tried many other distros on the XO, and either I couldn't get them to work, or my kids weren't happy with them. DebXO works right out of the box, and it's easy to install all the other apps we need. I really hope Dilinger maintains this distro as Debian comes out with new releases. Please see my comments above for suggestions for future releases.

I'd like to point out that the instructions for installing to Media smaller than 2GB also work if your media are larger than 2GB. I used an 8GB SD card and of course ended up with 6GB of free space. I tried to just create a new partition in the free space, but the XO wouldn't boot after that, even after removing the partition. So I started over, following the previously mentioned instructions. I did have a few errors to resolve:

  • When trying to loopmount the img file, I got an error that only root could mount it, so I used sudo; then I got an error that /media/sdloop didn't exist, so I used sudo mkdir to create it.
  • Similar problem when I tried to rsync to the SD card: permission denied. When I used sudo, it worked like a charm. Also, instead of referring to the SD card as /media/sdreal/, I used its real name, /media/DebXO/.

Linux gurus would know to use sudo or mkdir, but not everyone who uses the XO is a guru. These little tweaks to the instructions would help make them more user friendly.

--Marathonjon 05:12, 28 July 2011 (UTC)

"Installation ...Prerequisites" could give recommendations for SD capacity. The instructions for installation in less than 2 GiB suggest that a capacity larger than 2 is beneficial. But how large? How much storage does the simple installation require to function? If I am to buy an SD card, slightly more specific information will help. Thanks, Peter E., Peasthope 16:51, 1 February 2012 (UTC)


dd if=debxo-gnome.ext3.img of=/dev/sdX bs=4
dd if=/media/disk/debxo-gnome.ext3.img of=/dev/sdX bs=4
dd if=/media/disk/debxo-gnome.ext3.img of=/dev/mmcblk0p1 bs=4
dd if=/media/disk/debxo-gnome.ext3.img of=/media/XXXX bs=4

I upgraded to debxo " OLPC xo-1 " running the above command but terminal has been stuck there, only to input some garbled.

My steps:

  • Copy .Img to USB plate
  • At the same time equipment USB disk and SD card
  • Running OLPC XO -1
  • Open root terminal
  • Input command

Then the terminal on the card.

Hope to see who can help me.

Reinstalling might be easier than troubleshooting the upgrade. Have you tried to reinstall? ... Peasthope 22:41, 27 March 2013 (UTC)

DebXO on the 1.5

In the boot console of DebXO 0.6 on the 1.5, the text does not fit the screen properly. The device driver for the Via video hardware is specified in the olpc.fth.

\ " ro root=LABEL=DebXO video=viafb" to boot-file
" ro root=LABEL=DebXO video=viafb:1200x900 fbcon=font:SUN12x22" to boot-file

Ideas? Thanks, ... Peter E., Peasthope 21:27, 28 February 2013 (UTC)