Jump to: navigation, search

my journal icon has disappeared how do I get it back. I have pressed the magnifying glass key and it did not work

The first thing to try is rebooting the machine. If this does not fix the problem, you may have an instance of a problem for which we had gotten a few reports. We have a patch for this latter problem and it will be available soon through the automatic update process. Please do report back if the reboot did or did not fix the problem. --Walter 18:12, 14 December 2007 (EST)
I also had this problem, and rebooting fixed it. I'm not sure how I killed it in the first place.Paul Bock 14:02, 19 December 2007 (EST)
Solution? I had this problem after about three weeks with the XO, about a week after installing the Opera browser and a bookmarking plugin for it. One day the plugin disappeared. The next day, the Journal didn't show up and other activities wouldn't load. Update_paths Upgrading to the new "653" release of the system solved the problem. Opera was no longer working, so I reinstalled it too. All fine for the past week. -- Robby 16:45, 26 January 2008 (EST)
Another problem I found with Journal is that if you plug a USB flash drive in that already contains a lot of files, like over 2,000 in my case, it takes a long time to index all the files. While it is indexing, it seems to lock up the ability to switch between journal storage and the external storage. Also, is there a way to change the default location that Journal uses for storage, so that it uses my SD card instead? Paul Bock 14:02, 19 December 2007 (EST)
Some good observations and ideas here. Hopefully to be addressed in the new Journal spin scheduled for early 2008. --Walter 20:41, 19 December 2007 (EST)
Journal discussions in detail: scheduled for Jan 13-19? Sj talk

Where is journal data written to in the file system?

Is there a document within the wiki that describes how journal data is actually stored in the file system?

It seems that the design of the journal is such that it wants to prevent users from thinking about data in terms of files that have a location within a hierarchy, etc. Does there exist a way within this paradigm, however, for one activity to readily access data created/generated/downloaded by another activity? It seems that the "resume" button in the Journal activity does this in a limited way in its pull-down menu--but the pull-down menu does not list all the activities that might be able to read a certain peice data. Similarly, does there exist a way for a terminal process (vi, for example) to access data created or downloaded by activities? A hierarchical filesystem is very good at making these two tasks easy. How does the Journal solve these problems, and if it does not, what is the work-around (i.e. where is the data stored in the linux filesystem)?

What I am trying to do is download an ebook (albeit a large one, ~1.2mb) in ascii from Project Gutenberg and read it comfortably off-line. As of right now, the only way that I have figured out to do this is to use wget to grab the file and then open it in Browse by typing the file path into the url field (which, incidentally, crashed Browse, probably due to the size of the file).

I must admit that I am frustrated. Am I approaching this issue incorrectly? --Legutierr 21:51, 21 December 2007 (EST)

The Journal writes to a datastore (See /home/olpc/.sugar/defaults/datastore). There is as yet scant documentation and the mime types for many activities are not yet properly set (the reason why Read didn't open .txt. etc.) There is some good news on the horizon: Reinier Heeres is working on Read; he wrote a simple script to copy a regular file to the datastore/journal that got extended with quite a bit more functionality by Phil Bordelon. Stay tuned. --Walter 12:31, 22 December 2007 (EST)
Alternatively, you can load files into your Journal from a USB stick by drag and drop. --Walter 12:55, 22 December 2007 (EST)
BTW, could you please point us to the book that crashed the Browser, so we can investigate? Thanks. --Walter 12:32, 22 December 2007 (EST)
The book that I downloaded is Thusydides' Peloponnesian War, at; the crash was not immediate, but took place after attempting to re-size the text a couple of times, and after changing the screen orientation. I'll attempt to reproduce it and post my results.
BTW, I have experienced Browse crashing on several occasions, although I did not note the exact circumstances in each case. What seemed to be a common denominator was having multiple instances open. I think that I may also have been reorienting the screen for ebook mode, or re-sizing the text, but I cannon be at all sure in those other cases. --Legutierr 13:41, 22 December 2007 (EST)
The out of memory management is not as stable as we'd like at this point. Activities such as the browser use a lot of memory; multiple instances even more. Look forward to a more stable Browser in the Update.1 release in January, which uses a new underlying engine from Mozilla. --Walter 14:07, 22 December 2007 (EST)
I was able to reproduce the crash; it doesn't seem to be related to memory. See bug #5639. --Legutierr 23:34, 22 December 2007 (EST)
I've not been able to reproduce it in the Joyride builds, but we'll keep digging. Thanks. --Walter 01:13, 23 December 2007 (EST)
OK. I'm not entirely certain what joyride is (is it a more recent build of the system? Is it the OS running in an emulator? Based on what I've read here, I assume I'm using build 650, which is what came installed on my G1G1 machines). Anyway, maybe it was fixed since shipping, but for what it's worth I reproduced the same error consistantly on both of my (factory installed) XO laptops. --Legutierr 01:25, 24 December 2007 (EST)
Sorry about the jargon. Joyride is our development build. It has a newer version of the browse activity than the one shipped on G1G1 machines. You may want to follow the instructions for doing a developer upgrade (See Activation_and_Developer_Keys) on one of your machines to enable you to run newer software to see if it fixes your problem. After you get a developer key, you could try running olpc-update. The other option is to wait until Update.1 is released in mid-January. Good luck and please report back. -- 05:17, 24 December 2007 (EST)
Not sure if this is relevant, but you mentioned that you were trying to read an ascii text file - I thought the Read activity could currently only handle PDF files (I`m on build 650). --Tomhannen 07:20, 24 December 2007 (EST)

"starred" entries and deleting groups of entries

I have missed something in the discussion of the Journal. First, what does "starring" an entry do? I have toggled the star on various entries, now what can I do with those entries? Secondly, is there a means of selecting multiple entries to be deleted without selecting each individually?

You haven't missed anything. Starring is an incomplete feature. It will be used as a sorting attribute and as a means of suggesting to the backup system what to keep local on the laptop. In regards to multiple selections, that too is a future feature. --Walter 09:29, 31 December 2007 (EST)

I'm no iconoclast, but ...

Directions say I can view contents of external memory by clicking on the USB icon. What icon is this, and where? I'm a bit slow; what might be obvious to some users is anything but, to me. juanslayton 6 Mar 08

at the bottom of the list-view page in the Journal. --Walter 12:52, 9 March 2008 (EDT)

Trouble with blank journal

I now have an XO with a completely blank journal and a seeming inability to run any of the activities. For some reason, the XO will run programs that have activities listed in the journal on my USB key when the USB key is inserted, but the XO is essentially nonfunctional without that key and won't run anything that wasn't already on the key when the primary journal was wiped out.

Would anyone have hints about the best way to reunify Sugar with its journal?

Thank you.