Talk:OS images

Jump to: navigation, search

Reorganizing "Build images" pages

The current Build images pages are getting to get a bit disorganized. With the landing of LinuxBIOS, many testers will be using these images containing the Geode fbdev/X drivers rather than their own installs. These pages need to be cleaned up and organized so that they are easier to understand for the new influx of testers.

First change, "Build images" should be moved to something a little bit more descriptive, such as "Operating System images."

The Operating System images page should then be split up into multiple pages. The main page should continue to list information on how to download images, and the various images available. "Using Images" should be split into many different pages, possibly ones for "Using Operating System images on test boards", which would list instructions about dd'ing to a dedicated device, or the nitpicks and notes of copying to files to an existing filesystem and upgrading. "Using Operating System images in an emulator" could then describe use of QEMU on Linux, Windows, and the Mac, as well as in VMWare.

Multiple pages prompts the creation of some new categories. Some categories I can think of 'Emulation' and 'Operating System'. --SamatJain 02:03, 23 August 2006 (EDT)

Things to try once the build has loaded

Below we could discuss things that a user can currently do with the latest builds.

Build 59 allowed me to search the web, but much else yet (not meant as a criticism!)

Experiences with the build images:

Dell Latitude D600 Laptop with USB image build59

I'm no expert in Linux at all, but I really wanted to try the OLPC build to see how it works... I have a Mac & a Windows PC. I tried transferring to the USB stick using dd for windows but had problems with the end of the file (to do with the --size switch I think).

So instead used my mac to download the image, decompressed it using apple's BOMArchiveHelper, then transferred the image to the USB drive using the dd application from the Terminal, which worked well.

Then I shutdown the PC (a Dell Latitude D600 laptop), inserted the USB key, rebooted, changed the BIOS to boot from the USB (by holding down F2 on boot-up), and it all came up well.

I logged in as root, no password, but when I got the the command line, every few seconds what looked like an X-windows login window would appear asking me for a username (default OLPC). I pressed OK on this, then the screen went back to my command line. Then a few seconds later the same thing happened, and kept happening repeatedly. I tried some other usernames in the window, such as root, but this didn't solve the problem.

Just thought I'd let you know, I hope this is the correct place for this sort of feedback!

--Tomhannen 06:14, 11 August 2006 (EDT)

X looks to be dying after startup for some reason, hence the switching between the GUI (X) and the command line. I don't see this with build 59 when run on the OLPC boards, so it may be related to your machine. Have you tried Qemu? --SamatJain 11:18, 11 August 2006 (EDT)
Haven't tried qemu, as I don't have a machine that runs linux, I'm ashamed to say... Is there a LiveCD I could try with QEmu preinstalled? In fact, a liveCD for potential testers of the OLPC project might be a good idea... --Tomhannen 11:38, 11 August 2006 (EDT)
See LiveCD.--Mokurai 23:31, 25 June 2008 (UTC)

Hi. Tried QEmu today (see below). Here's the error I got with the USB image booting directly on the Dell (just for reference):

(EE) FBDEV(0): FBIOBLANK: Invalid Argument
(EE) AIGLX: Sceen 0 is not DRI compatible
(EE) FBDEV(0): FBIOBLANK: Invalid Argument
localuser:root being added to access control list
waiting for X server to shut down FreeFontPath: FPE "unix/:7100" refcount is 2, should be 1; fixing.

So I had a look at the Qemu user forum to see if there are any live CDs with qemu pre-configured.. And there are - one in particular called SLAX KillBill Edition v 5.1.7b

So I downloaded it, burnt to CD (eventually using the correct option in Roxio: File menu, then "Record Disk from Image"), and booted on my Dell Laptop.

SLAX asks you to login as "root", password is "toor".

Then I plugged in the usb stick. I had to mount the USB stick on the file system.. My file system had used device name "sda1" for the USB stick... Yours might not be.

So I typed

mkdir /mnt/sda1

to create a mount point for the USB stick, then

mount /dev/sda1 /mnt/sda1

then looked in the directory I'd just mounted

cd /mnt/sda1

then typed

qemu -hda olpc-stream-development-59-20060808_1153-ext3.img

which didn't work, it crashed with:

Could not open '/dev/kqemu' - QEMU acceleration layer not activated
Could not open SDL display

So I tried without -hda and got the same error... So I looked through the manpages on qemu, and tried

qemu -hda -no-kqemu olpc-stream-development-59-20060808_1153-ext3.img

with no luck, so tried

qemu -no-kqemu olpc-stream-development-59-20060808_1153-ext3.img

which gave the same SDL error, but without the bit about acceleration. Hope this is of use to someone. --Tomhannen 10:39, 12 August 2006 (EDT)

The message about acceleration is of no importance, it'll still work fine, just slower than with the kqemu component. the .img file is an argument to -hda, so the need to go together, not with -no-kqemu in between. But you can also specify the .img file as the last argument, without -hda, like you did. But the SDL error is important, and probably doesn't have anything to do with OLPC, it's just a qemu installation problem. -- ABostrom 15:30, 19 September 2006 (EDT)

Tinderbox issues with latest images

Tinderbox link is dead. Can someone correct this link? Even if tinderbox itself isn't working, the link should!

Tinderbox ( only lists information up through build 389, even though the header says it knows the latest build is 443 and stable is 406. The most recent build at seems to be 451. But if I click the "automated test results" from that build (or 443 or 406 or any of the recent ones for that matter), which is, I get a "not found" message.

All of this leads me to wonder if the tinderbox setup at RH has rotted from neglect. Should I expect this to work and find someone at RH to resuscitate it?


Incorrect link...

In 1.2 (Definitions; Downloads): You can download other recent and stable images from: (look in "latest")

Following the link as no directory 'latest'. Could someone who knows correct the link, or the text to be accurate? CharlesMerriam 10:16, 6 March 2008 (EST)

Updated that section, hopefully clearer now --morgs 06:00, 13 June 2008 (EDT)

Faster builds

There is nothing here about the "Faster" builds where speedups are being tested.--Mokurai 23:31, 25 June 2008 (UTC)