Talk:OS images for USB disks

Jump to: navigation, search


These instructions have not been updated for the latest release. Volunteers are needed to work through any problems and fix the instructions. In particular, the lzma support may need to be added if an XO laptop is used to follow the instructions. --Quozl 21:47, 8 December 2013 (UTC)

missing lzma support

Has a bug been filed for the absence of support for lzma in the XO laptop? I think it's part of OLPC's philosophy to include that kind of tool. --Boukman 20:35, 17 January 2014 (UTC)

Yes, 13.2.0 contains liblzma, and pyliblzma packages. No, it is not part of our philosophy to include all Open Source tools, they have to be obviously needed by a child and fit our storage limits before we will include them. Otherwise, the child can download tools needed using internet repositories. --Quozl 22:12, 17 January 2014 (UTC)

instructions for lzma

The recent os images are no longer bz2, they are lzma. I can not successfully extract the 874 lzma archive - I get multiple directory not found errors.

Instructions for extracting the lzma archives is needed. Rmyers 23:01, 3 August 2011 (UTC)

Much of the page is no longer relevant and is not good guidance. I was able to extra the archive fine. The command was "tar --extract --lzma --file os874.tree.tar.lzma --directory /mnt". However, I was not able to boot the filesystem, the initrd failed to proceed; there were errors about /lib/modules not found. There was lots of change in this area, and it was not our intention to support USB booting in this release, so it likely does not work. --Quozl 02:10, 4 August 2011 (UTC)
Thanks. Playing around I noticed that the extraction worked to a hard drive but not the SD card I was trying, so that may have been that issue. I'm trying to get it onto a external HD I formatted as a single ext3 partition 'OLPCRoot' but haven't got it to successfully boot yet. Rmyers 03:03, 5 August 2011 (UTC)

OS images for USB disks

Where can I download the OS images for USB disks that will run on OLPC?


Same problem here. (12 hours later):At last, I've found it. OS_images

PC Engines Alix.1C (AMD Geode LX800)

I want to run Sugar on Alix board, tried this image, but the boot fails on various errors it seems. Anyone has a suggestion? Thank you!--Kozuch82 01:31, 5 January 2009 (UTC)

How do I convert ISO files to IMG files

How can I convert these files or is there a possibility to use plain ISO files?