Jump to: navigation, search

Is there any way to get video working?

I understand that to get skype video working you would need to use unfree codecs, which OLPC cannot distribute. However, has anyone figured out how to do this?

PDS Yes, I just got video working in Skype based on a suggestion from one of the forums re. 'gstfakevideo' (aka skype video hijacker). I'll try to write up instructions at Skype: Video
Great job! I copied that content back to this page, I think it's better to have it all in one place. Homunq 08:10, 11 January 2008 (EST)
I am unable to get this to work, I am getting permission denied errors. Slightly more specific instructions such as where to unzip things would be super helpful as they are written now I feel like Im guessing at alot of things.
I've tried the video thingy too, and I'm not quite done: skype switches the cam on (options -> test), but displays only bogus (with line 42 commented) and black screen (with line 42 uncommented) -seb

on joyride builds...

I'm running on a development (joyride) build of the OS. Skype runs and I can hear the noises, but all calls result in "Problem with audio". This is obviously a permissions problem with the microphone device, because if I run Skype (briefly) with sudo it works fine. My options:

Run skype with sudo, and also hang out a giant 'hack me please' sign on my front door.

Try to find the microphone in the /dev directory and chmod it, get into a permissions war with my own OS. (Best case: all security except the LED that apps can't spy on me ... is blown. Worst case: I also have to repeat this step who knows how often.)

Figure out how to wrap skype so that Sugar gives it the right permissions.

Homunq 16:41, 10 January 2008 (EST)

No, that's wrong. sudo has nothing to do with it. The first call works, subsequent ones don't. Go figure. Homunq 16:46, 10 January 2008 (EST)


I followed both set of install instructions and came back with the missing error why I typed "skype". Any ideas how to proceed.

Okay. I fixed it by doing: wget rpm install (the above file)

Error: Cannot retrieve repository metadata (repond.xml) for respository: olpc_koji-ship2.

When attempting to install Libasound, getting the following error. Can anyone help? "Error: Cannot retrieve repository metadata (repond.xml) for respository: olpc_koji-ship2. Please verify its path and try again"

PDS I got that message when I wasn't networked properly and/or the OLPC repository was down - I'd confirm you have a network connection, and try again. cannot open shared object file

After having done SKYPE download instructions, I get this error. Can anyone help?

As of 8/12/2010 the problem continues. says:

I got this too when I followed the instructions on the Skype page under "Standard". I did yum install which seems to have installed the necessary bits because Skype launched.

I couldn't create an account following the link on the Skype sign in page for some reason, so I created one on my regular machine. After that, I was able to sign on using my OLPC and make a call.

Downloading Skype - Help

I've been trying to download Skype and it was working fine until I got to the step where you actually run the program for the first time. I couldn't get it to work and was not sure if anybody could tell me why or give me a suggestion on how to fix it? Also once it's completely finished downloading will it appear in the normal application bar at the bottom of the XO? Thanks!

i get the same problem...


You won't get an icon to launch it. Run Terminal, and then type 'skype' there to launch. --morgs 10:34, 21 May 2008 (EDT)

Installing gstfakevideo

I was wondering how I copy and install the file once I download it to a flash drive and plug it into my XO? Thanks!

See Skype#Installation. --morgs 10:40, 21 May 2008 (EDT)

More installing gstfakevideo

I was able to install skype. When I tried to add video, I am stuck because I dont know how to do the following:

"Make sure the video pipeline is correct by editing the gstfakevideo script (e.g. vi gstfakevideo) and changing the 'export GST_PIPE=...' line to read:

export GST_PIPE="v4l2src device=/dev/video1 ! ffmpegcolorspace ! videoscale"

Also make sure to delete any other lines that set GST_PIPE later in the file! (Like line #42 of gstfakevideo.)"

How do I edit the gstfakevideoscript? How do I delete other lines and which lines?


new skype version

In the skype website you can find only the new version fo linux so the standard and simple way to install it in the OLPC change a little:

cd /var/tmp
yum --nogpgcheck -y localinstall skype-
# all done; just run:

Skype Static

At 2013-09-27 Skype Static is discontinued. Linphone works. Psip might also. Just as well to avoid the proprietary software. Regards, ...Peasthope 13:38, 27 September 2013 (UTC)

Please merge this information into the main page, up the top, since it is a fundamental block to using Skype. --Quozl 22:14, 27 September 2013 (UTC)