Talk:WikiBrowse (old)

Jump to: navigation, search

Could not install

I tried installing wiki browse directly on a B4 machine, by opening the .xo activity from the Browse Activity, then Resuming it from the Journal. Eventually the journal opened, but was consuming 100% CPU time and moving very slowly. When I Resumed the WikiBrowse activity, it appeared on the activity dock, but wouldn't start up.

I'm using Build623 on a B4 with CL1 Q2004 Q2D firmware. -- 16:31, 29 November 2007 (EST)

Aha! The file @ wikibrowse-8 was really v.5, which needed a fix to work in /home/olpc. Try the currently linked file. That's working for me on 649, an should work on 623+. Sj talk 01:57, 4 December 2007 (EST)
Worked for me now - I've moved to build 649. Most of it seems to work really well, and I think it is a great idea for an Activity. Could you possibly document how to add other wikilibraries? I'd really like to be able to access the full text based wikipedia dumps that are made available [here], maybe from an external USB key (don't know if this is possible). Also - I couldn't get Alice's Adventures In Wonderland to load - is this because of the apostrophe? (Path was /home/olpc/Activities/WikiBrowse.activity/wp/a/Alice%s_Adventures_in_Wonderland.html ). --Tomhannen 05:17, 4 December 2007 (EST)

Hi Sj, Like Tomhannen I really want to know how you convert the wikipedia xml dump in .htm pages usable by WikiBrowse because I would like to make a French version of WikiBrowse. PatrickHetu 12:38, 25 December 2007 (EST)


Hey sj, it's been awhile. I'm not sure where to report bugs, so I thought I'd let you know here -- presently links to pages that contain parentheses in the title (e.g. Matrix (mathematics) ) are not generated correctly. Is there a general place to report bugs for OLPC projects? If so, I have a lot of feedback to give on plenty of other things as well. --Improv 14:58, 25 January 2008 (EST)