Jump to: navigation, search

why bother with system-config-services, when one can simply use chkconfig?

Anyone else having trouble with Gtk*** cannot open display because of an MIT_MAGIC-COOKIE-1 authentication error? It happens when I add wifi-radar -d to the automatically starting applications and disable the network manager. I notice that I am no longer XX-XX-XX-XX but localhost and thereafter dhcppc3 (once wifi-radar connects)?

I am losing the mouse cursor in XFCE, after following the instructions exactly. Everything works - it's just that the mouse cursor disappears, making everything a bit pointless. Any ideas?

Gian Pablo: I had the lost mouse problem and couldn't figure it out. I reflashed the OLPC to build 656. I did an olpc-update to update1.691, reinstalled XFCE, and everything worked fine from then on. (Except wifi-radar, which has never worked.)

Wifi-Radar and Connectivity

Is anybody using Wifi-Radar successfully? If so, with what sort of network connection? Is anybody successfully using another method?

I am able to connect to my personal WAP using the method described on the Manual Wireless Association page. I've created a script as follows (run as root):

/sbin/dhclient -r #turn off dhcp if on
/sbin/service NetworkManager stop
/sbin/service network stop
/sbin/iwconfig eth0 essid "mywapname" key 26hexdigitkey
sleep 5 #iwconfig comes right back, let connection settle
/sbin/dhclient -1 eth0

This proves I can connect, but is obviously not a great long term solution.

When I run wifi-radar it fails to establish a DHCP connection. It fails so poisonously that I have to turn the XO off before my script will connect again. I am running my WAP with WEP 26 digit password.

Thanks - Rmyers (Bob Myers)

- I feel like this section on wifi radar and getting wifi up and running needs greater expansion. I was able to follow every step of this short guide quite easily, but I couldn't get this wifi to work at all. My WPA setup wasn't able to connect, and there are a great deal of options in the Wifi Radar that are completely foreign to someone whose never used it before. Looking at some of the XO Laptop forums there are solutions to this problem, but they deal with hand editing files and wpa_supplicant.conf and all sorts of tricky stuff that isn't covered in this wiki. This feels like a specific case solution anyway, and would not be appropriate if you wanted to go to a cafe or something.

As well this wiki page doesn't explain why it's sometimes necessary to disable network manager, or why wifi radar is better than network manager either.

Tavis 04:53, 6 March 2008 (EST)

Yes, I use WiFi-Radar fairly successfully. I also selected a profile, clicked "edit", opened "Connection Commands", and added the line "/etc/init.d/NetworkManager stop" in the "Before" area, and this allows me to connect to an open wifi link without killing NetworkManager first in terminal, but I havent tried it with a locked node yet. See other comment below re: accessing built-in tools.

Sunglint 16:00, 17 March 2008 (CST)

"Yes, definitely needs more explanation. I initially was able to get wifi-radar working fine with my parents encrypted network but after the first reboot it never worked again. it always says "Connected to mynetwork ip(None)". I'm at a loss." -- Zimm

"igot mine working it took me a whill to figer out what the problem is it turns out you have to dissmantell networkmanager and then dismantel it for good (you can turn it on agian) after you dessmantill it run wifi-radar it will work then after you rin it dissmantell networkmanager for good. i hope this helps it did work for me (i gostill build 703)

how about WICD i have it installed you dont have to worry sbout that stuff it works well to "FAST!" it took me awhile to install but i did it

Automount of SD-cards (and other usb-mounted memory)

After changing my .xsession to launch xfce, I found that my SD-cards are no longer mounted. Further investigation showed that it is the Journal activity that is in charge of auto mounting the internal and external usb-memory as they are inserted into the computer. So how do you get the corresponding functionality when running xfce? It would be great if this was explained on this page.

done -- 12:00, 22 February 2008 (EST)
Thanks! --Dov 02:38, 24 February 2008 (EST)

Accessing Built-in tools via XFCE

I know that there are a variety of built-in applications that are accessible via or as activities in Sugar. I'd like to be able to access these in XFCE, either by terminal call or (ideally) as icon/shortcut in the menu. For instance, I want to read a pdf, and I know that I can in "read", but how to open one in XFCE? And how to tell firefox where the pdf reader is? I realize that Sugar is a great environment, and laud the awesome work done in the entire project, but I must echo other calls for an "adult" implementation. This could hopefully be a script that installs xfce, sets up .xsession, and adds the links mentioned above. Then at reboot in XFCE implement a session-manager type choice for the reboot. -- Sunglint 16:05, 17 March 2008 (CST)

To directly start activities, you could try a hand-written "adaptor" script similar to the one described for Helix. If this does not work (e.g. if it cannot run without a sugar-shell running), then you probably have to install alternative tools that work with XFCE (such as xpdf for PDF reading, not sure if his works with the available resources on XO). --Markus Krötzsch 04:12, 2 May 2008 (EDT)

RPM instead?

I wrote an rpm that installs and configures the scripts for screen brightness, battery status, volume management, etc. I also wrote an rpm to install xfce desktop properly and configure the hotkeys using xbindkeys. is there somewhere i can post this package besides my personal website? is there a process for inclusion into the repo? -michaelfavia

note on this

michaelfavia added the link to his rpm, and removed the discussion of how to do this longhand for those that might want to understand the process. Look at the March 16th, 2008 edit to see the longhand version. Rmyers 18:01, 29 April 2008 (EDT)

Need to Double Boot. Why?

If my XO is set to boot into XFCE, after a power down I usually have to boot it from power off twice. The first time, the XO eventually gets to the Sugar ring, and seems to stop. If I tap the power button, the screen shows the XFCE mouse emblem, and a watch cursor. The cursor cannot be moved. If I power down and then power up again, the XO successfully boots into XFCE. Anyone know why this is happening, and what can be done about it? Rmyers 20:27, 31 May 2008 (EDT)

  • Answering my own question here. Getting rid of the boot animation eliminates this issue. It doesn't answer why it happens Rmyers 21:49, 8 July 2008 (UTC)

How to switch screen to tablet mode (1200x900 monochrome)?

I have not found any info on how to do this in XFCE (not sure how to do it in Sugar).

TIA, Rokky 03:45, 7 September 2008 (UTC)

olpc-keybind problems

The olpc-keybind RPM works for its stated purpose: the brightness keys do work. Unfortunately, it leaves the rest of the keyboard useless: pressing any other key in a terminal window blinks the cursor, but nothing else happens. Any suggestions? -- 01:45, 8 September 2008 (UTC)

Im the author of that old RPM. The src rpm is there for anyone willing to take a look. If i have a moment ill do so myself and push a new version out that is a lot better. --michaelfavia Notes for build 767

On Notes for build 767

The same can be achieved easier and more in Unix style by adding the user to the groups (/etc/group) "messagebus" and "netdev". At least on Debian and most likely Ubuntu.

This might enable more than you want, though. The dbus config is more fine-grained.

programs we would like on Xfce

does anyone know how to ad wine for xfce any other programs you would like to see

yes, to simply install it do

# yum install wine (replace wine for other programs such as tux pant or frozen-bobble)

please note aim not with olpc any more (i got a real laptop) and ruining wine on the laptop slows it way done (not all programs work) (i have had it be4). Everett ~

article not up to date?

package xfce-mcs-plugins doesnt exist says my terminal/sugar version. in the article there are links to non-existant-anymore files etc. maybe someone skilled should mark it as not up to date and link/actualize it to sugarlabs wiki?

This article is no longer up to date!!!

Major revisions are needed on this article. This article may be of some help to... Well I don't know... Last edits were made in 2008... It's currently 2011 so everything is out over date.