Talk:Release notes/10.1.2

From OLPC

Jump to: navigation, search

Contents

Add Mac-specific Instructions

Hi..

I suggest you incorporate some of the features of the old "No Fail" update, especially the Mac-specific instructions for downloading directly to the usb drive. -- Caryl

Thanks Caryl, but there's no need at this stage. Once 10.1.2 is released, we'll edit the "No Fail" update instructions to use the 10.1.2 links, and add XO-1.5 support. The installation instructions in the Release notes pages are for a different readership, and I'd prefer them to be succinct. I do think that some of the "No Fail" update steps could go into specific Wiki transcluded template pages, like "How to download a large file reliably on various operating systems". -- Quozl 01:56, 9 August 2010 (UTC)

Clarify Rename

Hi James,

I was going to do a simple edit to prevent the problems I had with the update, but the text is hidden in another place that I am told does not exist when I try to go there. So... here are my suggestions for small changes to the instructions for both the XO-1 and XO-1.5:

Where it says:

  • Download os851.img.fs.zip,
  • Save the file to the top directory of a USB memory stick,
  • Rename the file to fs.zip,

Change the third line to:

  • Download os851.img.fs.zip,
  • Save the file to the top directory of a USB memory stick,
  • Rename the file to fs.zip, (just fs.zip nothing else)

-- Caryl

We already seek to clarify the task step by asking you to check the file name on the USB stick after copying it. The text you propose seeks to clarify the same thing, again, so I'm not sure how effective it will be. I've added some other text instead; instructing people to remove the os851.img portion of the filename. Do you think that might have worked on you? -- Quozl 05:26, 17 August 2010 (UTC)
The problem arose because the Mac appended ".txt" to the file. So when you said to make it "fs.zip" I thought you were referring only to the end of the file name, not the entire name. So, I left the part that said "os851". The file came through as os850.img.fs.zip.txt on the Mac. The ".txt" should probably be dealt with too.
BTW... I am struggling to get the XO-1.5 version downloaded. I think maybe it is due to too many users on our isp. They have an antenna that covers many square miles in our valley. The other night I was able to do the XO-1 version straight through, starting very late at night. Last night that didn't work. I will try it in Terminal tonight. I'm off to town to teach the folks at Montana State University how to update the XO-1s and give them copies of the files.
-- Caryl
That is strange. I've tested on Mac OS X 10.6.4 with Safari 5.0 by using ctrl-click on the os851.img.fs.zip file, and after download it is certainly not changed in name. It is os851.img.fs.zip. There's no .txt. I know this appending of .txt happens with the .crc file, but that's not what the instructions are currently talking about. I can only guess that an older version of Mac OS X or Safari is responsible. For download struggles, I suggest you use the curl method, which restarts from where the previous attempt left off. There may be better download managers for Mac OS X, but I don't know what they are. -- Quozl 00:42, 18 August 2010 (UTC)

Terminology Bikeshedding

Everyone, it is not a memory stick (that's a Sony product!!), or a thumb drive or a pen drive or a key or whatever cute pet name you favor. The actual product name on all the packages, on Amazon, in Wikipedia, etc. is a USB flash drive. Please be consistent! (my pet peeve :-) ) -- skierpage 02:38, 26 August 2010 (UTC)

Please create a terminology page that we can link to. Please also ensure that we can link to it for USB storage devices that are spinning hard drives, since these are often used instead, which is why some references use "USB device". "Key" should be avoided since it is easily conflated with developer or activation keys. -- Quozl 08:43, 26 August 2010 (UTC)
Back in 2008 terminology was part of OLPC:Style_guide#Writing, which has a "Specific words" subsection that mentions "USB flash drive". I've never tried installing from a USB hard drive, there may be some limitations in the XO firmware. If either USB flash drive or USB hard drive works, then you can say "insert USB drive"; there's a page for USB drive. "USB device" includes lights, fans, chargers, etc., so I wouldn't use that term. -- skierpage 11:07, 26 August 2010 (UTC)
Thanks, but I've worked really hard to make sure that OpenFirmware on the XO has good support for large and small USB storage devices, if you've an actual problem then please report it. There are occasional problems due to substandard hardware, or unusual filesystem formats, but in the majority of cases it works fine. I'll take a look at adopting USB drive. -- Quozl 01:03, 27 August 2010 (UTC)

Changes since 8.2.1

Before launch, I think this should give a high-level overview of changes since 8.2.1, summarized under "Purpose" section and with more meat in "New features" section. Things like:

  • Fedora 9 -> Fedora 11
  • Sugar 0.82.1 to 0.84.16, new firmware
  • addition of Gnome option

Later on when enumerating new features incorporate the changes in 10.1.0 and 10.1.1 rather than refer to them. -- skierpage 06:40, 26 August 2010 (UTC)

Before launch? No, we won't delay release because of this issue; you're the only one who is troubled by it at the moment. I'm happy with the amount of detail in the release notes now. Further information might be added after release, or even a page for guidance to users of 8.2.1 who might consider 10.1.2. Such guidance would be quite complex, and unrelated to use of the release in a new deployment. -- Quozl 05:06, 27 August 2010 (UTC)

XO-1 users should check Software update's Activity group!

I think that if you upgrade an XO-1 to 10.1.2 (rather than reflashing it), then Software update may grab the larger XO-1.5 set of activities. This happened to me, I think because I had a ~olpc/Activities/.groups that contained http://wiki.laptop.org/go/Activities/G1G1 , and I think this means Software update uses http://wiki.laptop.org/go/Activities/G1G1/10.1 , the big list of activities intended for XO-1.5. (The process is explained at <http://wiki.laptop.org/go/Software_update#Activity_groups>).

If people agree and/or can reproduce , then I think the section for updating an XO-1 should caution:

XO-1 users who use olpc-update to upgrade to 10.1.2 may get the much larger set set of default activities intended for the XO-1.5 (which has more storage capacity). If you don't want these, when you first run My settings > Software update,
  1. cancel the update
  2. click "Modify activity groups"
  3. If it shows "http://wiki.laptop.org/go/Activities/G1G1", click this, click [Remove]], then enter the group URL "http://wiki.laptop.org/go/Activities/G1G1Lite" (note Lite on the end) and Add this.

-- skierpage 06:40, 26 August 2010 (UTC)

Yes, this complexity is another good reason to remove the update section altogether. We don't have the resources to get it perfect and it may cause more problems than it is worth. The default set of activities in the XO-1 build does not need to bear any relationship to the set of activities available via Software update, and a user should not try to download and install more activities than can fit on their available free space. It seems Software update allows more downloads than can be fitted in. Someone might test that, and propose a fix to Sugar to warn the user. We won't be blocking the release for that though; it is a relatively insignificant problem, so it would be best to handle this issue through trac. -- Quozl 01:26, 27 August 2010 (UTC)

Can't get to Software update without scrolling

You have to scroll sideways with in My Settings in order to access Language and Software update. -- skierpage 06:40, 26 August 2010 (UTC)

Yes, but that's normal for Sugar 0.84 (SL #232), and teaches the use of scroll bars very well. It is easily discovered. I don't think it is sufficiently important to clutter the release notes known problems section. I'd prefer to use that section for problems with significance or notability. -- Quozl 01:14, 27 August 2010 (UTC)

Is incompatible with Teapot's Ubuntu

After installing OS852 I couldn't boot up Teapot's Ubuntu. The message:

Can't open boot device

is displayed. However, OS850 is compatible with Teapot's Ubuntu. Is there any thing I can do to be able to run Teapot's Ubuntu after updating to OS852?

Can you please point me to this Teapot's Ubuntu build? It sounds just too old, if it is 8.04. I've just done an Ubuntu 10.04 and 10.10 beta build for XO-1 and XO-1.5, see my mailing list posting. This problem does not occur using my builds. What you report is similar to a previous report in ticket #10307, and it is interesting to hear that it used to work on os850 ... that's a surprise. The fix should be to adopt the more recent olpc.fth file from the os852 build and merge it with the changes that were made between the os802 olpc.fth and Teapot's Ubuntu build. It isn't a problem with os852 per se. -- Quozl 02:18, 6 September 2010 (UTC)

USB update missing file

Cannot easily find .toc file to go with .usb file.

Good point. The links were missing. I've added them. -- Quozl 23:02, 28 October 2010 (UTC)

My OLPC now acts like a useful notebook

(this is my first attempt to edit; hope I am doing it right) Yesterday I downloaded build 852 for my XO-1 which had build 851.

Release_notes/10.1.2#Installation

There are two basic operations described.

  1. Simple Online Update which requires a working XO with an internet connection, and may take up to five hours. (note: Release Contents are somewhat confusing--it would help if the section.subsection numbers carried through to the actual text.) This begins on page 4 of the Release notes.
  2. Installation, which is what I chose, and would recommend to most. I had no particular files I wanted to save so erasing them from the XO completely was no problem. If there were files to save I suppose they could be saved to a USB drive (stick, card, whatever:) first. (this starts on page 2 of the Release notes/10.1.2)

After deciding on the operation, then I made the choice to XO-1 which is what I have. (page 3 of Release notes) It went very well:

  • Entered the address http::// ... /os852.img and downloaded it to my desktop.
  • Entered the address http::// ... /os852.img.fs.zip and downloaded it to my desktop.
  • Plugged a USB drive that had been previously formatted to FAT-32 into a USB port. (note: that is the same USB drive that I used for the 851 build update so I copied those over to a folder before removing them from the drive)
  • Copied the downloads from steps 1. and 2. onto the USB drive.
  • Edited the name of the download of step 2 to precede it with "fs.zip" and removed "os852.img."
  • plugged the USB drive into the turned-off XO
  • Proceeded as described in Start Installing

All went smoothly and took about five minutes.

  • As it restarted, I saw the USB drive symbol, ?, and a laptop symbol. "Sugar Labs" displayed on the lower left. This was quickly replaced by the XO symbol and surrounding dots. It asks for name
  • entered a name for my XO and clicked "next"
  • Asked to click the symbol to change color; this can be ignored.
  • Then the familiar sugar circle is displayed.
  • Click on the symbol and select settings. The new item is on the lower right of the screen and resembles a paw. Click on that.
  • I am told to restart. Restart the XO and then you see the GNOME DESKTOP (which by the way is very MAC-like).

02/10/11 17:25MST -- Generalludd

Thanks. Please try Release_notes/10.1.3 as well. It has far fewer known bugs. Build number os860. The section number lack is a Wiki default, but you can click on them in the Contents, or visit Special:Preferences to turn on Auto-number headings in the Misc tab for yourself. Page numbers don't mean anything, they can change according to screen size and font size. Congratulations on your contribution. --Quozl 01:21, 11 February 2011 (UTC)
Installed 10.1.3, as suggested. Thanks for the suggestion (from whoever entered the edit on 01:21, 11 February 2011 (UTC)). 10.1.3 installed smoothly and runs very well, as far as it goes. The Gnome desktop is very clean, but most of the applications go nowhere. I still reach dead-ends with no clue as to what to do next. For further entries from me, see the Talk:Release_notes/10.1.3. Perhaps my main problem is I have to remind myself "It's not a MAC":). --Generalludd
Please sign your entries. It is convention to sign entries in talk pages. This convention comes from Wikipedia, and we are using the same software for our Wiki. At the end of my edit you'll find a signature. I made it by typing two minus signs then four ~ signs. The signature should tell you that it was User:Quozl who made the edit. Following that link should lead you to my user page, which has my human name. You don't have a user page yet.
I've tested all the supplied GNOME applications on 10.1.2 and 10.1.3, and they don't go nowhere for me. I think you need to explain further what go nowhere means. Perhaps you haven't used GNOME before? OLPC uses GNOME without any significant change from where GNOME came from. See http://gnome.org/ for more detail on GNOME. --Quozl 05:59, 15 February 2011 (UTC)
Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox