Jump to: navigation, search

Missing activities

Ignore last entry - we solved the problem and are proud of non techo selves for doing so.

We did an update and lost the menu bar on the bottom of the screen so we cannot access the internet or terminal or any of the other activities. What to do????

See OLPC Update.1 Software Release Notes - on newer builds you need to install the activities separately. --morgs 07:37, 24 July 2008 (UTC)

Where the _bleep_ did my stuff go???

I just updated to 656, using the internet incremental update. Everything I installed on 653 is gone -- Java, Flash, XFCE, OpenOffice, a Java application, preference folders. You get the idea. However, all the space that they took up still seems used. I'm not back down to anything resembling a 300mb clean image.

So where's it hiding? Can it be recovered? If it can't be recovered, how do I reclaim the space?

IMO, there should be a big red warning on the update page about losing non-standard installs when updating. Better yet, why doesn't it respect what I've got on the machine, given that this is an incremental update that looks to be repeated fairly regularly as the base software evolves. After all, when I update from MacOS 10.4.10 to 10.4.11, all my non-Apple apps and data don't go away.

Rmyers 12:28, 1 February 2008 (EST)

Progress report

Ok, it appears my stuff is in a tree rooted at /versions/run/653. Given my limited linux experience, is there an easy way to 'mv' my stuff back into the main tree?

Rmyers 13:09, 1 February 2008 (EST)

Rmyers, during the update, anything in /home/olpc should of been left alone. However, any programs installed by 'root' in system folders will be 'removed' (essentially a 'clean' environment is created for the update). The suggestion method in the new environment, is re-installing all of those applications with the latest versions, to assure best compatibility with the newer OS.
Other than that, there are two options for you.
  • Hold down the (0) on the game pad, when you boot up. This will give your older environment back. (including the older OS).
  • Do a 'diff' between / and /versions/run/653, any difference you will need to determine one at a time, if you can apply to your current environment. You will then be able (as root) 'mv' or 'cp' them over. (not a task I enjoy, I assure you!)

As a developer, what I have done to minimize re-installing, is manually installing some of these applications (i.e. firefox) in /home/olpc and running them from there. Good luck. --ixo 03:09, 6 February 2008 (EST)

It should be possible for someone (yeah, I guess that means me) to write a script that goes through the last version and the current version, finds all the files which were in the last version but not in the current version, and prompt for pulling them into the current version. Note that this may take me a bit longer to write than it should, because I'm used to coding in zsh and perl; it's been a while since I've done bash and python. --tgape, 02:15 28 February 2008 (GMT)

Feature Requests

A request from a non-programmer for olpc-update and olpc-update-rsync commands:

Provide a --list (-l?) option that shows all available builds (easier to remember)
Provide a --changelog (-c?) option that shows a builds changelog (olpc-update -c build-609)
Provide --help (-h) to explain its usage, and the above options

HoboPrimate 00:04, 5 October 2007 (EDT)

 Done. You'll need very recent pyvserver and rainbow RPMs to try 
 these out. Also, you'll need to convince cscott to put ChangeLogs 
 in the rsync modules. (Or volunteer to do so yourself). 
   -- Michael Stone 01:54, 5 October 2007 (EDT)

When I click latest release, I see no file named osXYZ.usb, I see one called osXYZ.img, osXYZ.toc, etc. but no .usb. What gives?

Simplification needed

Gosh, this page is meaty and full of great stuff. However, if we are going to send users to it, it needs to be much simpler. Pictures are not out of the question. Alternatively, if there's another page to send users to for this, this we need to link it prominently in eg Support_FAQ. (And the Stable_Upgrade page is not even as clear as this page is).

On a related note, (why) do you need to specify the branch to get ship.2-653 ? This is counter to the documentation on this page. Edit: 653 is in a stable tree, but may not be officially stable in some sense (650 is still on front page of Wiki). I'm seeing conflicting reports of upgrades (usb and olpc-update) to 653, some not booting without a dev key. Thanks, --Adricnet 02:23, 25 December 2007 (EST)

Sorry, I have been trying to keep an open mind about this project, but it's just too complicated for most people, and certainly for me. I'm a principled but decidedly amateur linux user since the late 90s (RedHat 5.2 through Fedora 8), and I have managed to keep a working desktop most if not all of this time. (B/T/W, by "principled", I mean that I use linux as a way to avoid using MS and Mac.) But the OLPC XO is beating me. With OLPC, the lack of consistency between updates (i.e., the update method changes radically with every upgrade), the redundant terminology (i.e., "build" & "series") and the over-the-top elements (i.e., the need for a "developer key" to run anything besides Sugar) is just taking a toll on me. I'll stick with it as long as I can, but I'm fading fast ....

How to get current Build Number? Unsuccessful olpc-update

(I'm a retired developer, but almost no Linux or Unix expertise.) First, there must be some some command to retrieve what build is in the machine. olpc-update --version does not give a build. Second, I did run through the olpc-update -rv 653 apparently successfully, but it refused to reboot because I have no developer key. Do I have to have one to update manually? If so, how do I get one. Thanks, --Javerell 20:20, 28 January 2008 (EST)

You shouldn't need an developer key, however you can request one easily. To tell what version you have, type "cat /etc/issue" on the terminal. ffm 17:33, 29 January 2008 (EST)

Second user having the same problem, first with 656, then retried with 653. It wanted a developer key (havng verified). I'm a give one get one user. Thanks to the above, I have verified I'm on 650, and I want my machine to hook up through a WPA link to my router - hence my need for 653. So, pretty please - can someone clear down the 'developer only' flag on this release - otherwise no one can show G1G1 in use with a domestic router (as I want to do at a schools engineering day next week). 2nd Feb 2008 20:51 GMT (and yes, I'm the the UK!).

These 'unsigned update' problems should be fixed last night. I talked to one of the developers about it, who recognized it as what an older version of olpc-update would do. He corrected the offending wiki page, and I was able to update with the new instructions. 28 Feb 2008 02:24 GMT

Keep getting error: "could not download update contents"

I've been trying

#olpc-update 653

for days now. All I get is

"Could not download update contents file from: rsync:// I don't think you're connected to the internet."

I'm logged in as root (su -), I have a dev key, I can ping myself, my router, google, everybody as far as I can tell, *except* olpc-update!

Has a login step been left out? If the server is down pending changes to the build, please put a box to that effect somewhere, so we poor schmoes don't knock ourselves out trying to fix the unfixable.

olpc-update failed for me as well: rsync: failed to connect to Connection refused (111) rsync error: error in socket IO (code 10) at clientserver.c(104) [receiver=2.6.9]

Could not download update contents file from:


I don't think yhou're connected to the internet.

I'm told outgoing connections from here ( are not firewalled, incoming are.

Merge, re-organization, and page split

I 2nd, the proposal of a page merge with Stable Update (most of the information is already here).

Then, I also recommend looking at this current page and split it out into three pages with completely seperate content focus.

  1. Sugar update (General Public: How to go from current stable build to next stable build)
  2. olpc-update (General Public: Command Reference: The command and various options, examples)
  3. Sugar joyride (For Developers: Living on the edge differences between Stable,Ship,Update, and joyride builds)

I think the page currently mixes these concepts together 1) General public will have difficulty understanding what is needed, 2) Developers don't need to know about stable 'simple' upgrades, 3) there's more details and background missing which developers might want to know about the 'joyride build' stream.

This re-organization might even blend into several other pages, which duplicate this page information (presented in different incomplete forms). And a simple link back to one of the 3 pages above would suffice.

If this sounds like a good plan, who would be willing to assist me with the re-org? :-)

Thoughts? --ixo 02:37, 9 January 2008 (EST)

Merging the pages should be a no-brainer. Having the same information multiple places almost guarantees that when a human updates the wiki, at least one of the places will not be correctly updated. Separating the pages by user class should only be done if it can be done in such a manner as to not duplicate information. (It may be possible to do this by such means as putting how to manually update the olpc-update program on its own page, so that both the olpc-update page and the Sugar joyride page can reference it, for example.) --tgape 02:48, 28 February 2008 (GMT)

ERR: No space left on device

I am upgrading from 650 to 656. Connected to Internet. Several different attempts are made, but each ends with No space left on device. I have not done very much with the XO -- some web, some Tam Tam, -- really pretty minimal (my daughter is 2). Please advise.

EDIT: I tried a few more times and it went through. I think it was a server error. Feel free to delete this if it is not helpful to people.

== Same problem. My errors start with: Rsyncing: lib/modules/2.6.22-20071231.2. ... /kernel/sound/core/oss @ERROR: Unexpected server greeting: fakeroot, while creating message channels: No space left on device

I have tried several times with out luck. Tried deleting the few activities in the journal. Tried upgrading to 653 and then to 656 but couldn't get 653 to connect to the internet. --pkv

== 2/21/08, similar problem: olpc-update -rv 656 yields downloading contents of build 656. @ERROR unexpected server greeting: fakeroot, while creating message channels: no space left on device rsync error: error starting client-server protocol (code5) at main.c(1383) [reciever 2.6.9]

could not download update contents file from rsync:// I don't think the requested build number exists.

== 2/23/08 same problem. I have tried freeing up space on my machine and tried the update 5 times with no luck. Is a total re-install from a thumb drive the only option? I would prefer to do the 'simple' upgrade if possible but cant seem to get past this. anyone know what the free space requirements of 656? cmv

== 2/25/08 Same problem. When I do du I get 4931, with df:

mtd0 32% used 715164 free mounted on /

tmpfs 0% 35676 free mounted on /dev/shm

so there is plenty of room! Ideas? --WiseWoman


OK, I found the Activated Upgrade (recommended procedure for 656 upgrade but will wipe out any user data/programs) instructions at

Downloaded the two files to a USB flash drive, followed the instructions and I now have build 656 on my G1G1 XO. --pkv

UnSuccess (for me)

Once I got to 656 (and even after I downgraded to 653) I haven't been able to upgrade again. No matter what build I put in. Mainly, I'm trying to upgrade to a Joyride build, but it keeps saying "I don't think the requested build number exists." However, I think it's looking in the wrong place. It tries to rsync to " as opposed to which is where the Joyride builds (I believe) are located. Any ideas? -ThePete

Another Success

Previous failure (see "no space left on device" comment above), but today (2/26/08) all proceeded exactly as spcified in "simple on-line update" proceedure. Only difference on my end was a speedier internet connection.

Please sign your comments with ~~~~. ffm 21:08, 4 March 2008 (EST)

updating olpc-update without internet connection

There is a need to have instructions on how to update olpc-update without a internet connection, for those cases where people with the G1G1 default build want to update to a newer build using USB to fix WEP problems.

Thank you for pointing out this "Catch-22" style problem! Here I explain what the two documented commands tell us.

 wget -P /tmp/X -r -np -nd

According to (which I hope is 100% valid) here is what the command above does:
wget retrieves files from the Internet using the Web's HTT Protocol
-P /tmp/X roots the top of the receiving file system branch to /tmp/X
-r recursively plumbs the source Web directory branch
-np assures recursion only goes downward is the source branch

Therefore if one uses any method to obtain the Web-based files at and below, which as I write this are just the two files

 olpccontents-2.1-1.20080131git7206e521fc.i386.rpm   and

and puts them on a USB drive to copy them into the X-O at /tmp/X the second (following) command should work just fine installing them:

 rpm -Uvh --force /tmp/X/olpc*.rpm

The only issue is how to move files from USB drives into the X-O. Plugging my USB drive into the provided port and going to the Journal, I dwell over the USB icon and read "18FB-3D54". Opening a terminal session (its startup icon is off the screen of the default Activity Circle view, so scroll to the right) I can verify there is now a directory branch named /media/18FB-3D54 holding my USB drive contents by issuing:

    ls -al /media/18FB-3D54

(This is useful to know in many other contexts.) I can then use the mv command to copy the downloaded rpm files from the USB drive to /tmp/X. First, I find I must create the X directory under tmp to follow the exact rpm syntax cited above:

    mkdir /tmp/X

If I put no other rpm files in the root of the USB drive, I can then transfer the files using:

    mv /media/18FB-3D54/*.rpm /tmp/X

- Docdtv 00:33, 27 March 2008 (EDT)

User comments on USB upgrade

moved from wiki page to talk page. Cjl 10:19, 31 March 2008 (EDT)


Add note about firmware upgrading

And how this happens automatically on OS upgrade on first reboot. --Sj talk 12:08, 30 May 2008 (EDT)

Warning about wget of olpc-update needed for 656/G1G1 upgrade

The command: "wget -P /tmp/X -r -np -nd" appears to have kicked off downloading all of the files from the PARENT directory ("617-save.img", full-debian, and a large number of other files) - over 1.1 GB. I realized after the 1st attempt's saving in tmpfs blew its 120MB limit, that I needed to set up another destination dir on my 4GB SDHC card to isolate this effort. Looking back at my command history, it appears that the "-np" option was ignored if not reversed, but it was definitely there - all those extra files besides the 2 desired olpc*rpm files were in the parent directory - very weird!

Rokky 22:14, 10 August 2008 (UTC)

I'm trying to update from 605 to 711 and I had the same weird wget problem, but I think it may have been because of no trailing / at the end of the command? I ctl-c'd after the two files (and a few extra!) and it worked.

Lost "base" activities, but kept add-ons - say what??

After the update I finally figured out per my previous post just above, now my terminal "activity" is gone from the bottom menu along with other base activities like the TamTam ones. However, ones I added like GCompris are still there. Isn't that the opposite of what I should have seen after updating from 656 to 708?? Will those base activities be restored by the G1G1 "Activity Pack" referred to in the 703 Release Notes?
Rokky 01:17, 11 August 2008 (UTC)

YES, the G1G1 Activity Pack installation restored all the base activities I had "lost"!

And it seems that the added activities such as GCompris are also still available (hmm... not all though - need to investigate some more) - some consolation for the foregoing weirdness with wget.
Rokky 02:14, 23 August 2008 (UTC)

Release number in examples

To avoid confusion, you should really update all of the examples to 767 to match the current release. Alan Claver Alc 02:55, 16 October 2008 (UTC)

And keep updating it. especially since some sers are too harried & thick to realize they've copied the example withou reading the textproperly. <Ahem> Complex 02:26, 11 June 2009 (UTC)

XO Hacks, tips, tricks page

As per conversation on #olpc, add page to discuss advanced user hacks for the XO-1. One that is needed is a way to gain space by deleting /version alt-OS without damaging the olpc-update mechanism. CJB said he knew how to do this. A user borked his xo by trying to delete /version, so a safe way would be needed. (vs. getting a single OS jffs2 image). I have more hack to add but this was the first one needed. Kevin Mark kevix 23:00, 12 November 2008 (UTC)

Journal Full after G1G1 Update

Other than opting for a clean install, could this page link to advice to users on clearing disk space before the upgrade, locating downloaded files, and pointing out large file sizes, both already on the XO and in the new Activity/Library collections? Perhaps new generation machines have larger internal memory or I'm just great at accumulating clutter and cruft... As a 12/2007 G1G1 user who fell out of using my XO for a few months, I just upgraded my software and spent a morning with "journal is full" messages before noticing the size of the 90 mb Wikipedia collection, which was the final straw. I need an "annual housecleaning" instruction page and/or control panel utility, to help clear detritus from unused applications, find large pdfs, oggs or mp3s downloaded in the background months ago, some of which are not in Journal because they never opened successfully, etc. (Despite 25 years of computer use, I have limited experience with unix file structure from the command line, having gone from TOPS20 to VMS, CP/M, DOS, MAC/OS OS-X.) Robby 16:12, 16 November 2008 (UTC)


# rm -rf /versions/*/$OLD_BUILD_HASH_GOES_HERE

Which you figure out by looking at

# ls -la /versions/pristine/ 

and choosing the older folder.

ffm 01:59, 26 November 2008 (UTC)

Update from 10.1.2 (build 852) to latest (build 883) runs out of space!

It's been over a year, and I don't remember what I did to get to build 852. (I'm one of the original G1G1 folks.) I do have a gnome desktop if I want it, and on boot-up there's a logo for "sugarlabs" and "fedora remix." I thought I'd put debxo on, but maybe that was an earlier experiment.

Following the instructions on this page of the wiki, I su'ed to root, and typed "olpc-update 883". It trundled and tried several different rsyncs before giving me an insufficient space message. I have 397M free, 627M used on 1G memory. Trash is empty.

I haven't used the olpc much so I don't have any large user files I'm aware of, unless they're somehow hidden. The /versions directory shows only build 852 in /versions/pristine and /versions/run. (There's also the soft-linked dir /versions/running that points to /versions/pristine.)

Are "pristine" and "run" hardlinked to the same files? They're identical in all respects. If they're not hardlinks, do I need both? Obviously, if I could remove one, it would solve all my memory problems.

If I can't remove one of them, does anyone have any ideas how I might work around my space problem? Is there any way to point the temp files to use space on an sdcard, for instance? Quixote 13:15, 26 March 2012 (UTC)

The insufficient space message is a known problem for which we have update preparation steps listed. Please make sure you follow those steps before attempting olpc-update. Otherwise, use the fresh install method. --Quozl 23:07, 26 March 2012 (UTC)
Yes, I saw that about the size requirements and update preparation. I followed those steps. I was hoping that by squeezing out an extra few MB, I'd be able to do it. (397M seems like a lot :) ) I would dearly like to preserve my current setup, mostly because I don't remember how I did it. I'm sure a fresh install would be easier, since I have no data I want to keep, but I'd love to know how I got that switchable desktop between gnome and sugar. You wouldn't happen to know what where I find the procedure for that setup? I thought it was somewhere on the wiki, but haven't located it yet. Quixote 00:20, 27 March 2012 (UTC)
397M is not enough. You are doing a major upgrade, and most of the operating system files are to be replaced. The current release has a GNOME and Sugar desktop, so you may have forgotten that it was in the version you had already. To switch, you use the My Settings GNOME Desktop dialog in Sugar, and the Sugar desktop icon in GNOME. If you are switching between them in some other way, then that other way will be lost by olpc-update anyway. --Quozl 00:31, 27 March 2012 (UTC)
Excellent news. Yes, I'd totally forgotten about it being part of the version, but it makes sense. If it hadn't been such an easy process, I would have remembered it! Well, I'm off to upgrade the firmware and then do a fresh install using a USB. Thanks for your help! Quixote 02:10, 27 March 2012 (UTC)