Talk:Release notes/10.1.3

Jump to: navigation, search

Developer key required?

When doing an online update on an xo-1 system, running build 802, olpc-update says that I'm downloading an unsigned developer build and that the upgrade will fail. I stopped the download with ctrl-c. Is this a real warning?

Yes. What did you type after olpc-update? Some versions are unsigned developer builds. Do you really need deployment security enabled on your laptop? Wouldn't it be easier if you disabled it? --Quozl 23:41, 22 July 2011 (UTC)
I used the command that the page says to use (I assume that the page talks about stable (= signed?) builds): sudo olpc-update 10.1.3_xo1-860
Thanks. That's interesting. It should work without a warning, because 10.1.3 is a stable signed release. I'll draw the attention of the release team for 10.1.3 and 11.2.0 and see if they can reproduce it and get it fixed for 11.3.0. Looking at the source code it seems to be a bug, in that the check for whether it is an unsigned developer build depends on the hyphen in the build name, and we added more hyphens for XO-1 vs XO-1.5 differentiation. --Quozl 22:35, 24 July 2011 (UTC)

Also the main page lists Q2E45 as the latest firmware for xo-1, but the page that describes the update process lists Q2E41 as latest. What is the latest version for a secured xo-1?

Both sources of information are correct. Q2E45 is the latest version. Q2E41 is the latest signed version for automatic update on a laptop with deployment security enabled. You may install the latest version by disabling security, flashing the firmware, then enabling security again. Or if you are from a deployment team, sign the Q2E45 firmware with your deployment firmware keys. --Quozl 23:41, 22 July 2011 (UTC)
Sorry, the situation has changed slightly. Q2E46 is now the latest version, as I just released it. But the rest of the information above remains unchanged. --Quozl 00:18, 23 July 2011 (UTC)
I'm just someone who bought a XO-1 to help with translations in the past (wanted to have a look at it again and decided to update the XO-1 but got these issues), never needed the unsigned builds for that. Disabling security can be done by requesting a developer key or is there an other way?
It might work using the --force flag to olpc-update. If not, you'll be forced to reinstall instead of online update. Otherwise, yes, a developer key is easy and automatic. Just follow the procedure. No bother for us. --Quozl 22:35, 24 July 2011 (UTC)

Switching to GNOME

The XO will start up with the familiar Sugar desktop. (The use of the Sugar OS is thoroughly covered by other documentation.)

Click on the central XO symbol then select "settings"

Look for the "paw" icon bottom-right.

Click on it.

Observe that you will receive dialog to leave sugar environment and enter the Gnome desktop. (technically 'Gnome Panel 2.26.3')

NOTE: None of the Sugar Applications will be available. If you have been on a network, you will have to re-establish the connection. Be sure you know the password to get to the server that you use.

NOTE: The Neighborhood, local, home, activity, and journal keys will not function. They may serve as function keys with some Applications. (Applications are what the kid-friendly Sugar interface calls "Activities").

Switching to Sugar

Following the "start, change, and stop principle", to get out of the Gnome Desktop: there is an icon on the desktop entitled "Switch to Sugar".

NOTE: Should you be in some application that obscures the desktop: At the lower left of screen is a small icon to click on which will hide open windows and show the desktop.

Double-click on the "Switch to Sugar" icon.

A dialogue will ask you to OK the selection. Then you will be returned to the Sugar desktop.

NOTE: If the neighborhood button does not show any servers, go to Settings>Network>and click turn radio on button.

Firefox in GNOME

Firefox, the internet browser supplied, when launched will display a window urging you to update to 3.6 or beta 4. Also sites that use Flash Player do not operate properly. --Generalludd 01:39, 13 February 2011 (UTC)

Yes, Firefox as supplied in 10.1.3 does that. If you ignore the urging, it should work fine except for sites that require Adobe Flash support. OLPC cannot include the Adobe Flash plugin in the operating system build because of licensing issues, so you have to go get it yourself. If you need to use those sites, then see our page Adobe Flash for more detail, which is current. --Quozl 06:15, 15 February 2011 (UTC)
Thank you. I have attempted unsucessfully to "go get" flash myself. The Adobe site always point me to The system requirements seem to way exceed the capabilities of the XO. I followed that path and got nowhere. See my comments under Talk:Adobe Flash. I think what I need is an earlier version of Flash. After all I ran flash (with Opera and Browse) two years ago and they worked. Many agree that Flash is a PITA, but we are stuck with it for some applications. --Generalludd 14:54, 20 February 2011 (UTC)
The instructions for installing at Adobe Flash - Firefox Browser (on GNOME) work fine for me on 10.1.3. Please follow them. --Quozl 04:24, 21 February 2011 (UTC)

Shutdown in GNOME

On the top menu bar, click on Systems. There you will find a drop down menu with Preferences, About Gnome, Log Out OLPC, and Shut Down.

Click on Shut Down and it will shut down. When you start up again (with the ON button), you will be returned to Gnome.

Sleep and Wake

When you close the lid of the XO, it goes into a sleep (or something similar) mode. The on indicator blinks slowly. When you open the XO, the screen is blank until you briefly touch the power button. (I put it on battery power only and closed it. I'm curious to see how long the battery will last in this mode.) --Generalludd 01:53, 19 February 2011 (UTC)

Apparently the battery is depleted very little. The light was still blinking several hours later and after restart there was still 80% or so. However; if left off for a long period (like overnight), the light no longer blinks and pressing the start button will result in a total restart. --Generalludd 15:41, 20 February 2011 (UTC)

Yes, this is a feature of Powerd that you can change if you edit the configuration file. By default, it suspends for a few hours, but if there is still no activity it shuts down fully to conserve power. If you have more power available than the average third-world primary school child, you may want to adopt more reasonable values. --Quozl 03:48, 21 February 2011 (UTC)

Re-establishing Internet Connection

As mentioned in the release notes, any wireless connection may have to be re-instated after a restart. If it doesn't do it automatically (in about a minute), right click on the network icon (next to the battery indicator) and be sure that Enable Networking and Enable Wireless are checked. Then shortly you will be reconnected. --Generalludd 15:47, 20 February 2011 (UTC)