Talk:Support FAQ

Jump to: navigation, search

Please Be Specific About Releases

This is a helpful page, but just a suggestion: the wiki woud not have so much out of date content if statements like this:

"Currently there are no activities that use the stylus. The Draw activity will work with a stylus in the next software update."

instead identified the software update in question and perhaps linked to the roadmap.

Make the FAQ page more user-friendly

Please make your suggestions here! -- Chihyu 17:57, 6 January 2008 (EST)


  • can we have a table of contents with larger font size? (grand)parents with presbyopia might have trouble reading the tiny scripts, as well as folks who don't use the "search" function of their browsers.

color scheme

  • what's a better color scheme than the current one?

re-categorize questions

  • separate troubleshooting questions from "how should I use X" questions
  • Why have all the headings/subheadings disappeared? Isn't this forcing users to read through 60+ questions regardless? Not everyone utilizes the "search" function in the browser... (more over, "Browse" doesn't have such a function!) --Chihyu 16:39, 24 January 2008 (EST)
  • can we have a top 10 list of most frequently asked questions on the top, and then have a categorized list of questions in the rest of the page? --Chihyu 17:42, 29 January 2008 (EST)
  • done --Chihyu 15:53, 30 January 2008 (EST)

Additions to FAQ

These issues have come up that have solutions:

Airplane_mode How to set local timezone via Sugar_Control_Panel

Other things have come up regularly that *don't* have answers. I imagine we're not going to recommend that G1G1 users update to joyride are we? is for Insects 01:52, 16 December 2007 (EST)

How To Get Started

I have received my two XOen and I am using my beginner's mind to notice everything I can for creating how-to information. Here is what I notice so far:

  • There is no instruction in the box or on the getting started page about what to do with the battery and anything about charging it the first time (or thereafter). I figured it out, but it would be good to have a clear depiction in the box or as part of some sort of progressive disclosure on the getting started page.
    • The XO serial number is in the battery compartment. Because the battery is a little tricky to remove later, it is useful to document the serial number ("CSN" followed by 8 hexadecimal numerals) before inserting the battery the first time. (Orcmid 14:56, 22 December 2007 (EST))
    • Uh, instructions on removing the battery are useful too. The latches are a little tricky and I found that I needed a screw-driver tip to lift the battery at the access slot. (Orcmid 14:59, 22 December 2007 (EST))
  • I have no idea what Name is being asked for on the initial power-up configuration activity. I have not passed that stage until I know more (and have taken photos and other notes for how-to purposes. Since I have no clue what is irreversible about the choice there, and what guidance there is on good choices (especially since I have two XOen), I powered-down at that point until I can figure out more or am willing to experiment with the first one out-of-the box to see what's up. It is not great that there is no clue about the purpose of the information requested and the consequences of supplying it.
Orcmid 12:28, 20 December 2007 (EST)

Changing handedness of pointers on an OLPC-XO

The OLPC-XO as shipped seems to lack a GUI configuration tool for sugar. So I've figured out a way which seems to correctly reverse the mouse buttons on my OLPC-XO. This is crucial for me to comfortably use the XO as I am left-handed. It's complicated and hideous for an end-user, and I'm not entirely sure I haven't munged some other parts of the system. I use xmodmap(1):

Open the "terminal" activity Copy the ".xsession-example" file to ".xsession" in /home/olpc (the default directory when the terminal is opened):

     cp .xsession-example .xsession

Edit the ".xsession file with vim(1):

     vi .xsession

Add the following line to the .xsession script:

  xmodmap -e "pointer = 3 2 1 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32"

Reboot your XO and the functions of the "X" and the "O" buttons on the trackpad will be reversed.

It is easy to mung the mouse settings with the xmodmap(1) command. If you succeed in doing this and lose control of the GUI, you can press <ctrl><alt><f3> to access a terminal. As shipped, the OLPC has no root password, so you can log in as root on the console, change directories to /home/olpc, and fix your .xsession file as needed. The xmodmap(1) command also works from the terminal window -- you can change the pointer button configuration back to right-handed temporarily by executing:

  xmodmap -e "pointer = 1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 29 30 31 32"

as needed. A wise coder will of course put this command into a script for future reference.

--Cshapiro 22:28, 5 January 2008 (EST)

How do I install Adobe Flash Player?

This one gets asked a lot. Shaving 1 min off of the solution will be a big win. Sj


which option do I take from Adobe? There are 4 or 5 possible for Linux?

How do I connect to a WiFi network that has a hidden SSID?

How do I connect to TMobile?

This one likewise. User:Sj

  1. Be sure the account has been setup previously.
  2. Click on Neighborhood, and click on the tmobile circle. Be sure you are connected. There will be a disconnect button on the pull down flag.
  3. Start the Browse Activity. When the home page appears, click in the Google search box and press the "Search The Internet" button.
  4. A login screen will appear where User and Password are entered, press the login button. The connection is made.
  5. This technique will work with T-Mobile and all AT&T systems as well; they have been tested.

-- courtesy of Kevin Donahue (RT #5254), copied & pasted by Chihyu 11:18, 30 January 2008 (EST)

Also, what if I didn't get the E-mail?

Here's what you need to know to claim the one year of T-mobile service:
  • Update: OLPC Customer Care has been sending out e-mails that provide the T-mobile PIN numbers. If you have received one of those (I just received three of them), you can use those PINs and go directly to the T-mobile Give1Get1 setup page. In that case, you can skip the business about the Order Reference Number, and e-mail address, going directly to Setting Up Your Hotspot Account, below. (Orcmid 15:22, 22 December 2007 (EST))
  • Use the e-mail address that you provided on your order and that is how OLPC Customer Care has been communicating with you (to confirm your order, and so on.)
  • Learn your Order Reference Number. This number is not provided in any order-time e-mails, although it is provided in the shipping notification e-mail (with subject "Thank You and Welcome to the OLPC Community!"). The number is also on the shipping label from Brightstar US. It is a 10-digit number identified as the P.O. on the large shipping label (not the FedEx label). There are no letters in the Order Reference Number (aka P.O.). The number also appears in small text on a second label that was on the side of the shipping carton I received.
  • Go to the T-Mobile Site to Create an Account and Claim your PIN. The e-mail contains an obfuscated web-site address that goes through some relay. (I hate this stuff.) This lands at an IP address (numeric without a domain name) that I was hesitant to provide here. The problem is that this is indistinguishable from a phishing attack and while it makes little sense for that (it probably being a lame way to protect the T-Mobile site from attack and PIN theft), this is the kind of thing that makes me go "ick." I have since found a link to the page from a confirmed OLPC page, so I have provided it here. There is also a nice T-Mobile PIN explanation and link page on the OLPC site (and you can use it to tell if your XO has shipped).
    • The T-Mobile G1G1 page will ask for your Reference Number and the E-mail address. There are terms-and-conditions that you should read also. There is nothing surprising but you should be aware of the limitations.
    • When you provide the correct information, you will reach a second page that lists the serial number of your machine(s) and provides a lengthy PIN for each machine. I Gave 2 and Got 2, so I see two serial numbers with separate PINs.
    • If your Reference (P.O.) Number is not recognized, the recommendation is to contact service AT (Orcmid 13:33, 24 December 2007 (EST) update)
    • The serial number of your XO is in the battery compartment (beginning with letters "CSN" and followed by a string of what appear to be hexadecimal numerals. I don't think you actually need the serial number for anything, but I decided to record mine so I don't have to pull the battery out again in the future.
    • The PIN is a 16-character alphanumeric sequence and you'll want to get it onto the clip board for the next step. I also saved the web page to my desktop computer's hard drive and printed it too.
  • The page that lists your serial numbers and PINs also links to a T-mobile page where you can set up your account by providing the PIN. From this point on, you only need to know the PIN. It is needed just long enough to setup the account.
  • Setting Up Your HotSpot Account: You can use any WiFi-enabled device(s) [only one log-in session at a time, but any device can be used in that session] with the account. What you are setting up is a 12-month free trial that you can extend yourself later on. The sign-up page comes up in a new browser window (thank you, thank you), so you can still see your PINs and can copy-paste them into the field on the sign-up page.
  • The 365-day unlimited T-Mobile access period commences with your creation of the account. You must create your account before June 30, 2008.
  • As part of account setup you will need to choose an User ID and a password (this will be used to log on to T-Mobile). You will provide an answer to a "secret question" chosen from a list for use in recovering your account if you lose or forget your password. You will also provide an e-mail address and a telephone number as well as your actual name (separate from the User ID).
  • After reviewing the terms and conditions, your account setup will be confirmed. I wondered if a previous, expired T-Mobile HotSpot account User ID was usable, and it was.
  • T-Mobile also has an Optional Connection Manager that can be used to make it easier to use your account at a Hot Spot. It requires Windows 2000/XP/Vista. The download page provides an useful overview as well as the link for the actual download (40.6MB). The Connection Manager works with all connections and provides auto-detection of WiFi access points as well as security support and log-in support. It might conflict with other WiFi connection managers, especially on Vista, but you may find it useful.
Orcmid 14:16, 22 December 2007 (EST)

BONUS INFORMATION. The G1G1 shipping-confirmation e-mail provides a link to an OLPC web page where you can download gift cards and also send e-Cards.' (Orcmid 14:16, 22 December 2007 (EST))

My XOen arrived today but I did not receive an e-mail shipping notice, tracking number, or T-mobile PIN and instructions. It may have been in my junk mail folder and I missed it. (The last time I checked here, I did not find this SupporFAQ page.) How can I request the information? (Orcmid 20:06, 19 December 2007 (EST))

  • Update: I did e-mail on December 19, but I haven't had a response of any kind yet. (Orcmid 15:33, 21 December 2007 (EST) corrected Orcmid 12:24, 22 December 2007 (EST))
  • Note to Others: If you are adding yourself to this list (such as the folks below), you need to identify yourself. It is very difficult to figure out who posted what by looking at the page history. The way to do this is with four tilde ('~') characters: ~~~~. When you save the page, it is replaced by something like this: Orcmid 15:33, 21 December 2007 (EST)
  • E-mail Arrived: This morning, I found an e-mail from OLPC Customer Care (service AT that, when viewed as HTML, provides the necessary information. It was in my junk mail folder and this was apparently not a response from my inquiry. It was sent 23:24 (pst) on 21 December via, some sort of fulfillment service, it appears. What's interesting is that, if you have your XO shipping label, you also have the information that you need for T-mobile. I will add the information to the top of this section and to the FAQ. (Orcmid 12:24, 22 December 2007 (EST))

I also received my XO today. Did not receive the shipping notice from UPS nor any T-Mobile information. Please advise. Thanks.

I also received my xo and no email as to shipping and t mobile pin or information. Please comment so people can quit posting this problem. Thanks.

Me too - see a trend here - maybe none of this information was sent to anyone...

Please send my T-Mobile connection information. Just to be sure, send/resend this information to everyone.

I second that motion.

Cannot see all available hotspots

Using a Qwest DSL/ActionTec GT701WG router. One of two XOs saw that access point once, but would not take the key. TomP 21:11, 26 December 2007 (EST) -update on this: I was trying to help my sister by remote control over the phone and we were getting nowhere, so I had her ship me the pair of XOs that had been Christmas gifts to my neices. Once I got them in my hands I was able to focus a bit and I have been able to get them connected to the 'net. But I've also seen something interesting. On one Qwest DSL/Actiontec wireless router that I configured (as I did my sister's) there is a WEP password set and a non-standard essid. The WEP key is HEX (on my sister's router it is a passphrase). When the XO machines came up at first they saw it. I entered the HEX key, and it failed several times. After the machine was restarted that wifi hotspot did not appear in neighborhood. I was able to connect them to an unsecured router, also a Qwest DSL/Actiontec. My Dell laptop can see both Actiontec routers, the one I have control over and a nearby unsecured one. But neither of the XOs see the secured one. I have performed olpc-update on both machines to bring them up to build 653. TomP 17:36, 1 January 2008 (EST)

AIM, Yahoo, MSN support

This seems to be asked a lot. While the native programs obviously don't work, these services have web interfaces that may be usable via the Browse activity. I don't have an XO or membership in the services, though... If someone could test them and write/update the appropriate questions, that would be great. See AIM Express, Yahoo WebMessenger, MSN Web Messenger. —Joe 12:35, 17 December 2007 (EST)

I've tried AIM Express using the browse activity. I've been unable to log in.

Use [meebo]. ffm 17:12, 28 December 2007 (EST)
I created [OLPC-Chat]. It's a xulrunner&libpurple based chat client that supports a variety of protocols including GTalk (Jabber), AIM, Yahoo, MSN and others. --Oliver

won't play sound, try volume keys

An obvious cause of not playing sound is having the volume set too low. Use the volume up key. See Keyboard Shortcuts.

Apple Access Point Connection

The FAQ should specify (and doesn't) that these are instructions for a WEP access point. At least, that's my assumption, given that we have WPA and I see no "hex" or "shared" choices in the dialog box that pops up (which makes the instructions doubly confusing).

There are recommendations for WPA connection WPA_Manual_Setting. Unfortunately, these haven't worked for me so I can't say if they're valid. I couldn't make the manual config (below) work either. The iwlist command returns "no scan results". (The Neighborhood screen does show our local Airport HUB).

--Vlb 13:25, 21 December 2007 (EST)

As of today I was able to get a WPA2 connection to work between my XO and my Apple WPA network using the script specified at WPA_Manual_Setting. I did not copy the script using a usb drive as specified, however; instead, I typed it up using vi in the terminal, then typed "chmod 777" into the commandline. It is very important to note that I did NOT change anything password/network information to HEX as specified in this section, which does seem to only pertain to a WEP-configured Apple network (which I haven't tested). Rather, I just followed the script prompts and typed my network name and password in as plain text. (I should also note that I made sure that my SSID contained no spaces; I have no idea if this helped, but it's what I did.)

A change should be made to this section, because it is confusing and misleading.

--Legutierr 14:30, 21 December 2007 (EST)

I agree with Vlb's observations, and add that there are two WEP keys generated by the converter at

   KEYs for non apple computers/networks:
   (104/128bit) hashed key: 617C516AC0CD96C0B43C40E79E
   KEYs for apple networks or if the AP is a airport express:
   (104/128bit) key: 63313054733176736263377570

The key for an Airport Express appears to be an octal number, not hexadecimal. I have tried both numbers, and neither works. I am also unable to connect to unsecured wireless networks near my home. And does anyone else find the presence of the "Mesh{1,6,11}" icons to be confusing/distracting/misleading in the same display which shows real wireless access points?

Stevenjay 22:52, 21 December 2007 (EST)

Apparently there has been no activity on this issue. The support FAQ is confusing and appears to be invalid. To recap what was stated by previous posters:

1. My Apple Airport Extreme wifi SSID shows up in the Neighborhood. The security is WEP 128 bit (not WPA) but when I try to connect I do not have a choice of "hex" or "shared" in the dialog box, as noted by Vlb. I tried turning off security and was able to connect, so this is definitely a security password issue. 2. As noted by Stevenjay, the hex converter generates two hexidecimal keys (each equally difficult to type on the tiny OLPC keyboard), and the instructions are unclear as to which should be used. It may not matter, though, since neither seems to work. 3. I have not tried the script hack, as it appears to be related to WPA security (not WEP).

Coming from the Mac side of the world, I guess I am disappointed that it requires so much effort.

How to manually configure networking

Note: Do not try this unless you really know what you are doing. That said, this is the only way I was able to connect.

First, switch to root:

su - root

Next, disable networkmanager:

/etc/init.d/NetworkManager stop

Next make network come up:

ifconfig eth0 up

Next, maybe try scanning for wifi networks:

iwlist eth0 scan

Find one you like and connect:

iwconfig eth0 essid foo
iwconfig eth0 key AB123456DE
iwconfig eth0 channel 9
iwconfig eth0 mode managed
iwconfig eth0 ap 00:12:34:56:78:90

And create a default gateway

route add default gw

And some dns servers:

vi /etc/resolv.conf

And inside:


If every thing is correct, you have connected manually. 00:24, 21 December 2007 (EST)

How to cause XO to remember WEP keys

This is for use of the XO in two locations, both with different SSIDs and WEP keys. I would like it to remember the WEP key for each SSID so it does not need to be retyped every time a connection is made.


JetrZ 10:02, 22 December 2007 (EST) - Go to link and use the script to update the network.cfg file.

Using Files and File System

What is the SD Card Support?

The SD Card is a bit awkward to get to. It looks like a great place to add a card as an extension of the available memory though.

  • Update: The SD Card slot placement is intentional, since it is for semi-permanent extension of the basic memory. (Orcmid 19:35, 9 January 2008 (EST))
  • What kind of SD Card Support is provided? Is it basically standard multi-use SD Card (1GB or less) or are any of the later, higher-capacity forms supported. Because of confusion in the marketplace, I guess I need to be more specific:
    • Is the SDHC specification supported? If so, is there any limitation on capacity of the card in the XO hardware/software?
      • update: The answer is Yes for SDHC. Capacity should be whatever SDHC supports. (Orcmid 19:35, 9 January 2008 (EST))
      • A 16G SDHC card has been reported to work. —Joe 18:25, 28 December 2007 (EST)
      • At the December 30 SeaXO meet-up, I saw a 4GB SDHC Card running in an XO-1 too. I'm satisfied that the SD Card slot accepts the largest capacity SD and SDHC cards and will provide significant extended storage. (Orcmid 19:35, 9 January 2008 (EST))
    • For the standard SD support, what is the maximum card capacity? In particular, are sizes larger than 1 gigabyte supported? Is this with the same technique as, say the 2GB SanDisk SD Card?

Language, Keyboard and Display

Typing Unicode Characters

  • The current FAQ (2007-12-23-18:25Z) states that the procedure for entering a Unicode code point (number) is with Ctrl+Shift held down and typing "u" followed by 4 hexadecimal characters for the number. I can't tell for sure (I will need to experiment) but I suspect that these are really UTF-16 code values unless the XO (and the underlying Linux implementation) is really limited to supporting the Unicode BMP only. (Orcmid 13:47, 23 December 2007 (EST))
  • The question is basically whether surrogate pairs can be typed or not. This may be particularly important in Asia. (Orcmid 13:47, 23 December 2007 (EST))

  • Related Point: I am not sure what the actual functionality is, but if the intention is to allow actual Unicode code points, it would seem useful to be able to type as many hex digits as needed and no more (i.e., leading zeroes are optional). In addition, it should be possible to enter up to 5 hexadecimal characters (as well as optional leading zeroes), allowing for the BMP and 15 additional Unicode planes. This would be true code point entry, with any conversion to UTF-16 handled out of the user's direct sight. (Orcmid 13:47, 23 December 2007 (EST))
    • I have yet to be able to type Chinese characters using this approach. --Chihyu 00:38, 11 January 2008 (EST)
  • Continuing: If code points are to be entered, it becomes important whether non-Unicodes are filtered out (by a beeper or something) so that entry of raw binary codes and of Unicode code points are not confused together. The geek in my rather fancies the code-point notion, but I suspect this is actually a nomenclature bug (and I am happy to be mistaken about this). Second prize would be for UTF-16 but then surrogate pairs have to be explained and some how filtered properly. Third prize would be, well, I don't think there is a third prize for keyboard entry of uninterpreted binary. It's the wrong place to make such a provision. (Orcmid 13:47, 23 December 2007 (EST))
  • Concluding: I am looking at the Unicode 4.0 specification. I don't know if the Unicode 5.0 book has been published yet. One thing that needs to be tracked is the version of Unicode that is supported in the box and what the strategy is for migration-to/accomodation-of later versions. I suspect that this will not bother keyboard support very much, although it might impact filtering for stuff and classification of code points for various types of characters. I wonder if the approach of XML 1.1 is relevant. (I don't know, just wondering.) (Orcmid 13:47, 23 December 2007 (EST))

Getting Unicode Fonts

  • At the December 30 SeaXO meet-up, one woman wanted to be able to display Chinese characters on her XO-1, especially when browsing. Apparently there is no full (or reasonably-full) Unicode font installed on the machine. This will defeat multi-lingual usage settings and visiting to web sites that present characters other than those of the locale of the XO-1.
  • What provisions are there for downloading additional font characters or enhanced Unicode-mapped fonts? (Orcmid 19:47, 9 January 2008 (EST))

How do I change the language that Sugar uses?

This tip requires an understanding of how the Terminal activity works.

cd /home/olpc
nano .i18n
  • You should see some text appear like:
  • The LANG refers to the language displayed in Sugar. "es_AR.UTF-8" means it is displaying a form of Spanish. "en_UK.UTF-8" would be UK English. So change it to which ever code you need [(see a full list here).]
  • Then press ctrl+x to exit, and press y to save your changes.
  • Then restart Sugar by pressing ctrl+alt+backspace.

If you can't load the sugar-control-panel

I was unable to load the sugar control panel because the SUGAR_PATH was not set. I fixed this with the command:

export SUGAR_PATH=/usr/share/sugar

How do I edit the Support FAQ, I don't seem to have the rights...

Hi all,

This is Dan Bennett and while resolving a support ticket for a donor I realized that we had some misinformation on the wiki leading our user to log his ticket in the first place. Essentially, the "How do I download/install Activities" entry recommends going to the "Journal" instead of to the "Home" screen to find, install, and run your new activity after you download it.

How can I update this item myself, or is adding a discussion like this one the only way to do so?

  • Dan, the Support FAQ page is identified as one maintained by the OLPC team. (This is in the banner at the top.) My impression is that the team does review these discussions and they can be reflected in the FAQ as appropriate. I suggest making an entry here, in relatively the same position as the closest-corresponding Support FAQ topic, and enter your suggested change. (Orcmid 19:40, 9 January 2008 (EST))

3.14 How to disable wireless while flying

this section instructs the use of su/sudo to root before running sugar-control-panel. This is incorrect, and does not work? I'll make the change myself later if no one objects. --Adricnet 19:21, 25 December 2007 (EST)

  • I moved Mokurai's comment from the article page to here, just for further confirmation (and for keeping the FAQ page in simple, plain English). --Chihyu 13:29, 18 January 2008 (EST)

To disable the wireless entirely so you can turn your XO off and then on again without the radio coming on, you need to rename /lib/firmware/usb8388.bin as root. Something like the following.
cd /lib/firmware
mv usb8388.bin usb8388.bak
To reenable wireless, reverse the process
cd /lib/firmware
mv usb8388.bak usb8388.bin
and reboot. A method for disabling and reenabling wireless from the normal Sugar user interface is in development.--Mokurai 19:21, 16 January 2008 (EST)

OpenDNS use?

How about configuring to use OpenDNS if there is a DNS resolution problem? I found this at top of this page and moved down --Adricnet 23:30, 27 December 2007 (EST)

See this recipe Adding OpenDNS configuration Martinlanghoff 19:48, 28 September 2010 (UTC)

Proposed update in text

(I was going to make the changes directly, but saw the note "maintained by staff'...)

... First, you must have wireless(*) Internet nearby using WiFi channels 1, 6, or 11; second, . . .

Proposed changes in red.

  It would also be nice to be able to change this behavior. 
  i.e. Customize Wifi channel scanning, for own local channels.

--IainD 21:23, 30 December 2007 (EST)

In, the word "length" in the second sentence of the second paragraph is misspelled. (Was lenght, should be length.) --Beth

The image in shows four children using three laptops. This may not be the best depiction of the one laptop per child concept.

Stylus in debug mode

For the stylus question, you should mention that it may be tested in debug mode (hold rocker at boot). This lets people test it out before offical support.-ThePlaz 18:54, 2 January 2008 (EST)

How do I update/upgrade my laptop? changes

I'm making some slight edits to this section (or will shortly), based on some discussion on the support list and some developer comments.

The most important point is that G1G1 XOs do not automatically update, and so I've hidden that sentence for a time when the FAQ is more aimed at a larger audience.

I've also fixed a couple typos and reworded some stuff for clarity. And I added links. So much for atomic deltas ;) Done.

--Adricnet 05:46, 3 January 2008 (EST)

adobe flash and gnash

I removed the following:

To ensure that certain Flash sites such as JumpStart or StarFall or Webkinz work, Gnash might have to be disabled, or the sites will recognize Gnash as the current version.

As far as I can tell, disabling Gnash is never necessary; once you have adobe flash properly enabled (you can check this by visiting a flash-checking URL such as [http:/ this one at]) it should run the same way whether or not the gnash plugin is still around. If you remove gnash, it simply makes it harder to switch back if you later decide to do so... If someone has a specific use case that requires removal of Gnash, that would merit filing a more fundamental bug; please cite your use case (here on the talk page, and on the Adobe Flash page). --Sj leave me a message 14:01, 3 January 2008 (EST)

Opening laptop

The answer says that opening the laptop does not void the warranty, then immediately goes on to state that it is at your own risk. Surely these statements conflict with each other? At the very least it's confusing.

Fixed. ffm 10:52, 17 January 2008 (EST)

separating the G1G1 FAQ.

Generally, I suppose, an "Support FAQ" of a product is resources for how to use or maintain it. Most of this "Support FAQ" contain how to use XO and this wiki says "technical questions", "how to use your XO laptop" to this FAQ. Therefore, I think the 'G1G1 FAQ' in this article should be seperated and moved into another page unless this wiki is dedicated "G1G1 customer service". Any other reason? -- LeeSI 23:17, 21 January 2008 (EST)

How can we be certain that non-G1G1 users will NOT ask the same questions as the G1G1 users? --Chihyu 17:54, 22 January 2008 (EST)

First of all, I've said about non-technical questions in this FAQ. The 'G1G1 fulfillment' and 'donation' questions are not the "How to Use XO", I think. If not necessary, why is this (technical) 'Support FAQ' seperated from the other FAQs? -- LeeSI 00:15, 23 January 2008 (EST)

"Ask OLPC a Question" is obsolete. We are still in transition of moving the questions and answers to the Support FAQ page. Also, the Support FAQ page is updated based on the questions we received on IRC and from "help at laptop dot org", and thus the fulfillment and donation topics in the FAQ. --Chihyu 15:03, 23 January 2008 (EST)

If so, this is not the "how to use (and maintain) XO" FAQ any more and all the FAQs will have been merged into this one. (And the structure or flow of documentation, reflected on the navigation pannel, may need to be changed.)
Is that the goal of the transition or plan? -- LeeSI 06:51, 24 January 2008 (EST)

Bulletin Board

Is the bulletin board working? I can't seem to find the BB. There is no key on the places bar and the keyboard button (2nd from right, top row) doesn't do anything. Maybe I don't understand how it is supposed to work.


It is reserved for a future feature. See getting started

--Chihyu 12:47, 24 January 2008 (EST)

FAQ reference to internal (watch) battery

"Do NOT remove the watch battery on the mother board if you disassemble your machine; prior to the Q2D07 version of firmware, this can result in the computer becoming unusable, due to a bug in our anti-theft firmware implementation. G1G1 systems do not have the anti-theft system enabled."

Does that mean that when the watch battery dies, the computer is a brick? Or does it mean that a new version of the firmware will fix this during the life of the original battery? Or does the last sentence mean that G1G1 owners don't have to worry, even if they remove the battery? Someone please clarify. thanks. -- Robby 14:36, 17 February 2008 (EST)

"can't open NAND image file"

I couldn't flash gg-767-4.img onto my G1G1 and couldn't figure out why. I put gg-767-4.img and onto a flash drive and got the error message above. When I instead tried to flash os767.img, the procedure worked. Finally I realized that even though both os767.img and gg-767-4.img needed files called to install, they needed *different* ones. I was trying to install gg-767-4.img with the file needed by os767.img. Once I used the correct file, I had no problems. I suggest that either the two files have different names like and, or that the instructions be revised to explicitly note that the files are different.

Chaiken 19:34, 21 April 2009 (UTC)