Talk:Ubuntu Gutsy On OLPC XO

Jump to: navigation, search

Please ask your questions and post comments about installation of Ubuntu on the XO here so that all may benefit :D

- Can someone please post instructions on how to connect to a WEP wireless connection, the NETWORKING portion of this wiki only makes mention of WPA

- What's the Intrepid mini.iso for?

- I'm finding a few discrepancies regarding wpa_supplicant but before I correct the actual page I'll put a couple of notes here. On this version of wpa_supplicant there's no space between -c and the path, so the actual string should be:

$ sudo wpa_supplicant -Dwext -ieth1 -c/etc/wpa_supplicant.conf -B

- Despite figuring this out and finding I can get networking going when I issue these commands, I can't get the wireless to start automagically on boot OR using wifi-radar. When I issue the terminal commands I get some odd error messages, but the networking starts anyway. So there's something wrong with what I'm doing. Google searches imply it's some funkiness in the wext driver. Twt 18:58, 12 May 2008 (EDT)

- I continued to get ioctl errors with wpa_supplicant, but networking seemed to work fine anyway (hardy).

So what's the disk drive driver on the XO? During the QEMU installation it doesn't detect a hard disk and asks me to choose from a list. Any ideas?

  • It sounds like you didn't specify an image to install to -- go back to the beginning and check your qemu settings very carefully. Twt 18:58, 12 May 2008 (EDT)

- How much of these instructions are Ubuntu-Specific? Could another distribution, such as DSL or Puppy, be made to work the same way?

  • I think any recent linux could work. For Ubuntu I used the kernel from the original Red Hat and the modified xorg packages based from Debian as it was being developed to use the hardware display accelleration. Ubuntu had to be modified to use sysvinit instead of upstart because of how the kernel was configured. - Freelikegnu

- So basically If I had a working recent distro on a USB I could do step 7 (copy boot and other files from the XO) and it would most likely work?

When I install sysvinit, at the end I get "init: timeout opening/writing control channel /dev/initctl". I assume this is related to the note that upstart wants to be PID 1. Is this error important, or can I forge on despite it? 11:30, 3 February 2008 (EST)

So I forged on despite the error, and in the middle of installing xorg/xfce I started getting error messages every 2 seconds that start with ata2.00. I assume these are the ata errors that the instructions say are harmless. However, when I try to shutdown (sudo halt) I get "shutdown: timeout opening/writing control channel /dev/initctl". I rebooted with reboot -f and the ata errors reappear during startup (right after the "starting system log daemon" line, I think). 12:05, 3 February 2008 (EST)

Cleaning up Sugar afterwards?

Any instructions on how to get rid of all the bloat associated with Sugar and activities, after we've successfully installed Ununtu? After all, no point in having 2 OSes taking up space, is there? 12:55, 5 February 2008 (EST)

Speed of boot?

I just tried this using an 8 GB SDHC card from PQI. It's a 66X card. How quickly should the XO boot? For me, I see OpenFirmware load sd:\boot\olpc.fth with the correct command line, then it stops. No text scrolling, no advancement past that screen. I let it sit for a while, too: at least 10 minutes. I've followed the instructions to the T. I was using OLPC firmware 656 while readying it. Any ideas? Colin 01:59, 19 February 2008 (EST)

You need to force into check mode or you won't get prompt at the end of boot (it might still be working behind the scenes). Hold the check mark key at startup to force it, I ended up editing out the alternate option so it would only go in check mode (one of the .fth files had an extra option that seemed to get in the way).

Installing back-ported xorg drivers

I'm having problems installing the new xorg drivers that Holger Levsen back ported. When I start apt-get update, it throws the error about no public key for the layer-acht etch release, and says run apt-get update to correct the problem, which obviously doesn't work. If I go ahead and try to install it anyway, I get a broken packages error. Any ideas?

No new ideas here, but that is exactly what I ran into as well...

I finally got this working (hardy) by adding the "... ..." lines to /etc/apt/sources.list, not under sources.list.d. I still got verification errors on xserver-xorg-video-amd but ignored them and got video working OK. It wouldn't work at all with the original Qemu image. Also I had to "sudo apt-get purge xserver-xorg-video-geode" before the amd video would install.

Bartwensley 22:26, 25 July 2008 (UTC): I don't think the back ported drivers are necessary if you are using Hardy. I did an install of the Xubuntu alternate CD and the xserver-xorg-video-geode driver seems to work very well. Just edit the /etc/X11/xorg.conf and set the driver to geode:

Section "Device"
	Identifier  "Videocard0"
	Driver      "geode"

Issues using Hardy

  • I've opted to install Hardy on my SD card. I've got it running fairly well and even Network Manager is functioning properly. However, I've got gigantic fonts in XFCE and all X programs. I am unsure of how to correct this. I can get a "normal" sized terminal by using a font size of roughly 7, but changing the XFCE DPI setting had no effect. Running 'xdpyinfo' shows that the DPI is 201 which is the same as when running under Sugar. Any ideas on how to fix this?

Bartwensley 22:27, 25 July 2008 (UTC): The best way I found is to lie in /etc/X11/xorg.conf about the display size:

DisplaySize 228 171

This adjusts the font sizes in all applications.

  • I noticed that the xorg.conf file needed to go in a slightly different location. Edit the instructions to:
  wget -O /media/OLPCRoot/etc/X11/xorg.conf
  • Using the sugar /etc/modprobe.d/modprobe* (sorry, I forget the exact name of the file) in Ubuntu 8.04 messes up sound. There's a line near the end with 4 modprobes &&-ed together, but the first one fails. If I enter the last 3 modprobes from the command line, however, I get proper sound capture and playback.
  • At boot I can't get anything to display (except OpenFirmware) unless I hold the right game key at boot. The XO then shows the boot messages and starts X as expected. (This is true regardless of using sysvinit or upstart.)
  • FWIW, I found I got a much more workable system by installing from the Xubuntu 8.04 alternate CD. I tried the directions based on mini.iso and while the system worked, there were too many missing pieces for my taste. Xubuntu straight off the alt CD fits in a 2GB SD card.
  • I found that Xubuntu 8.04 didn't like sysvinit. It wouldn't shut down either from the GUI or command line. (I didn't try startup.) Leaving that alone and staying with upstart works fine on the XO.

Differences for using a 1GB UDB?

  • I assume we should make the initial partition smaller for if using a 1GB usb drive?
  • I tried an initial partition of 1GB and it wouldn't copy to a 1GB usb drive (not enough room for the drive overhead). Don't know how much smaller it must be as I moved to a 4GB to get things working.

Issues using Ubuntu in VMware

  • Any issues one might foresee? I'm plugging along on it now, and have had only minor blips.

Error with custom olpc.fth : "unrecognized program format"

A solution comes from here:

User linuxspice says, "...for olpc.fth this first line must start with a "\ " - i.e., a backslash followed by a space character. So a single "\" won't work, but a line such as "\ My olpc.fth file" will. ... If the firmware finds a "\ " (backslash, space) at the beginning of the olpc.fth file, it will treat it as a real Forth script, otherwise it will treat it as a binary executable."

Multiple Partitions

I am using an 8GB USB stick, and I do not want to install this into the first partition. At first, I (foolishly?) thought I could get away with making the dd outfile of=/dev/sda3. Unfortunately, that created an unreadable partition within partition 3 (/dev/sda3p1). I already have an alternate boot on sda1 that I want to keep (and it is only one GB, anyway), so what do I do? Is there some way to copy the image into partition 3 or do I have to emulate that somehow? If I use the emulator, and there are two empty partitions, dd will most likely overwrite empty partitions to my device -- replacing my partitions, right?

So, to restate: Is there a way to write the image to anything but the raw usb device?

--LuYu 14:24, 9 May 2008 (EDT)

What Now?

Okay, so I gave up on the disk and just bought a new 2GB SD. It worked after some initial problems like getting the developer key and figuring out how to display the boot messages. Now that I have it working, the XFCE desktop is quite spartan. It reminds me of the early days of Gnome and KDE where one would get X running and be very nearly without any apps.

So, now my question is: Where do we go from here? Booting Ubuntu is very cool, and fun, but many of XFCE's features (such as the very important battery monitor) do not work. I checked dmesg, and there were tons of messages put out by the OLPC kernel. Are there any GUI laptop apps that work with the OLPC kernel output?

The OLPC also has tons of buttons that would be very useful if they were not off. How can one make these work within a given (Gnome/KDE/XFCE/FluxBox) GUI? This includes the game controllers and game buttons for tablet mode, the brightness keys, and a few others.

I would especially like to get the screen rotation key working. However, I assume that will take a customized xorg.conf file. Every time I have used such a feature, it has worked automagically. Now that it does not, I imagine it will take some acrobatics to implement. I, nevertheless, would like to attempt it.

Does anyone have any ideas about these things? Perhaps a separate page should be created like Ubuntu and OLCP Hardware or something like that.

I am open to any suggestions :)

--LuYu 13:49, 14 May 2008 (EDT)

Upstart, oatc & pid 1

Why not just remove oatc? Then upstart can run as pid 1. Ashley Y 22:19, 5 June 2008 (EDT)

  • OK, so what's your proposal on how to to that?? ffm 12:24, 13 June 2008 (EDT)
Edit olpcrd.img and pull it out. Ashley Y 09:48, 28 June 2008 (UTC)

share a complete disk image?

It would be handy if someone shared their final SD/USB disk image via e.g. bittorrent.

I agree... I'm currently downloading it from [1], but I'm not sure if it works...


help im trying to install ubuntu on my xo but i have no idea and sudo dase not work on my xo what do i do?? please e-mail me at

i really wont it on my xo laptop but i just dont no how can you install ubuntu on a GIGI laptop? please e-mail me how or post on here please and thank

alternate install method

Hey, This did not seem to work for me. It kept getting stuck at the olpc.img loading. However I did get Ubuntu running following this guide:
Guysoft 21:14, 26 September 2008 (UTC)

Alternate install Method - Xubuntu

I did the alternate install method with Xubuntu. When I try using Qemu to boot my installation from the image I created, I received errors about no available disk space. I cannot login as a result. Did I do something wrong? hermitcrab 9:06, 18 September 2009 (CDT)

olpc installed for the disabled

say for instance you had suffered a stroke (like me) and had huge issues with communication where would you get an olpc pre installed with something usable.

that is no huge areas of white but able to run firefox,etc and have access to console for running mutt/festival/lynx and other decent apps that display in a sane black background.

all the silly iso's to date of ubuntu seem to be white dominant and very migrainne agravating to install.

hope this makes sense i cannot tts check forms for sanity.

i am on irc freenode but will check back here if you have ideas.