Talk:Fluendo mp3 decoder

Jump to: navigation, search

Installation experiences / tips

I could not get this installation to work in Sugar, on build 623, on a B4 OLPC. However, it worked from the command line using

gst-launch-0.10 playbin uri=file:///path/to/file.mp3

It works well in Build 650, and mp3 files can be played from the Journal, using the Watch & Listen Activity. --Tomhannen 11:16, 10 December 2007 (EST)

  • The file retrieved to Firefox in Gnome is fluendo-codecs-mp3-15-5.i386.rpm. Attempting to install it with yum fails with a message that it is an unsigned rpm. I've attempted to add enough details to the installation instructions to help others avoid this error, ... Peter E., Peasthope 03:28, 9 February 2012 (UTC)

Simpler installation procedure?

I emailed Fluendo asking if the install process could be simplified for OLPC systems, as going through an online shop is quite laborious for a free (as in $0) codec. Here is the reply I received:

We have a license agreement allowing projects like OLPC to distribute the mp3 codec themselves for
free as a distribution channel for our technology.

Our Codec manager (included in Fedora 8) allows automatic installation
of MP3 as well. For the others we prefer if they pass by our webshop.
This way they have an account and see our other product which is a good
marketing point for us.

Best regards,

Does this mean that the installation process could be improved? --Tomhannen 11:16, 10 December 2007 (EST)

I think that Mp3 support isn't really wanted as a goal of the project. We might be able to add the codec for free, but mp3 as a format is not Free/Libri. Ogg is preferable and superior. As an education machine for children there are several reasons *not* to include the ability. And for G1G1 users, not having the codec will encourage them to support Free formats, and perhaps lead them to Free and Open (CC) music. This stance is about social change, much the same as Ubuntu's on the same subject. is for Insects 12:58, 10 December 2007 (EST)
I completely agree with the goal of free & open source software, but I also would like as many people as possible to be able to access a wide variety of news sources.. Why is it easier to read a PDF file than an mp3 or Realplayer stream? Surely these are equally as proprietary? I'd love to persuade major broadcasting organisations to release their content as ogg files (maybe one day I might..), but until they do, I'd feel like OLPC was missing out somehow, and would be criticised for restricting its decoding abilities, compared to other FOSS projects, such as firefox... --Tomhannen 18:17, 11 December 2007 (EST)
wikipedia:PDF is no longer a proprietary format. -- skierpage 11:30, 27 February 2009 (UTC)

Downloading file from internet

I've downloaded the MP3 codec from Fluendo as I found in one of your wiki entries but I can't figure out where it put it to unzip it and copy it to the directory I want

Dcutter1 10:51, 23 December 2007 (EST)

Here's some notes on how I finally got the MP3 codec moved. Not sure if this was the correct way to do it but hey I'm not a 8 year old working on this machine :-)

Location of these instructions: (modified with actual commands I used to get file unpacked and moved)

In order to download the codec you have to "buy" the Fluendo mp3 decoder from their store for $0.00 from

You are then allowed to download the file fluendo-mp3-2.i386.tar.bz2

At this point I'm not sure where it downloaded the file but I went to the journal and clicked on the clipboard icon. I then went into terminal mode did a cd / to get to root and found the file in the tmp directory. The file name is in the awful long string of numbers and letters that this system uses to keep track of file names.

Unzip it - tar -xvfj fluendo-mp3-2.i386.tar.bz2 (the filename actually looked like this 1256ab-345-15b-123f45RMm.tbz2,

The unpacked worked and it created a new directory in the tmp directory (note: if the file name has a "(" in it tar can not unpack it as it thinks this is an invalid name, I ran into this the first time I tried this).

I changed to SU so I could copy to user/lib and then I did the copy cp tmp/fluendo-mp3-2.i386/ /usr/lib/gstreamer-0.10

You can also copy into $HOME/.gstreamer-0.10/plugins on your local system.

If you copy to /usr/lib/gstreamer-0.10 then the plugin will be available to any user logging into this machine.

Once it is copied over, verify that gstreamer recognises the plugin by doing a 'gst-inspect-0.10 flump3dec' from the root directory.

Unless this command reports back 'No such element or plugin 'flump3dec' the plugin should be sucessfully installed and you should have access to playing back MP3 files using GStreamer applications. You should see a couple pages of information about the plugin.

Hope this helps and for you people that know this system please update with any easier way to do this.

Dcutter1 08:24, 24 December 2007 (EST)

Other plug-ins

Has anyone tried Fluendo's other gstreamer plug-ins, specifically the one for MPEG-4? Does it work, and how is playback performance? Bouncey 12:59, 5 January 2008 (EST)

Important files

So does this mean that the only important bit is the lib*stuff*.so? Can everything else be deleted? -Adina: 15:04, 24 January 2008 (EST)


xo mp3 discussion but not fluendo, mp3 player in etoys?

Where do I find info about mp3, the .../go/mp3 page redirected me here.

What I am trying to figure out...

I am using G1G1, build 656. When I would click on NPR listen, gnuflash or whatever would run but no sound. Then one day I think I clicked on something that was a stream but ended in .mp3 A file got downloaded but I don't know if it was valid or corrupt. It was in my Journal, and I clicked on resume. I'm not sure what happened next, but I think e-toys activity got launched, and something that looked like a movie or audio player came up. No sound came out and I stopped the activity. When I resumed the activity it still didn't work. I erased the journal entry and have not been able to duplicate anything like the above again. Can anyone tell me what might have happened? I wish I had done a screen save but I didn't think of it then.

I guess I am just about at the point where I would like to totally update my xo, firmware, software, and start over from scratch. And I got the feeling I will want to do that repeatedly, as if I am starting with a just shipped machine again and again. Not even have previous build.

Where should I ask this question if not here?

BobUgh 03:05, 27 June 2008 (UTC)

Etoys declared it had support for .mp3 and somewhat accidentally in some releases this worked, see <trac>8982</trac>. The instructions I put on Fluendo mp3 decoder make MP3 files work in Browse. If you add an MP3 codec to GStreamer then several activities gain the capability to play .mp3 files; the issue is which activities tell the Journal they can handle audio/mpeg mime type. -- skierpage 11:35, 27 February 2009 (UTC)

Also not working in Journal

BobUgh -

I'm having similar problems, both with 656 build and now the 708.

Mp3s will not run from Journal. In 708, the "start' command is available under the small button in the far right edge of the item view in Journal, but nothing happens (no sound, no launch of Watch and listen). (This may have to do with new Journal problems in 708 build). BUT,

Mp3s *will* run if you launch Terminal, and run Totem directly by typing the command 'totem'. This command brings you the Totem player, with full file window system, etc.

I had this problem after installing Fluendo as instructed here into my original G1G1 656 build, and had similar behavior, including some false launches of etoys now in 708. One added note: if you install the plugin in the alternate location (usr/lib...), the system will respond correctly to the 'inspect'command. (hope this is not cryptic -- assume that all I know is what I read here today.)

From docs here and at the Fluendo vendor, they say that this plugin shouldwork for all GStreamer applications, which should include Journal. But, No. Re: asking this question, try the OLPC News forums. -- g1g1user @ Oregon 8/18/08

Again, system MP3 support and the Journal knowing what activity to start are two separate things. -- skierpage 11:35, 27 February 2009 (UTC)

MP3 at 2014-10-01.

The shared object file worked for OLPC release 13.2.0 on an XO-1.5. If is installed in 13.2.1, sound is produced on a compressed time scale. In Gnome, Totem now renders human voice in chipmunk mode. In the graphical interface, no setting to correct this evident.

The link is no longer available. Fluendo allows retrieval of a complete repository for the ONEPLAY MP3 Decoder. Open and scroll down the page to find the svn command. The repository contains hundreds of C source files but no shared object decoder.

MP3 usage needs reassessment. Which decoder is used in Debian? Peasthope 13:16, 1 October 2014 (UTC)

Thanks for the research.
Luckily the Fluendo MP3 decoder was a redundant option. So I've removed the suggestions to use the Fluendo decoder in Restricted formats and GStreamer, leaving the GStreamer plugins at rpmfusion the only remaining method. After installing these plugins on 14.1.0 build 2, the gst-launch-0.10 playbin recipe works fine.
I've also tested with yum install -y mpg123 and used mpg123 to play a file, and it worked fine.
Don't forget we use a bug tracker and devel@ mailing list for bug reporting and dialog with developers; this Wiki has a very limited readership, and I'd prefer you not try to engage me through it when there are more appropriate channels with transparency, accountability and a wider readership. --Quozl 01:43, 2 October 2014 (UTC)
See <trac>12833</trac> --Quozl 07:28, 14 October 2014 (UTC)