Test group release notes/2009 and earlier

From OLPC

Jump to: navigation, search
Old testing results

Contents

Purpose of test group release notes

If you are interested in developing or testing builds that are not yet released, come to this page first and see if the build has any major problems. If it can't even pass the Smoke Test, you probably don't want to waste time loading it.

If you don't see anything here on the latest build, please add your notes on smoke test and/or basic functionality to help the next guy.

NOTE: Entering issues on this page does NOT count as reporting them. Please enter bugs in Trac.
For information on how to report bugs, see: Reporting bugs
- Kim

Smoke test, changelogs

General smoke and regression tests:

  • Smoke test links to the 1-hour smoke test for a particular release

8.2.1 builds

Please write your testing notes here. Thanks! --Michael Stone 18:57, 29 January 2009 (UTC)

http://dev.laptop.org/~bert/8.2-8.2.1.html shows diffs between candidate OS images on the road to 8.2.1 and build 767 (8.2.0)

candidate-801

sudo olpc-update candidate-801 from candidate-800 worked fine for me. -- skierpage 04:45, 1 March 2009 (UTC)

candidate-800

sudo olpc-update candidate-800 from build 767 worked fine for me. Wireless connectivity to my old Linksys BEFW11 router with 128-bit WEP worked OK, but I still am disconnected for a while after resuming from standby until the XO gives up on mesh. -- skierpage 2009-01-26 ...

olpc-update staging-7

Passed smoke test by Bpepple. Booted and tried by Reuben and Kim.
Cursor control problems reported but not proved worse or better than before.

Booted and tried briefly by iXo . Unable to connect to either WEP or WPA access points. Some errors during on console during bootup, mostly to do with JFFS and xauth. Will investigate further in next few days. (Contact via email, or post on User Talk page. --ixo 07:52, 5 January 2009 (UTC) )

8.2 builds

Build 8.2-767 (candidate release)

Startup/Upgrade

  • Updated from 711 through olpc-update.
  • Boot up is a tad slower than 711, but otherwise, upgrade and boot up are flawless.

Network and mesh

  • Activities updated successfully and internet connection successful. Still have not tested a Mesh with multiple XOs

Programs and other stuff

  • Ran through the 1-Hour Smoke Test:
  • Log Viewer Activity did not function at all. It will not open period.
  • All other applications and features functioned as expected.
  • One time it did not shut down properly (Stayed on until the battery died!) but I have not had any problems since then.
  • Several other applications downloaded off the Wiki and installed on the XO through USB:
  • SimCity hangs after exiting. All other applications I tested worked correctly.
  • "shutdown -r" command does not properly shutdown XO. Regular shutdown methods still function (Mostly).

-- Echo35 - 16:04 EST October 7th, 2008

Build 8.2-766 (candidate release)

First portion of 1-hour smoke tests (starting from the top of the list and going down through/including "installing library bundle") pass. AFAIK other smoke tests (run by Joe, Frances, and Kim) passed as well. Mchua 13:36, 2 October 2008 (UTC)

Fails activation 8715.

Build 8.2-765 (candidate release)

cscott's Changelog; rwh's Changelog

Build 8.2-763 (candidate release)

Changelog

Install

  • I did a cleaninstall on one laptop and an olpc-update (from 760) on another. Both upgrades completed and the laptops booted up.
  • The activity updater launched and got the latest activities from /Activities/G1G1/8.2.0, but did not pull down the content or collections. #8493, marked as a blocking bug for 8.2
  • NOTE: After changes to the wiki page, the content is also getting updated properly.

Activities

  • Started many activities and tested for basic funcationality. Results are now being logged in the test restults page: TestResults_8.2.0

Collaboration

  • This build has now been loaded onto the 30 laptop test bed and a number of smaller testbeds. All standard collaboration continues to work as in the last release.
  • Simple mesh collaborates, connection to an AP, and connection/registration to a school server -- no regressions.

Build 8.2-760

  • changelog?

Startup/upgrade

  • I upgraded some laptops from 759 to 760 via olpc-update. The upgrade was followed by the activity update, which completed without problems (about 6 laptops). Additionally, Joe, Mel and Frances upgraded 39 laptops without any problem.
  • I upgraded via cleaninstall on 3 laptops. The machines booted and the activity update completed without problems.

Network/connectivity

  • Connected to open and WEP access points.
  • When connected to WEP AP, my two laptops at home also saw each other.
  • I turned the radio off on one laptop and the other's neighborhood view continued to show the XO even the next morning...#8441. After turning the radio back on, the two neighborhood views won't sync up again. They can't see each other to share any new activities.
  • After a while I tried to share write and they were able to see the write doc.

Activities

  • Chat, Write, Record (video, still, and voice), Pippy, Tamtam jam, Browse all started and performed as expected.
  • Browse shows no Library content! #8493

Kimquirk 12:30, 15 September 2008 (UTC)

Ethernet connection

  • My D-Link DUB-E100 USB Ethernet adapter does not work with this build. No connection.

Collaboration

  • 29 laptops connected to a school server and running Chat, Browse and (in the case of 3 laptops) also Write survived the overnight collaboration.
  • 5 out of 10 laptops on the mesh network running Chat and Record (in the Photo mode) stopped collaborating after the overnight run. 3 of those laptops were also running Write; in one of the 'invited' laptops Write disappeared by the morning; the laptop itself was still operational; other two laptops still running Write stopped collaborating.

- Joe 9/16/08

Build 8.2-759

ChangeLog

Activities

Etoys: Saving fails if project name has non-ascii characters ticket #8212

Screen pulsing, out-of-memory

Twice with 8.2-759 my G1G1 machine has had the screen flash on and off coming out of a "standby" (screen off) state. The second time seemed a memory pressure state, I typed some memory commands at random and saved the output at User:Skierpage/out-of-memory -- Skierpage 23:41, 14 September 2008 (UTC)

Build 8.2-757

Changelog_757

Connectivity test results

  • 40+ laptops were upgraded with olpc-update 8.2-757; some with copy-nand of the os757.img; some with olpc-update 8.2-757.
  • Laptops booted up properly, but some of them required reinstallation of the build.
  • Connected to simple mesh 11 (all mesh circles are showing again in this release!), some of the laptops left and rejoined the mesh periodically.
  • Connected properly to School Server AP (open, no encryption)
  • Upgraded many activities well through activity updater (some activities had to try twice)
  • Connected to canopy (WPA), and olpc (WEP) APs and browsed the web correctly.
  • Ran Chat, Browse and Write sharing on laptops connected to a school server. Out of 30+ laptops, only two couldn't see the Write's icon in the "Group" view. Other machine happily shared those activities.
  • Ran Chat and Write sharing on 10 laptops connected to over the simple mesh. Sugar suddenly restarted in several laptops already sharing Write, when one of other laptops joined sharing the Write. After sharing of Chat and Wtite was restored, laptops starting behaving properly.

olpc-update

Running olpc-update 8.2-757 to update from joyride-2301:

  • Always reports Contents manifest failure at line 383 Last file examined: localtime when Trying irsync_pristine. This happens to many upgraders, filed ticket #8190 for investigation.
  • Then X always restarts in Trying irsync_dirty, probably ticket #5954 "oom-killer during olpc-update". A workaround may be to NOT run the command in Terminal Activity, but instead in a console, possibly in the background.

-- Skierpage 06:52, 28 August 2008 (UTC)

  • Updates worked pretty well on 32 laptops, some had to be initiated several times; but once they were up they all connected to the Zoom AP, and registered with the school server.
  • Some laptops were clean-installed as well. One had to be rebooted as the wireless didn't come the first time.
  • All 32 laptops are connected to AP to a school server. Chat was started on one laptop and shared with all the others. Browse was started on one laptop and bookmarks were shared across many laptops. The next morning they were ALL still running (no crashes, no sugar reboots, chat and browse still active); and the chat continued to work across all machines.
  • On many machines in the neighborhood view, the circle of XOs around the shared activity disappeared. The shared activity is still there and others can still join it: ticket #8184.

Kimquirk 15:37, 28 August 2008 (UTC)

Activities

Record-57: Only a single frame appears on the screen. Attempt to take a photo causes the busy mouse to appear for a long time (forever?). Shall I file a bug? Jpritikin 16:19, 30 August 2008 (UTC)
  • Test report from Wellington:

http://lists.laptop.org/pipermail/devel/2008-September/018879.html

Build 8.2-756

(based on joyride 2324)

XOs being used for this testing are running the following:

Build: 756
Firmware: Q2E14
Libertas: test version of 5.110.22.p18 (0.0.0.p18)

Connectivity

At boot up after a cleaninstall the MP laptop defaulted to 'Channel 11'; but there are no simple mesh channels showing in the network neighborhood. Also, my two B4 laptops got no WLAN connection at all after boot up. You can click on an infrastructure AP, though. ticket #8133
Two laptops near each other but connected to an AP to the internet can no longer see each other. ticket #7972

Joyride builds

Build 2456

  • changelog:

+dbus-python.i386 0:0.83.0-3.fc9

-dbus-python.i386 0:0.83.0-3marco.fc9

#8552 Hal daemon fails to start, X crashes on start

Build joyride-2301

XOs being used for the initial test were running the following:

Build: Joyride-2301
Firmware: CL1 Q2E12 Q2E
Libertas: 5.110.22.p17

XOs being used for the initial test were connected to the internet through School Wifi.

Telepathy: gabble
Jabber: schoolserver.media.mit.edu
essid: media lab 802.11
Channel: 11

Activities:

Same results as 2294.

Miscellaneous:

The main difference between joyride-2301 and joyride-2294 is that 2301 has had the automatic idle-suspend defaulted to OFF. If you need to or want to test how idle-suspend may or may not break things, use the following commands in a virtual terminal to turn it on or off as needed.
To disable idle-suspend, type the following: touch /etc/ohm/inhibit-idle-suspend
To (re-)enable idle-suspend, type the following: rm /etc/ohm/inhibit-idle-suspend

Or apparently you can simply use the Sugar Control Panel / Power pane (under the XO guy in Home/Favourites view). The Automatic Power Management checkmark option creates or deletes the above file.

Build joyride-2294

XOs being used for the initial test were running the following:

Build: Joyride-2294
Firmware: CL1 Q2E12 Q2E
Libertas: 5.110.22.p17

XOs being used for the initial test were connected to the internet through School Wifi.

Telepathy: gabble
Jabber: schoolserver.media.mit.edu
essid: media lab 802.11
Channel: 11

Activities:

Browse-95: Viewing source results in a file with incorrect (non-Write/abiword) MIME-type. (ticket #7860)
Chat-45: XMPP 1:1 chats work fine with a non-XO. ticket #7633 appears to be fixed.
Read-49: PDF files load in Read now (ticket #7615), but shared Read activities do not send the PDF file to XOs that join the activity.
Record-56: No unexpected behavior aside from a crash to the Home view that seemed isolated; will look into it.
Write-57: No unexpected behavior.


Build joyride-2263

XOs being used for the initial test were running the following:

Build: Joyride-2263
Firmware: CL1 Q2E12 Q2E
Libertas: 5.110.22.p17

XOs being used for the initial test were connected to the internet through School Wifi.

Telepathy: gabble
Jabber: schoolserver.media.mit.edu
essid: media lab 802.11
Channel: 11

Activities:

Browse-95: Viewing source results in a file with incorrect (non-Write/abiword) MIME-type. (ticket #7860)
Chat-45: XMPP 1:1 chats work fine with a non-XO. ticket #7633 appears to be fixed.
Read-48: PDF files do not load.
Record-56: No unexpected behavior.
Write-56: No unexpected behavior.

Has a bug in activity updater on clean install; "mkdir ~olpc/Activities" from terminal to workaround. Fixed in joyride-2266. Also: suspend may occur during long downloads; issue not yet fixed.

Build joyride-2230

Misc

screen rotate button makes XO screen go white, you have to reboot. ticket #7407
Read can't open PDFs ticket #7615
no, that's an unrelated bug that was fixed in an earlier build, please file a new ticket next time. I've fixed this for future builds with new gnome-vfs2 packages. -DanielDrake 21:51, 6 August 2008 (UTC)

Ran Software Update to get new activities.

Browse and Log Viewer do not appear to update properly -- SW Update keeps listing them as un-updated even after supposedly updating them (ticket #7494, ticket #7640). Workaround: delete the offending activities and re-run Software Update.

XOs being used for the smoketest are running the following:

Build: Joyride-2230
Firmware: CL1 Q2E12 Q2E
Libertas: 5.110.22.p17

XOs being used for the smoketest are connected to the internet through School Wifi.

Telepathy: gabble
Jabber: schoolserver.media.mit.edu
essid: media lab 802.11
Channel: 11

Collaboration: Chat-43

Sharing with Neighborhood works in both directions without visible issues (G02 starting the activity with W08 joining, and vice versa).

Collaboration: Browse-94

Shared bookmarks appear to work without issues.

Collaboration: Read-45

PDF file doesn't seem to transfer from "host" XO to the joining XO(s).

Collaboration: Record-56

XO(s) joining a shared Record activity freeze?

Collaboration: Write-55

Shared Write activity appears to work without issues.

(Tickets to bugs found will be added once the tickets are submitted.)

Build joyride-2140

Activities: Measure doesn't display properly -- the waveform area is grey, but the Sugar interface up top and the scrollbar on the right show properly. TamTamJam does not start.(ticket #7467 and ticket #7466 respectively.)

Image Transferring and Invite: Copying to the clipboard and Journal appears to work, however the image cannot be pasted from the clipboard to the Write activity, nor can it be pasted by using the Image menu. (File is named "Clipboard object: ." for some reason -- possibly connected? See ticket #7468) The second XO experienced no visible issues when invited to the Write activity, and both laptops were able to share the activity and see each others' changes.

Installing an Activity Bundle (Browse): Implode installs, but hangs when running; maybe same issue as with TamTamJam? (Running Browse-92.)

Not the same as TamTam. I mailed the Implode author with diagnosis info. It needs an update for new sugar/GTK+ API. Please test another activity instead, e.g. Distance (AcousticMeasure) -DanielDrake 17:35, 11 July 2008 (UTC)
Okay, redid this part of the test with Block Party, which seems to have downloaded, installed and run properly. -Charlie 14:05, 14 July 2008 (UTC)

Installing a Library Bundle (USB): Wikibooks-4.xol is not installed (is not present in /home/olpc/Library/) after clicking start in the Journal. Possible MIME-type issue? Copying Wikibooks-4.xol to /home/olpc/Library/ from the USB stick did not fix the problem.

Installing a Library Bundle (Browse): Bible-en.xol downloads, but is not installed (is not present in /home/olpc/Library/). Clicking 'Start' in the Journal does not do anything -- possibly a MIME-type issue? (ticket #7427, running Browse-92.)

7427 is unrelated, we need a new ticket -DanielDrake 17:35, 11 July 2008 (UTC)

Installing a Library Bundle (offline): Phyla PDF downloads; when started through Journal, Read starts but no document appears. (Running Browse-92.)

Transfer files to USB stick: Clipboard image does not load on other XO; probably related to results from Browse/Write sharing.

Update.1 builds

Build 713 for Ethiopia

  • Tested against open AP and school server
  • Collaboration over infrastructure (salut) was a bit unreliable, probably due to noisy RF environment
  • ticket #8379: Pretty boot does not work
  • No other problems found

-DanielDrake 23:18, 9 September 2008 (UTC)

Build 712 for Ethiopia

  • Tested against WEP AP.
  • Did all collaboration testing over simple mesh
  • Write defaults to DejaVu font, which does not have Amharic characters. Perhaps it should default to Abyssinica SIL on ethiopian laptops.
  • Did not test school server connectivity or filling NAND
  • No problems found otherwise (completed the rest of the smoke test in full)

-DanielDrake 02:25, 4 September 2008 (UTC)

Build 711 Q2e12 (8.1.2)

For this build I did some quick testing of sharing write, record, and chat between two laptops on simple mesh.

The only difference between this build and 709 below is a fix for the SD card. Should be no change in Wifi capabilities, sharing, or any individual activities functionality.

Specific tests for the bug fix can be found in the ECO check list for release:

For the per711-1, I did a cleaninstall (which is what they will need); boot up and checked for the new content.

Build 709 Q2E12

Startup:

  • Cleaninstall; added activities with the bundles directory (peru activities)
  • Connected to medialab 802.11, browsed the web
  • Connected to WPA (olpc), and connected to WEP (canopy), browsed the web

Activities:

  • Pippy, sequence to test out audio
  • Record, took pictures
  • TamTam - played a few quick sounds
  • Opened Turtle Art and Scratch
  • Copied an image from the browser to the clipboard and onto a write doc
  • Saved it; retrieved it from the journal

Sharing:

  • Two laptops shared the following via simple mesh properly:
    • Chat
    • Write
    • Record photos
    • Browser links

Some activities I shared with the neighborhood, some I used the private invitation.

Bundles

  • I downloaded Flipsticks from the web (Activities link, Testing link); it installed and loaded.
  • Ran it and closed it.

Build 708 Q2D16 (8.1.1 RC1)

Startup:

  • Connected by default to school mesh, was able to access an open AP (media lab 802.11), WEP (canopy), and WPA (olpc) fine.

Activities:

  • Measure: no problems
  • TamTam: see ticket #7159
  • Record: records/plays back properly, no problems.
  • Paint: resumes fine, no problems

Image transfer/invite:

  • No problems.

Activity Install:

  • Activity installed/ran from USB fine.
  • Activity downloaded/installed/ran from web fine.

Library Bundle Install:

  • Installed and opened fine from web.
  • Installed and opened fine from offline.

Playing .ogg file in Browse:

  • No problems.

USB transfer:

  • All activities resumed properly.

Chat:

  • Works properly both ways.

Distance:

  • Works properly both ways.

Journal stress-test:

  • Not tested

Suspend/Resume:

  • No problems encountered.

Build 706 Q2D14

Smoketest

Boot:

  • No bugs/errors encountered.
  • WEP/WPA: not tested

Activities:

  • Measure: fine
  • TamTamJam: fine, but took about 20-30 seconds to load.
  • Record-photo: saved fine, loaded fine
  • Record-video: saved fine, loaded and played fine
  • Record-audio: saved fine, loaded and played fine
  • Paint: drawing with the touchpad works fine, drawing with the pen-tablet works fine but response is a little jerky
  • Pippy: fine
  • Calculate: fine

Image Transferring and Invite:

  • No bugs/errors encountered.

Installing an Activity Bundle from USB Key:

  • No bugs/errors encountered.

Installing an Activity Bundle from the Web:

  • No bugs/errors encountered.

Installing a Library Bundle - Online:

  • No bugs/errors encountered.

Installing a Library Bundle - Offline:

  • No bugs/errors encountered.

Playing an .ogg file in Browse:

  • No bugs/errors encountered.

Transfer Files to USB stick:

  • No bugs/errors encountered.

Suspend/Resume:

  • No bugs/errors encountered.

Peru Build 703 Q2D16 (8.1.0, also known as "Update.1")

8.1.0 Release notes

Startup:

  • Boots fine.
  • Joins schoolserver by default.

Activities:

  • Measure/Medir: Fine
  • TamTamJam:
    • Takes about 20 seconds to start/resume.
    • The default key to start the drumset (/) is not in the position indicated by the keyboard -- instead it is the -/_ key that activates it.
  • Record/Grabar: Fine
  • Paint/Pintar: Fine
  • Wikipedia: Takes about 20 seconds to start/resume. (Expected)
  • Speak: Fine
  • Sudoku: Fine

Image Transferring and Invite:

  • Browse opens properly.
  • Invite works properly.
  • No issues.

Installing Activity from USB Key:

  • No issues.

Installing Activity from the Web:

  • No issues.

Installing a Library Bundle:

  • Online
    • .xol files downloaded, but while they are present in the journal they are not present in the clipboard, nor in /home/olpc/Library/ -- and thus do not load.
      • Which files are you downloading? The server needs to have the right mimetype set for the bundles to install.
  • Offline
    • Opens and downloads fine, however, the Biology (Biologia) pages and the Phyla PDF are in English -- shouldn't they be in Spanish on the Peru build?

Playing .ogg file in Browse:

  • No issues.

Transfer Files to USB Stick:

  • No issues.

Collaboration with Chat:

  • No issues.

Collaboration with Distance:

  • No issues.

Trying Different Connection Types:

  • No issues, XO started up and connected to the school server by default.

Suspend/Resume Due to Cover Close:

  • No issues.

Old test notes

Old Update.1 build notes

Firmware Release Notes

Personal tools
  • Log in
  • Login with OpenID
About OLPC
About the laptop
About the tablet
Projects
OLPC wiki
Toolbox
In other languages